Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't install X Window Server
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Oleg_Ponomaryov
n00b
n00b


Joined: 13 Jan 2014
Posts: 7

PostPosted: Sun Jan 26, 2014 4:41 pm    Post subject: Can't install X Window Server Reply with quote

I'm trying to install X on Gentoo using this guide https://wiki.gentoo.org/wiki/Xorg/Configuration, but when I use
Code:
startx

I get:
Code:
(EE) no screens found(EE)

My notebook is Dell Inspiron N7110 with Intel HD Graphics 3000 and NVidia GeForce 525m. After getting the error, I've installed NVidia drivers using this article https://wiki.gentoo.org/wiki/NVidia/nvidia-drivers, but nothing have changed. When I tried to use mesa-progs tools, I got:
Code:
couldn't open display

Please, help me to solve the problem!
My Xorg.0.log:
Code:
[  4265.046]
X.Org X Server 1.14.3
Release Date: 2013-09-12
[  4265.046] X Protocol Version 11, Revision 0
[  4265.046] Build Operating System: Linux 3.10.25-gentoo x86_64 Gentoo
[  4265.046] Current Operating System: Linux inspiron 3.10.25-gentoo #1 SMP Wed Jan 15 00:57:28 EET 2014 x86_64
[  4265.046] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-3.10.25-gentoo root=UUID=5fa85daf-3401-4a0a-a26b-ed302cbfc97c ro
[  4265.047] Build Date: 19 January 2014  06:57:28PM
[  4265.047] 
[  4265.047] Current version of pixman: 0.32.4
[  4265.047]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  4265.047] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  4265.048] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Jan 21 19:00:51 2014
[  4265.048] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  4265.048] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  4265.048] (==) No Layout section.  Using the first Screen section.
[  4265.048] (==) No screen section available. Using defaults.
[  4265.048] (**) |-->Screen "Default Screen Section" (0)
[  4265.048] (**) |   |-->Monitor "<default monitor>"
[  4265.048] (==) No device specified for screen "Default Screen Section".
   Using the first device section listed.
[  4265.048] (**) |   |-->Device "nvidia"
[  4265.048] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[  4265.049] (==) Automatically adding devices
[  4265.049] (==) Automatically enabling devices
[  4265.049] (==) Automatically adding GPU devices
[  4265.049] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[  4265.049]    Entry deleted from font path.
[  4265.049] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  4265.049]    Entry deleted from font path.
[  4265.049] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  4265.049]    Entry deleted from font path.
[  4265.049] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  4265.049]    Entry deleted from font path.
[  4265.049] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[  4265.049]    Entry deleted from font path.
[  4265.049] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[  4265.049]    Entry deleted from font path.
[  4265.049] (==) FontPath set to:
   
[  4265.049] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  4265.049] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  4265.049] (II) Loader magic: 0x7fcc00
[  4265.049] (II) Module ABI versions:
[  4265.049]    X.Org ANSI C Emulation: 0.4
[  4265.049]    X.Org Video Driver: 14.1
[  4265.049]    X.Org XInput driver : 19.1
[  4265.049]    X.Org Server Extension : 7.0
[  4265.050] (--) PCI:*(0:0:2:0) 8086:0116:1028:04c4 rev 9, Mem @ 0xf1400000/4194304, 0xe0000000/268435456, I/O @ 0x00005000/64
[  4265.050] (--) PCI: (0:1:0:0) 10de:0df5:1028:04c4 rev 161, Mem @ 0xf0000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/524288
[  4265.050] Initializing built-in extension Generic Event Extension
[  4265.050] Initializing built-in extension SHAPE
[  4265.050] Initializing built-in extension MIT-SHM
[  4265.050] Initializing built-in extension XInputExtension
[  4265.050] Initializing built-in extension XTEST
[  4265.050] Initializing built-in extension BIG-REQUESTS
[  4265.051] Initializing built-in extension SYNC
[  4265.051] Initializing built-in extension XKEYBOARD
[  4265.051] Initializing built-in extension XC-MISC
[  4265.051] Initializing built-in extension XINERAMA
[  4265.051] Initializing built-in extension XFIXES
[  4265.051] Initializing built-in extension RENDER
[  4265.051] Initializing built-in extension RANDR
[  4265.051] Initializing built-in extension COMPOSITE
[  4265.051] Initializing built-in extension DAMAGE
[  4265.051] Initializing built-in extension MIT-SCREEN-SAVER
[  4265.052] Initializing built-in extension DOUBLE-BUFFER
[  4265.052] Initializing built-in extension RECORD
[  4265.052] Initializing built-in extension DPMS
[  4265.052] Initializing built-in extension X-Resource
[  4265.052] Initializing built-in extension XVideo
[  4265.052] Initializing built-in extension XVideo-MotionCompensation
[  4265.052] Initializing built-in extension XFree86-VidModeExtension
[  4265.052] Initializing built-in extension XFree86-DGA
[  4265.052] Initializing built-in extension XFree86-DRI
[  4265.052] Initializing built-in extension DRI2
[  4265.053] (II) LoadModule: "glx"
[  4265.053] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  4265.214] (II) Module glx: vendor="NVIDIA Corporation"
[  4265.214]    compiled for 4.0.2, module version = 1.0.0
[  4265.214]    Module class: X.Org Server Extension
[  4265.214] (II) NVIDIA GLX Module  304.117  Tue Nov 26 21:45:09 PST 2013
[  4265.214] Loading extension GLX
[  4265.214] (II) LoadModule: "nvidia"
[  4265.214] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[  4265.215] (II) Module nvidia: vendor="NVIDIA Corporation"
[  4265.215]    compiled for 4.0.2, module version = 1.0.0
[  4265.215]    Module class: X.Org Video Driver
[  4265.215] (II) NVIDIA dlloader X Driver  304.117  Tue Nov 26 21:27:08 PST 2013
[  4265.215] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  4265.216] (--) using VT number 7

[  4265.219] (EE) No devices detected.
[  4265.219] (EE)
Fatal server error:
[  4265.219] (EE) no screens found(EE)
[  4265.219] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  4265.219] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  4265.219] (EE)
[/glsa]

My lspci:
Code:
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM67 Express Chipset Family LPC Controller (rev 05)
00:1f.2 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
00:1f.5 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 2 port SATA IDE Controller (rev 05)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 525M] (rev a1)
02:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
[/quote]
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42592
Location: 56N 3W

PostPosted: Sun Jan 26, 2014 6:19 pm    Post subject: Reply with quote

Oleg_Ponomaryov,

Your laptop has an Optimus Graphics system.
That means that the Intel Graphics can work alone, or the nVidia and Intel graphics can cooperate.
The other option, nVidia only, is designed to not work and your log shows
Code:
[  4265.214] (II) LoadModule: "nvidia"


Make the Intel graphics work first.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Oleg_Ponomaryov
n00b
n00b


Joined: 13 Jan 2014
Posts: 7

PostPosted: Sun Jan 26, 2014 11:07 pm    Post subject: Reply with quote

NeddySeagoon wrote:
Make the Intel graphics work first.

Thank you for the answer! I've installed Intel driver using this guide http://wiki.gentoo.org/wiki/Intel, but i still get the same error using startx.
Here is my new Xorg.0.log:
Code:
[  2651.621]
X.Org X Server 1.14.3
Release Date: 2013-09-12
[  2651.621] X Protocol Version 11, Revision 0
[  2651.621] Build Operating System: Linux 3.10.25-gentoo x86_64 Gentoo
[  2651.621] Current Operating System: Linux inspiron 3.10.25-gentoo #1 SMP Wed Jan 22 15:32:45 EET 2014 x86_64
[  2651.621] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-3.10.25-gentoo root=UUID=5fa85daf-3401-4a0a-a26b-ed302cbfc97c ro
[  2651.622] Build Date: 19 January 2014  06:57:28PM
[  2651.623] 
[  2651.623] Current version of pixman: 0.32.4
[  2651.624]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  2651.624] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2651.624] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Jan 26 21:58:26 2014
[  2651.625] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  2651.625] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2651.625] (==) No Layout section.  Using the first Screen section.
[  2651.625] (==) No screen section available. Using defaults.
[  2651.625] (**) |-->Screen "Default Screen Section" (0)
[  2651.625] (**) |   |-->Monitor "<default monitor>"
[  2651.625] (==) No device specified for screen "Default Screen Section".
   Using the first device section listed.
[  2651.625] (**) |   |-->Device "intel i985"
[  2651.625] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[  2651.625] (==) Automatically adding devices
[  2651.625] (==) Automatically enabling devices
[  2651.625] (==) Automatically adding GPU devices
[  2651.625] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  2651.625]    Entry deleted from font path.
[  2651.625] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  2651.625]    Entry deleted from font path.
[  2651.625] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  2651.625]    Entry deleted from font path.
[  2651.625] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[  2651.625]    Entry deleted from font path.
[  2651.625]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[  2651.625] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[  2651.625]    Entry deleted from font path.
[  2651.625]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[  2651.625] (==) FontPath set to:
   /usr/share/fonts/misc/
[  2651.625] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  2651.625] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  2651.625] (II) Loader magic: 0x7fcc00
[  2651.625] (II) Module ABI versions:
[  2651.625]    X.Org ANSI C Emulation: 0.4
[  2651.625]    X.Org Video Driver: 14.1
[  2651.625]    X.Org XInput driver : 19.1
[  2651.625]    X.Org Server Extension : 7.0
[  2651.626] (--) PCI:*(0:0:2:0) 8086:0116:1028:04c4 rev 9, Mem @ 0xf1400000/4194304, 0xe0000000/268435456, I/O @ 0x00005000/64
[  2651.626] (--) PCI: (0:1:0:0) 10de:0df5:1028:04c4 rev 161, Mem @ 0xf0000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/524288
[  2651.627] Initializing built-in extension Generic Event Extension
[  2651.627] Initializing built-in extension SHAPE
[  2651.627] Initializing built-in extension MIT-SHM
[  2651.627] Initializing built-in extension XInputExtension
[  2651.627] Initializing built-in extension XTEST
[  2651.627] Initializing built-in extension BIG-REQUESTS
[  2651.627] Initializing built-in extension SYNC
[  2651.627] Initializing built-in extension XKEYBOARD
[  2651.627] Initializing built-in extension XC-MISC
[  2651.628] Initializing built-in extension XINERAMA
[  2651.628] Initializing built-in extension XFIXES
[  2651.628] Initializing built-in extension RENDER
[  2651.628] Initializing built-in extension RANDR
[  2651.628] Initializing built-in extension COMPOSITE
[  2651.628] Initializing built-in extension DAMAGE
[  2651.628] Initializing built-in extension MIT-SCREEN-SAVER
[  2651.628] Initializing built-in extension DOUBLE-BUFFER
[  2651.628] Initializing built-in extension RECORD
[  2651.628] Initializing built-in extension DPMS
[  2651.629] Initializing built-in extension X-Resource
[  2651.629] Initializing built-in extension XVideo
[  2651.629] Initializing built-in extension XVideo-MotionCompensation
[  2651.629] Initializing built-in extension XFree86-VidModeExtension
[  2651.629] Initializing built-in extension XFree86-DGA
[  2651.629] Initializing built-in extension XFree86-DRI
[  2651.629] Initializing built-in extension DRI2
[  2651.629] (II) LoadModule: "glx"
[  2651.629] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  2651.645] (II) Module glx: vendor="X.Org Foundation"
[  2651.645]    compiled for 1.14.3, module version = 1.0.0
[  2651.645]    ABI class: X.Org Server Extension, version 7.0
[  2651.645] (==) AIGLX enabled
[  2651.645] Loading extension GLX
[  2651.645] (II) LoadModule: "inteli985"
[  2651.646] (WW) Warning, couldn't open module inteli985
[  2651.646] (II) UnloadModule: "inteli985"
[  2651.646] (II) Unloading inteli985
[  2651.646] (EE) Failed to load module "inteli985" (module does not exist, 0)
[  2651.646] (EE) No drivers available.
[  2651.646] (EE)
Fatal server error:
[  2651.646] (EE) no screens found(EE)
[  2651.646] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  2651.647] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  2651.647] (EE)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42592
Location: 56N 3W

PostPosted: Sun Jan 26, 2014 11:35 pm    Post subject: Reply with quote

Oleg_Ponomaryov,

Please post the output of
Code:
emerge --info
so we can check some of your settings.

Code:
[  2651.646] (WW) Warning, couldn't open module inteli985
looks odd.
The driver is just called intel.

It looks like you have told Xorg to load inteli985, which does not exist
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Oleg_Ponomaryov
n00b
n00b


Joined: 13 Jan 2014
Posts: 7

PostPosted: Fri Jan 31, 2014 2:02 pm    Post subject: Reply with quote

NeddySeagoon wrote:
Oleg_Ponomaryov,

Please post the output of
Code:
emerge --info
so we can check some of your settings.

Code:
[  2651.646] (WW) Warning, couldn't open module inteli985
looks odd.
The driver is just called intel.

It looks like you have told Xorg to load inteli985, which does not exist

I tried using "intel", but situation was the same. I also tried to install Bumblebee to make Nvidia Optimus work, but it didn't help. Maybe I'm doing something wrong, cause I have no experience of working with Gentoo, but I can't understand, where is my fault.
Here is my "emerge --info":
Code:
Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.17, 3.10.25-gentoo x86_64)
=================================================================
System uname: Linux-3.10.25-gentoo-x86_64-Intel-R-_Core-TM-_i5-2410M_CPU_@_2.30GHz-with-gentoo-2.2
KiB Mem:     3967980 total,   3697076 free
KiB Swap:    6143996 total,   6143996 free
Timestamp of tree: Sat, 18 Jan 2014 19:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.5-r3, 3.3.2-r2
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.kiev.ua/ftp/ ftp://gentoo.kiev.ua/ rsync://gentoo.kiev.ua/gentoo-distfiles http://gentoo.iteam.net.ua/ http://portage.org.ua/ ftp://portage.org.ua/"
LANG="en_US.iso88591"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.ua.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 bbswitch berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gdbm gif gpm iconv ipv6 jpeg jpeg2k kde kipi lame lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qt3support qt4 readline sdl semantic-desktop session sna spell sse sse2 ssl startup-notification svg taglib tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="mouse keyboard joystick endev synapdics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en ru uk" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="intel nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Fri Jan 31, 2014 6:05 pm    Post subject: Reply with quote

What did you put into your xorg.conf ?
It's most likely wrong, but seeing it would clear up a few things.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42592
Location: 56N 3W

PostPosted: Fri Jan 31, 2014 9:48 pm    Post subject: Reply with quote

Oleg_Ponomaryov,

Your emerge --info is correct at far ax Xorg goes
If yoy don't have an xorg.cony file, the log does not mention one, post any files in
Code:
[  2651.625] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  2651.625] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
that you have created or edited

I suspect you have a fragment

Code:

Section "Device"
        Identifier ...
        Driver "inteli985"
        ...


That "inteli985" should be "intel"
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum