Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XFCE4 and nVidia long loading X
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
vhristev
n00b
n00b


Joined: 08 Jan 2014
Posts: 22

PostPosted: Sun Jan 26, 2014 8:38 am    Post subject: XFCE4 and nVidia long loading X Reply with quote

Hello ,

I install nVidia drivers which i download from nVidia and when i start X console or with XDM no matter it loads a lot .
I found in X logs that :
####### HERE IS WHERE I WAIT A LOT #####
[ 74.660] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 74.661] (**) NVIDIA(0): Enabling 2D acceleration
[ 92.104] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[ 92.104] (II) NVIDIA(GPU-0): stereo.


######## X starts #######

It stop on Enabling 2D acceleration then after some time proceed but that waiting I do not from where it comes.

I tried with Nvidia drivers 331.38.run but GLX didn't work
Then i reinstall lower driver 325.15 and now GLX is working but same long X loading. With that driver GLX direct rendering is Yes and "glxgears" are working 60 FPS
With Gentoo nvidia drivers X didn't start at all i'm sure i didn't do something correct but i want to see from where is that long delay.

On that laptop i had Debian and Ubuntu and didn't have that long loading.

Any suggestions how to debug it or to try Gentoo nvidia drivers and follow the Wiki for nVidia.

System info:

Gentoo Base System release 2.2
X.Org X Server 1.14.3

make.conf
Code:


FLAGS="-O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="bindist mmx sse sse2"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
MAKEOPTS="-j8"

GENTOO_MIRRORS="http://mirrors.telepoint.bg/gentoo/"
INPUT_DEVICES="evdev synaptics"
## (For nVidia cards)
VIDEO_CARDS="nvidia"
USE="-gnome -kde -minimal -qt4 xfce dbus jpeg lock session startup-notification thunar udev X xinerama"


xorg.conf

Code:

hristev ~ # cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 325.15  (buildmeister@swio-display-x64-rhel04-03)  Wed Jul 31 19:04:27 PDT 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection



Xorg.0.log

Code:

[    74.074]
X.Org X Server 1.14.3
Release Date: 2013-09-12
[    74.099] X Protocol Version 11, Revision 0
[    74.108] Build Operating System: Linux 3.10.25-gentoo x86_64 Gentoo
[    74.118] Current Operating System: Linux hristev 3.10.25-gentoo #1 SMP Mon Jan 20 00:12:57 EET 2014 x86_64
[    74.119] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-3.10.25-gentoo root=UUID=8d327d54-d978-45c0-a826-8dba0b25c093 ro
[    74.140] Build Date: 20 January 2014  12:45:56AM
[    74.151]
[    74.162] Current version of pixman: 0.32.4
[    74.185]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    74.185] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    74.236] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Jan 26 10:26:42 2014
[    74.249] (==) Using config file: "/etc/X11/xorg.conf"
[    74.263] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    74.263] (==) ServerLayout "Layout0"
[    74.263] (**) |-->Screen "Screen0" (0)
[    74.263] (**) |   |-->Monitor "Monitor0"
[    74.263] (**) |   |-->Device "Device0"
[    74.263] (**) |-->Input Device "Keyboard0"
[    74.263] (**) |-->Input Device "Mouse0"
[    74.263] (==) Automatically adding devices
[    74.263] (==) Automatically enabling devices
[    74.263] (==) Automatically adding GPU devices
[    74.263] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    74.263]    Entry deleted from font path.
[    74.263] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    74.263]    Entry deleted from font path.
[    74.263] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    74.263]    Entry deleted from font path.
[    74.263] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    74.263]    Entry deleted from font path.
[    74.263]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    74.263] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    74.263]    Entry deleted from font path.
[    74.263]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    74.263] (==) FontPath set to:
   /usr/share/fonts/misc/
[    74.263] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    74.263] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    74.263] (WW) Disabling Keyboard0
[    74.263] (WW) Disabling Mouse0
[    74.263] (II) Loader magic: 0x7fec20
[    74.263] (II) Module ABI versions:
[    74.263]    X.Org ANSI C Emulation: 0.4
[    74.263]    X.Org Video Driver: 14.1
[    74.263]    X.Org XInput driver : 19.1
[    74.263]    X.Org Server Extension : 7.0
[    74.264] (--) PCI:*(0:1:0:0) 10de:0dfc:1028:0534 rev 161, Mem @ 0xf5000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[    74.278] Initializing built-in extension Generic Event Extension
[    74.292] Initializing built-in extension SHAPE
[    74.305] Initializing built-in extension MIT-SHM
[    74.319] Initializing built-in extension XInputExtension
[    74.332] Initializing built-in extension XTEST
[    74.345] Initializing built-in extension BIG-REQUESTS
[    74.358] Initializing built-in extension SYNC
[    74.371] Initializing built-in extension XKEYBOARD
[    74.383] Initializing built-in extension XC-MISC
[    74.395] Initializing built-in extension XINERAMA
[    74.406] Initializing built-in extension XFIXES
[    74.418] Initializing built-in extension RENDER
[    74.429] Initializing built-in extension RANDR
[    74.440] Initializing built-in extension COMPOSITE
[    74.451] Initializing built-in extension DAMAGE
[    74.462] Initializing built-in extension MIT-SCREEN-SAVER
[    74.473] Initializing built-in extension DOUBLE-BUFFER
[    74.485] Initializing built-in extension RECORD
[    74.496] Initializing built-in extension DPMS
[    74.507] Initializing built-in extension X-Resource
[    74.518] Initializing built-in extension XVideo
[    74.529] Initializing built-in extension XVideo-MotionCompensation
[    74.541] Initializing built-in extension XFree86-VidModeExtension
[    74.552] Initializing built-in extension XFree86-DGA
[    74.563] Initializing built-in extension XFree86-DRI
[    74.573] Initializing built-in extension DRI2
[    74.573] (II) LoadModule: "glx"
[    74.573] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    74.580] (II) Module glx: vendor="NVIDIA Corporation"
[    74.580]    compiled for 4.0.2, module version = 1.0.0
[    74.580]    Module class: X.Org Server Extension
[    74.580] (II) NVIDIA GLX Module  325.15  Wed Jul 31 18:12:00 PDT 2013
[    74.591] Loading extension GLX
[    74.591] (II) LoadModule: "nvidia"
[    74.591] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[    74.600] (II) Module nvidia: vendor="NVIDIA Corporation"
[    74.600]    compiled for 4.0.2, module version = 1.0.0
[    74.600]    Module class: X.Org Video Driver
[    74.600] (II) NVIDIA dlloader X Driver  325.15  Wed Jul 31 17:50:57 PDT 2013
[    74.601] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    74.601] (--) using VT number 7

[    74.654] (II) Loading sub module "fb"
[    74.654] (II) LoadModule: "fb"
[    74.654] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    74.655] (II) Module fb: vendor="X.Org Foundation"
[    74.655]    compiled for 1.14.3, module version = 1.0.0
[    74.655]    ABI class: X.Org ANSI C Emulation, version 0.4
[    74.655] (WW) Unresolved symbol: fbGetGCPrivateKey
[    74.655] (II) Loading sub module "wfb"
[    74.655] (II) LoadModule: "wfb"
[    74.655] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[    74.657] (II) Module wfb: vendor="X.Org Foundation"
[    74.657]    compiled for 1.14.3, module version = 1.0.0
[    74.657]    ABI class: X.Org ANSI C Emulation, version 0.4
[    74.657] (II) Loading sub module "shadow"
[    74.657] (II) LoadModule: "shadow"
[    74.657] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[    74.658] (II) Module shadow: vendor="X.Org Foundation"
[    74.658]    compiled for 1.14.3, module version = 1.1.0
[    74.658]    ABI class: X.Org ANSI C Emulation, version 0.4
[    74.658] (II) Loading sub module "ramdac"
[    74.658] (II) LoadModule: "ramdac"
[    74.658] (II) Module "ramdac" already built-in
[    74.660] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    74.660] (==) NVIDIA(0): RGB weight 888
[    74.660] (==) NVIDIA(0): Default visual is TrueColor
####### HERE IS WHERE I WAIT A LOT #####
[b][    74.660] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    74.661] (**) NVIDIA(0): Enabling 2D acceleration
[    92.104] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[    92.104] (II) NVIDIA(GPU-0):     stereo.[/b]

######## X starts #######
[    92.104] (II) NVIDIA(0): NVIDIA GPU NVS 5200M (GF108) at PCI:1:0:0 (GPU-0)
[    92.104] (--) NVIDIA(0): Memory: 1048576 kBytes
[    92.104] (--) NVIDIA(0): VideoBIOS: 70.08.a8.00.8d
[    92.104] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    92.107] (--) NVIDIA(0): Valid display device(s) on NVS 5200M at PCI:1:0:0
[    92.107] (--) NVIDIA(0):     CRT-0
[    92.107] (--) NVIDIA(0):     LGD (DFP-0) (boot, connected)
[    92.107] (--) NVIDIA(0):     DFP-1
[    92.107] (--) NVIDIA(0):     DFP-2
[    92.107] (--) NVIDIA(0):     DFP-3
[    92.107] (--) NVIDIA(0):     DFP-4
[    92.107] (--) NVIDIA(0):     DFP-5
[    92.107] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[    92.107] (--) NVIDIA(0): LGD (DFP-0): 330.0 MHz maximum pixel clock
[    92.107] (--) NVIDIA(0): LGD (DFP-0): Internal Dual Link LVDS
[    92.107] (--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
[    92.107] (--) NVIDIA(0): DFP-1: Internal Single Link TMDS
[    92.107] (--) NVIDIA(0): DFP-2: 165.0 MHz maximum pixel clock
[    92.107] (--) NVIDIA(0): DFP-2: Internal Single Link TMDS
[    92.107] (--) NVIDIA(0): DFP-3: 165.0 MHz maximum pixel clock
[    92.107] (--) NVIDIA(0): DFP-3: Internal Single Link TMDS
[    92.107] (--) NVIDIA(0): DFP-4: 480.0 MHz maximum pixel clock
[    92.107] (--) NVIDIA(0): DFP-4: Internal DisplayPort
[    92.107] (--) NVIDIA(0): DFP-5: 480.0 MHz maximum pixel clock
[    92.107] (--) NVIDIA(0): DFP-5: Internal DisplayPort
[    92.107] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[    92.107] (**) NVIDIA(0):     device LGD (DFP-0) (Using EDID frequencies has been
[    92.107] (**) NVIDIA(0):     enabled on all display devices.)
[    92.107] (==) NVIDIA(0):
[    92.107] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[    92.107] (==) NVIDIA(0):     will be used as the requested mode.
[    92.107] (==) NVIDIA(0):
[    92.108] (II) NVIDIA(0): Validated MetaModes:
[    92.108] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select{}"
[    92.108] (II) NVIDIA(0): Virtual screen size determined to be 1600 x 900
[    93.392] (--) NVIDIA(0): DPI set to (131, 134); computed from "UseEdidDpi" X config
[    93.392] (--) NVIDIA(0):     option
[    93.392] (--) Depth 24 pixmap format is 32 bpp
[    93.392] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[    93.392] (II) NVIDIA:     access.
[    93.396] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[    93.396] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[    93.396] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[    93.396] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[    93.396] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[    93.396] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[    93.396] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[    93.396] (II) NVIDIA(0):     Config Options in the README.
[    93.399] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select{}"
[    93.688] Loading extension NV-GLX
[    93.743] (==) NVIDIA(0): Disabling shared memory pixmaps
[    93.743] (==) NVIDIA(0): Backing store disabled
[    93.743] (==) NVIDIA(0): Silken mouse enabled
[    93.744] (**) NVIDIA(0): DPMS enabled
[    93.744] Loading extension NV-CONTROL
[    93.744] Loading extension XINERAMA
[    93.745] (II) Loading sub module "dri2"
[    93.745] (II) LoadModule: "dri2"
[    93.745] (II) Module "dri2" already built-in
[    93.745] (II) NVIDIA(0): [DRI2] Setup complete
[    93.745] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    93.745] (--) RandR disabled
[    93.750] (II) Initializing extension GLX
[    93.803] (II) config/udev: Adding input device Power Button (/dev/input/event6)
[    93.803] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    93.803] (II) LoadModule: "evdev"
[    93.803] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[    93.804] (II) Module evdev: vendor="X.Org Foundation"
[    93.804]    compiled for 1.14.3, module version = 2.8.1
[    93.804]    Module class: X.Org XInput Driver
[    93.804]    ABI class: X.Org XInput driver, version 19.1
[    93.804] (II) Using input driver 'evdev' for 'Power Button'
[    93.804] (**) Power Button: always reports core events
[    93.804] (**) evdev: Power Button: Device: "/dev/input/event6"
[    93.804] (--) evdev: Power Button: Vendor 0 Product 0x1
[    93.804] (--) evdev: Power Button: Found keys
[    93.804] (II) evdev: Power Button: Configuring as keyboard
[    93.804] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input6/event6"
[    93.804] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    93.804] (**) Option "xkb_rules" "evdev"
[    93.804] (**) Option "xkb_model" "pc104"
[    93.804] (**) Option "xkb_layout" "us"
[    93.821] (II) config/udev: Adding input device Video Bus (/dev/input/event7)
[    93.821] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[    93.821] (II) Using input driver 'evdev' for 'Video Bus'
[    93.821] (**) Video Bus: always reports core events
[    93.821] (**) evdev: Video Bus: Device: "/dev/input/event7"
[    93.821] (--) evdev: Video Bus: Vendor 0 Product 0x6
[    93.821] (--) evdev: Video Bus: Found keys
[    93.821] (II) evdev: Video Bus: Configuring as keyboard
[    93.821] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:15/LNXVIDEO:00/input/input7/event7"
[    93.821] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[    93.821] (**) Option "xkb_rules" "evdev"
[    93.821] (**) Option "xkb_model" "pc104"
[    93.821] (**) Option "xkb_layout" "us"
[    93.821] (II) config/udev: Adding input device Power Button (/dev/input/event4)
[    93.821] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    93.821] (II) Using input driver 'evdev' for 'Power Button'
[    93.821] (**) Power Button: always reports core events
[    93.821] (**) evdev: Power Button: Device: "/dev/input/event4"
[    93.821] (--) evdev: Power Button: Vendor 0 Product 0x1
[    93.821] (--) evdev: Power Button: Found keys
[    93.821] (II) evdev: Power Button: Configuring as keyboard
[    93.821] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input4/event4"
[    93.821] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 8)
[    93.821] (**) Option "xkb_rules" "evdev"
[    93.821] (**) Option "xkb_model" "pc104"
[    93.821] (**) Option "xkb_layout" "us"
[    93.822] (II) config/udev: Adding input device Lid Switch (/dev/input/event3)
[    93.822] (II) No input driver specified, ignoring this device.
[    93.822] (II) This device may have been added with another device file.
[    93.822] (II) config/udev: Adding input device Sleep Button (/dev/input/event5)
[    93.822] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[    93.822] (II) Using input driver 'evdev' for 'Sleep Button'
[    93.822] (**) Sleep Button: always reports core events
[    93.822] (**) evdev: Sleep Button: Device: "/dev/input/event5"
[    93.822] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[    93.822] (--) evdev: Sleep Button: Found keys
[    93.822] (II) evdev: Sleep Button: Configuring as keyboard
[    93.822] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input5/event5"
[    93.822] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 9)
[    93.822] (**) Option "xkb_rules" "evdev"
[    93.822] (**) Option "xkb_model" "pc104"
[    93.822] (**) Option "xkb_layout" "us"
[    93.822] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[    93.822] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    93.822] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[    93.822] (**) AT Translated Set 2 keyboard: always reports core events
[    93.822] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[    93.822] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[    93.822] (--) evdev: AT Translated Set 2 keyboard: Found keys
[    93.822] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[    93.822] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[    93.822] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 10)
[    93.822] (**) Option "xkb_rules" "evdev"
[    93.822] (**) Option "xkb_model" "pc104"
[    93.822] (**) Option "xkb_layout" "us"
[    93.822] (II) config/udev: Adding input device DualPoint Stick (/dev/input/event1)
[    93.822] (**) DualPoint Stick: Applying InputClass "evdev pointer catchall"
[    93.822] (II) Using input driver 'evdev' for 'DualPoint Stick'
[    93.822] (**) DualPoint Stick: always reports core events
[    93.823] (**) evdev: DualPoint Stick: Device: "/dev/input/event1"
[    93.823] (--) evdev: DualPoint Stick: Vendor 0x2 Product 0x8
[    93.823] (--) evdev: DualPoint Stick: Found 3 mouse buttons
[    93.823] (--) evdev: DualPoint Stick: Found relative axes
[    93.823] (--) evdev: DualPoint Stick: Found x and y relative axes
[    93.823] (II) evdev: DualPoint Stick: Configuring as mouse
[    93.823] (**) evdev: DualPoint Stick: YAxisMapping: buttons 4 and 5
[    93.823] (**) evdev: DualPoint Stick: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    93.823] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input1/event1"
[    93.823] (II) XINPUT: Adding extended input device "DualPoint Stick" (type: MOUSE, id 11)
[    93.823] (II) evdev: DualPoint Stick: initialized for relative axes.
[    93.823] (**) DualPoint Stick: (accel) keeping acceleration scheme 1
[    93.823] (**) DualPoint Stick: (accel) acceleration profile 0
[    93.823] (**) DualPoint Stick: (accel) acceleration factor: 2.000
[    93.823] (**) DualPoint Stick: (accel) acceleration threshold: 4
[    93.823] (II) config/udev: Adding input device DualPoint Stick (/dev/input/mouse0)
[    93.823] (II) No input driver specified, ignoring this device.
[    93.823] (II) This device may have been added with another device file.
[    93.823] (II) config/udev: Adding input device AlpsPS/2 ALPS DualPoint TouchPad (/dev/input/event2)
[    93.823] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "evdev touchpad catchall"
[    93.823] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "touchpad catchall"
[    93.823] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "Default clickpad buttons"
[    93.823] (II) LoadModule: "synaptics"
[    93.823] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[    93.824] (II) Module synaptics: vendor="X.Org Foundation"
[    93.824]    compiled for 1.14.3, module version = 1.7.1
[    93.824]    Module class: X.Org XInput Driver
[    93.824]    ABI class: X.Org XInput driver, version 19.1
[    93.824] (II) Using input driver 'synaptics' for 'AlpsPS/2 ALPS DualPoint TouchPad'
[    93.824] (**) AlpsPS/2 ALPS DualPoint TouchPad: always reports core events
[    93.824] (**) Option "Device" "/dev/input/event2"
[    94.060] (II) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: ignoring touch events for semi-multitouch device
[    94.060] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: x-axis range 0 - 2000 (res 0)
[    94.060] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: y-axis range 0 - 1400 (res 0)
[    94.060] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: pressure range 0 - 127
[    94.060] (II) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: device does not report finger width.
[    94.060] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: buttons: left right middle double triple
[    94.060] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: Vendor 0x2 Product 0x8
[    94.060] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: invalid finger width range.  defaulting to 0 - 15
[    94.060] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: touchpad found
[    94.060] (**) AlpsPS/2 ALPS DualPoint TouchPad: always reports core events
[    94.160] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input2/event2"
[    94.160] (II) XINPUT: Adding extended input device "AlpsPS/2 ALPS DualPoint TouchPad" (type: TOUCHPAD, id 12)
[    94.160] (**) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    94.160] (**) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: (accel) MaxSpeed is now 1.75
[    94.160] (**) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: (accel) AccelFactor is now 0.082
[    94.160] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) keeping acceleration scheme 1
[    94.160] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration profile 1
[    94.160] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration factor: 2.000
[    94.160] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration threshold: 4
[    94.160] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: touchpad found
[    94.160] (II) config/udev: Adding input device AlpsPS/2 ALPS DualPoint TouchPad (/dev/input/mouse1)
[    94.160] (**) AlpsPS/2 ALPS DualPoint TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
[    94.161] (II) config/udev: Adding input device Dell WMI hotkeys (/dev/input/event8)
[    94.161] (**) Dell WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[    94.161] (II) Using input driver 'evdev' for 'Dell WMI hotkeys'
[    94.161] (**) Dell WMI hotkeys: always reports core events
[    94.161] (**) evdev: Dell WMI hotkeys: Device: "/dev/input/event8"
[    94.161] (--) evdev: Dell WMI hotkeys: Vendor 0 Product 0
[    94.161] (--) evdev: Dell WMI hotkeys: Found keys
[    94.161] (II) evdev: Dell WMI hotkeys: Configuring as keyboard
[    94.161] (**) Option "config_info" "udev:/sys/devices/virtual/input/input8/event8"
[    94.161] (II) XINPUT: Adding extended input device "Dell WMI hotkeys" (type: KEYBOARD, id 13)
[    94.161] (**) Option "xkb_rules" "evdev"
[    94.161] (**) Option "xkb_model" "pc104"
[    94.161] (**) Option "xkb_layout" "us"
[    94.352] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[    94.352] (II) NVIDIA(GPU-0):     stereo.
[    94.354] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[    94.354] (II) NVIDIA(GPU-0):     stereo.
[    94.381] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[    94.381] (II) NVIDIA(GPU-0):     stereo.


BR
Valentin
_________________
Being lazy means being smart
Back to top
View user's profile Send private message
vhristev
n00b
n00b


Joined: 08 Jan 2014
Posts: 22

PostPosted: Mon Jan 27, 2014 9:26 am    Post subject: Reply with quote

Hello ,

I'm still experience that behaviour no idea why X start so slow ( its from Nvidia ) .

Any ideas how I can debug it.
_________________
Being lazy means being smart
Back to top
View user's profile Send private message
epsilon72
Guru
Guru


Joined: 20 Sep 2007
Posts: 568

PostPosted: Mon Jan 27, 2014 1:31 pm    Post subject: Reply with quote

You have
Code:
VIDEO_CARDS="nvidia"

in your make.conf but you also say that you downloaded and installed nvidia's driver package from their website. You should not need to do both.
I recommend you uninstall the downloaded nvidia driver package and then follow Gentoo's nvidia guide: http://wiki.gentoo.org/wiki/NVidia/nvidia-drivers
Back to top
View user's profile Send private message
vhristev
n00b
n00b


Joined: 08 Jan 2014
Posts: 22

PostPosted: Mon Jan 27, 2014 3:34 pm    Post subject: Reply with quote

Hello ,

Found the issue. I compile the kernel with "High Resolution Time Support"

Code:

CONFIG_HIGH_RES_TIMERS:                                                                                                                  │ 
  │                                                                                                                                          │ 
  │ This option enables high resolution timer support. If your                                                                               │ 
  │ hardware is not capable then this option only increases                                                                                  │ 
  │ the size of the kernel image.                                                                                                            │ 
  │                                                                                                                                          │ 
  │ Symbol: HIGH_RES_TIMERS [=y]                                                                                                             │ 
  │ Type  : boolean                                                                                                                          │ 
  │ Prompt: High Resolution Timer Support                                                                                                    │ 
  │   Location:                                                                                                                              │ 
  │     -> General setup                                                                                                                     │ 
  │       -> Timers subsystem                                                                                                                │ 
  │   Defined at kernel/time/Kconfig:145                                                                                                     │ 
  │   Depends on: !ARCH_USES_GETTIMEOFFSET [=n] && GENERIC_CLOCKEVENTS [=y]                                                                  │ 
  │   Selects: TICK_ONESHOT [=y]                                                                                                             │ 
  │   Selected by: TILE_NET [=n] && NETDEVICES [=y] && ETHERNET [=y] && TILE && TILEGX     


"nvidia" is gone from make file i put it there when i'm trying make it work with Gentoo nvidia drivers.

Now everything is loading as speed of light.

I found that when I compile my VMWARE modules. This weekend i will switch to my new SSD so I plan to do everything from scratch.

When I start installing gentoo with "gentoo-minimal" I grab the kernel config from gentoo-minimal I used "zcat /proc/config.gz > /usr/src/linux/kernel config path" and I compile it that way. Maybe that was the problem I didn't spend some time tweaking my kernel. In 99% of the cases i use generic full kernel support because i can start that system on any hardware.

When i migrate i will find some good Gentoo on laptop howto and spend some time reading.

Thanks for your advice
_________________
Being lazy means being smart
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum