Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bluetooth fails to connect.
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message

Joined: 30 Jan 2005
Posts: 486
Location: Klamath Falls, Jefferson, USA, North America, Midgarth

PostPosted: Thu Jan 23, 2014 11:48 pm    Post subject: Bluetooth fails to connect. Reply with quote

Hi peeps. I've just picked up a usb bluetooth dongle and a pair of headphones.

Been following the wiki.

I'm fine until I try to connect, then I get :

[nqs@tablet]  OK % bluez-test-input connect FC:58:FA:39:38:F1                                                              2014-01-23-15:38:50
Traceback (most recent call last):
  File "/usr/bin/bluez-test-input", line 42, in <module>
  File "/usr/lib64/python2.7/site-packages/dbus/", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib64/python2.7/site-packages/dbus/", line 145, in __call__
  File "/usr/lib64/python2.7/site-packages/dbus/", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.bluez.Error.NotSupported: Operation is not supported
zsh: exit 1     bluez-test-input connect FC:58:FA:39:38:F1
~ on terminal pts/0, Command #1068
[nqs@tablet]  FAIL %

running as root give same result.

I thought, based upon error, it was a python mis-match, so I ran python-updater, no changes to bluez. Vhen I google lines from the error message, I get back way to much "noise".

for starts, is the problem Bluez, python, dbus, or ...?

I tried unmasking bluez-5.12, but the build fails, and I'm not in favor of messing with it if I can use a stable build

How can I get my 'phones to connect?

These opinions are mine, mine I say! Piss off and get your own.

As I see it -- An irregular blog, Improved with new location

To delete French language packs from system use 'sudo rm -fr /'
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum