Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to get international keys working on mac alu keyboard
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Wed Jan 22, 2014 10:36 pm    Post subject: Unable to get international keys working on mac alu keyboard Reply with quote

hi all,
I've been struggling a bit, but didn't really care too much about it because, you know, english.
But I've come across a friend of mine who's got the same problem on Gentoo, and asked me for help.. and in turn I'm asking here to see if anyone knows a solution for this.

First of all, UK international was working fine without any problems, until one day it suddenly decided to stop working after an upgrade.

I'm using XFCE and the keyboard is a classic USB Mac Alu UK
(this one: http://blog.ilovemac.com.ua/wp-content/uploads/2013/03/Wired-Keyboard-Aluminium_6.jpeg)
[edit] The correct keyboard layout is the following:
http://images.esellerpro.com/2477/I/640/424/MB110B-1.jpg

system-wide the configuration for the keyboard is set to be:
Code:
# cat /etc/conf.d/keymaps | grep ^[^#]
keymap="uk"
windowkeys="YES"
extended_keymaps=""
dumpkeys_charset=""
fix_euro="NO"


and within XFCE4 it's set to be English (UK, Macintosh International) with model set to Apple Aluminum Keyboard (ISO)

Even with this, combos e.g. AltGR+'+e is not outputting é, nor any other combination for any other international character, works.

Any idea what's wrong?
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom


Last edited by Peach on Fri Jan 24, 2014 12:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Wed Jan 22, 2014 10:43 pm    Post subject: Reply with quote

Well, in X /etc/conf.d/keymaps doesn't really matter.

Not sure what your desktop applet of choice actually does, so check:
- 'setxkbmap -print'
- xserver log for what rules are getting applied to the keyboard
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Thu Jan 23, 2014 10:10 am    Post subject: Reply with quote

Consider that I've never configured the keyboard under X, and always let XFCE take care of it.

VoidMage wrote:
Not sure what your desktop applet of choice actually does, so check:
- 'setxkbmap -print'
- xserver log for what rules are getting applied to the keyboard


Code:
$ setxkbmap -print
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+us+inet(evdev)"     };
        xkb_geometry  { include "pc(pc104)"     };
};


the Xorg.0.log shows more or less the same:
Code:
[2679122.777] (II) XINPUT: Adding extended input device "Apple Inc. Apple Keyboard" (type: KEYBOARD, id 10)
[2679122.777] (**) Option "xkb_rules" "evdev"
[2679122.777] (**) Option "xkb_model" "pc104"
[2679122.777] (**) Option "xkb_layout" "us"
[2679122.777] (II) config/udev: Adding input device Apple Inc. Apple Keyboard (/dev/input/event4)
[2679122.777] (**) Apple Inc. Apple Keyboard: Applying InputClass "evdev keyboard catchall"
[2679122.777] (II) Using input driver 'evdev' for 'Apple Inc. Apple Keyboard'
[2679122.777] (**) Apple Inc. Apple Keyboard: always reports core events
[2679122.777] (**) evdev: Apple Inc. Apple Keyboard: Device: "/dev/input/event4"
[2679122.777] (--) evdev: Apple Inc. Apple Keyboard: Vendor 0x5ac Product 0x250
[2679122.777] (--) evdev: Apple Inc. Apple Keyboard: Found keys
[2679122.777] (II) evdev: Apple Inc. Apple Keyboard: Configuring as keyboard
[2679122.777] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3.2/1-1.3.2:1.1/input/input4/event4"

_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1633
Location: United Kingdom

PostPosted: Thu Jan 23, 2014 12:55 pm    Post subject: Reply with quote

I don't use a Mac, but that keyboard layout you linked to is not a British Apple keyboard layout (see Differences between British and US Apple Keyboards). It looks to me to be a US Apple keyboard layout.

Do you have xfce4-xkb-plugin installed, and do you normally select the keyboard layout using Keyboard Layouts in Xfce? Rather than selecting the keyboard layout via the GUI you could try doing it directly in xorg.conf if your keyboard device is already specified in that file, or in a separate file /etc/X11/xorg.conf.d/00-keyboard.conf if your keyboard device is not already specified in xorg.conf [1]. You may already have a file *-keyboard.conf in /etc/X11/xorg.conf.d/ which you could edit accordingly.

All the possible XkbModels, XkbLayouts, XkbVariants and XkbOptions are listed in the text file /usr/share/X11/xkb/rules/xorg.lst on your machine. I see in that file on my main laptop running Gentoo that the possible Apple entries for XkbModels are:

Code:
apple           Apple
apple_laptop    Apple Laptop
applealu_ansi   Apple Aluminium Keyboard (ANSI)
applealu_iso    Apple Aluminium Keyboard (ISO)
applealu_jis    Apple Aluminium Keyboard (JIS)

So you could try a file /etc/X11/xorg.conf.d/00-keyboard.conf along the following lines:

Code:
Section "InputClass"
    Identifier "keyboard"
    MatchIsKeyboard "yes"
    Option "XkbLayout" "applealu_iso" # Try "applealu_ansi" as well.
    Option "XkbLayout" "gb"
EndSection

You'll need to play around with the options. On some of my machines I want to be able to switch keyboard layouts between British English, US English, Brazilian Portuguese and Spanish, so I have a file /etc/X11/xorg.conf.d/00-keyboard.conf that looks like the following:

Code:
Section "InputClass"
    Identifier "keyboard"
    MatchIsKeyboard "yes"
    Option "XkbLayout" "gb,us,br,es"
    Option "XkbVariant" ""
    Option "XkbOptions" "grp:alt_shift_toggle"
EndSection

I have specified the XkbOptions option to be "grp:alt_shift_toggle" so that I can use Alt+Shift to toggle between the keyboard layouts. The key combination options for toggling are also listed in /usr/share/X11/xkb/rules/xorg.lst.

Another thing to try: As the keyboard layout you linked to appears to be a US layout, you could try something like the following:

Code:
Section "InputClass"
    Identifier "keyboard"
    MatchIsKeyboard "yes"
    Option "XkbLayout" "us"
    Option "XkbVariant" "intl" # Or maybe try "alt-intl".
EndSection

The different keyboard variants are also listed in /usr/share/X11/xkb/rules/xorg.lst.

If you prefer, instead of using an X.Org configuration file, it is possible to assign keyboard layouts, variants and options via the command line by using the setkbmap command. For example:

Code:
setxkbmap -layout us -variant intl

If you wanted to use a Compose Key then the command would become for example:

Code:
setxkbmap -layout us -variant intl -option compose:lwin

The allowable alternatives to 'lwin' (Left Windows key) are also listed in /usr/share/X11/xkb/rules/xorg.lst.


[1] Selecting different keyboard layouts in Xfce.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Thu Jan 23, 2014 2:48 pm    Post subject: Reply with quote

After talking in the #xfce channel I found out the reason it's not working anymore on XFCE is due to a problem that has now been fixed on 4.10
https://bugzilla.xfce.org/show_bug.cgi?id=10226

I'll try to implement the solution given by Fitzcarraldo and report back.
Thanks :)
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Fri Jan 24, 2014 2:04 pm    Post subject: Reply with quote

So I´ve been playing a bit with it, found out I´ve linked the wrong image for the keyboard layout:
http://images.esellerpro.com/2477/I/640/424/MB110B-1.jpg

Now I´ve got the internationalisation keys working using the keyboard layout switcher of XFCE, but some keys are just awkward, as the double quotes gives me this symbol: ¨ and the §/± key is inverted with ~/` key. :(
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum