Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X: Fatal Server Error: No Screens found
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
--kenny--
n00b
n00b


Joined: 21 Jan 2014
Posts: 2

PostPosted: Tue Jan 21, 2014 4:58 am    Post subject: X: Fatal Server Error: No Screens found Reply with quote

I successfully installed gentoo to my mac g4 and can boolt into a command line.

Xorg fails to run however. I followed https://wiki.gentoo.org/wiki/Xorg/Configuration and X fails to run.

Startx DID give me a black screen with some white textin top left and a bit in bottom left and I would have to force shut down to get back to a prompt. I installed xf86-video-nouveau and it now gives me

Code:

(EE)
Fatal server error:
(EE) no screens found(EE)
(EE)


Here is /var/log/Xorg.0.log:

Code:

[  1977.495]
X.Org X Server 1.14.3
Release Date: 2013-09-12
[  1977.506] X Protocol Version 11, Revision 0
[  1977.509] Build Operating System: Linux 3.10.7-gentoo-r1 ppc Gentoo
[  1977.513] Current Operating System: Linux DaBollix 3.10.7-gentoo-r1 #1 Tue Dec 17 06:49:37 EST 2013 ppc
[  1977.513] Kernel command line: root=/dev/hda4 ro video=ofonly
[  1977.521] Build Date: 18 December 2013  02:45:32PM
[  1977.525] 
[  1977.529] Current version of pixman: 0.32.4
[  1977.537]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  1977.537] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1977.555] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Jan 21 15:20:19 2014
[  1977.560] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1977.560] (==) No Layout section.  Using the first Screen section.
[  1977.560] (==) No screen section available. Using defaults.
[  1977.560] (**) |-->Screen "Default Screen Section" (0)
[  1977.561] (**) |   |-->Monitor "<default monitor>"
[  1977.561] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[  1977.561] (==) Automatically adding devices
[  1977.561] (==) Automatically enabling devices
[  1977.561] (==) Automatically adding GPU devices
[  1977.561] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  1977.561]    Entry deleted from font path.
[  1977.561] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  1977.561]    Entry deleted from font path.
[  1977.561] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  1977.561]    Entry deleted from font path.
[  1977.561] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[  1977.561]    Entry deleted from font path.
[  1977.561]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[  1977.561] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[  1977.561]    Entry deleted from font path.
[  1977.561]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[  1977.561] (==) FontPath set to:
   /usr/share/fonts/misc/
[  1977.561] (==) ModulePath set to "/usr/lib/xorg/modules"
[  1977.561] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  1977.561] (II) Loader magic: 0x102095f8
[  1977.561] (II) Module ABI versions:
[  1977.562]    X.Org ANSI C Emulation: 0.4
[  1977.562]    X.Org Video Driver: 14.1
[  1977.562]    X.Org XInput driver : 19.1
[  1977.562]    X.Org Server Extension : 7.0
[  1977.563] (--) PCI:*(0:0:16:0) 10de:0329:10de:0010 rev 161, Mem @ 0x91000000/16777216, 0xa0000000/134217728, BIOS @ 0x????????/131072
[  1977.563] (II) Open APM successful
[  1977.568] Initializing built-in extension Generic Event Extension
[  1977.573] Initializing built-in extension SHAPE
[  1977.577] Initializing built-in extension MIT-SHM
[  1977.582] Initializing built-in extension XInputExtension
[  1977.586] Initializing built-in extension XTEST
[  1977.591] Initializing built-in extension BIG-REQUESTS
[  1977.595] Initializing built-in extension SYNC
[  1977.600] Initializing built-in extension XKEYBOARD
[  1977.604] Initializing built-in extension XC-MISC
[  1977.609] Initializing built-in extension XINERAMA
[  1977.613] Initializing built-in extension XFIXES
[  1977.617] Initializing built-in extension RENDER
[  1977.621] Initializing built-in extension RANDR
[  1977.626] Initializing built-in extension COMPOSITE
[  1977.630] Initializing built-in extension DAMAGE
[  1977.634] Initializing built-in extension MIT-SCREEN-SAVER
[  1977.638] Initializing built-in extension DOUBLE-BUFFER
[  1977.643] Initializing built-in extension RECORD
[  1977.647] Initializing built-in extension DPMS
[  1977.651] Initializing built-in extension X-Resource
[  1977.655] Initializing built-in extension XVideo
[  1977.659] Initializing built-in extension XVideo-MotionCompensation
[  1977.663] Initializing built-in extension XFree86-VidModeExtension
[  1977.667] Initializing built-in extension XFree86-DGA
[  1977.671] Initializing built-in extension XFree86-DRI
[  1977.676] Initializing built-in extension DRI2
[  1977.676] (II) LoadModule: "glx"
[  1977.676] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  1977.677] (II) Module glx: vendor="X.Org Foundation"
[  1977.677]    compiled for 1.14.3, module version = 1.0.0
[  1977.677]    ABI class: X.Org Server Extension, version 7.0
[  1977.677] (==) AIGLX enabled
[  1977.681] Loading extension GLX
[  1977.681] (==) Matched nouveau as autoconfigured driver 0
[  1977.681] (==) Matched nv as autoconfigured driver 1
[  1977.681] (==) Matched modesetting as autoconfigured driver 2
[  1977.681] (==) Matched fbdev as autoconfigured driver 3
[  1977.681] (==) Assigned the driver to the xf86ConfigLayout
[  1977.681] (II) LoadModule: "nouveau"
[  1977.682] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[  1977.682] (II) Module nouveau: vendor="X.Org Foundation"
[  1977.682]    compiled for 1.14.3, module version = 1.0.9
[  1977.682]    Module class: X.Org Video Driver
[  1977.682]    ABI class: X.Org Video Driver, version 14.1
[  1977.682] (II) LoadModule: "nv"
[  1977.683] (II) Loading /usr/lib/xorg/modules/drivers/nv_drv.so
[  1977.683] (II) Module nv: vendor="X.Org Foundation"
[  1977.683]    compiled for 1.14.3, module version = 2.1.20
[  1977.683]    Module class: X.Org Video Driver
[  1977.683]    ABI class: X.Org Video Driver, version 14.1
[  1977.683] (II) LoadModule: "modesetting"
[  1977.684] (WW) Warning, couldn't open module modesetting
[  1977.684] (II) UnloadModule: "modesetting"
[  1977.684] (II) Unloading modesetting
[  1977.684] (EE) Failed to load module "modesetting" (module does not exist, 0)
[  1977.684] (II) LoadModule: "fbdev"
[  1977.684] (WW) Warning, couldn't open module fbdev
[  1977.684] (II) UnloadModule: "fbdev"
[  1977.684] (II) Unloading fbdev
[  1977.684] (EE) Failed to load module "fbdev" (module does not exist, 0)
[  1977.684] (II) NOUVEAU driver
[  1977.684] (II) NOUVEAU driver for NVIDIA chipset families :
[  1977.684]    RIVA TNT        (NV04)
[  1977.685]    RIVA TNT2       (NV05)
[  1977.685]    GeForce 256     (NV10)
[  1977.685]    GeForce 2       (NV11, NV15)
[  1977.685]    GeForce 4MX     (NV17, NV18)
[  1977.685]    GeForce 3       (NV20)
[  1977.685]    GeForce 4Ti     (NV25, NV28)
[  1977.685]    GeForce FX      (NV3x)
[  1977.685]    GeForce 6       (NV4x)
[  1977.685]    GeForce 7       (G7x)
[  1977.685]    GeForce 8       (G8x)
[  1977.685]    GeForce GTX 200 (NVA0)
[  1977.685]    GeForce GTX 400 (NVC0)
[  1977.685] (II) NOUVEAU driver
[  1977.685] (II) NOUVEAU driver for NVIDIA chipset families :
[  1977.685]    RIVA TNT        (NV04)
[  1977.685]    RIVA TNT2       (NV05)
[  1977.685]    GeForce 256     (NV10)
[  1977.685]    GeForce 2       (NV11, NV15)
[  1977.685]    GeForce 4MX     (NV17, NV18)
[  1977.685]    GeForce 3       (NV20)
[  1977.685]    GeForce 4Ti     (NV25, NV28)
[  1977.685]    GeForce FX      (NV3x)
[  1977.685]    GeForce 6       (NV4x)
[  1977.685]    GeForce 7       (G7x)
[  1977.685]    GeForce 8       (G8x)
[  1977.686]    GeForce GTX 200 (NVA0)
[  1977.686]    GeForce GTX 400 (NVC0)
[  1977.686] (--) using VT number 7

[  1977.715] (EE) [drm] KMS not enabled
[  1977.716] (EE) [drm] KMS not enabled
[  1977.716] (EE) No devices detected.
[  1977.716] (EE)
Fatal server error:
[  1977.716] (EE) no screens found(EE)
[  1977.716] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  1977.716] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  1977.716] (EE)


I do not understand what I did wrong but before install xf86-video-nouveau I tried to install nvidia-drivers, which failed to install.
Back to top
View user's profile Send private message
--kenny--
n00b
n00b


Joined: 21 Jan 2014
Posts: 2

PostPosted: Tue Jan 21, 2014 6:32 am    Post subject: Reply with quote

Just realised that i missed the last few lines where it said KMS not enabled. Another noob question now :)

How to I enable/compile KMS?

Thanks
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Tue Jan 21, 2014 7:34 pm    Post subject: Reply with quote

On a not really related note: that guide forgets in the input portion to mention that setting '/dev/input/event*' filter is helpful, though perhaps the driver does it on its own by now.

Now, as for the problem.
Post 'emerge -1pv mesa libdrm xorg-server xf86-video-nouveau'.
Pastebin kernel config.

Also,
--kenny-- wrote:
[ 1977.513] Kernel command line: root=/dev/hda4 ro video=ofonly

...well, your kernel config needs more than one tweak.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum