Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problems with UTF-8 clippboard and possibly gdk-pixbuf
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
potuz
Guru
Guru


Joined: 30 Jan 2010
Posts: 378

PostPosted: Thu Jan 16, 2014 11:09 pm    Post subject: problems with UTF-8 clippboard and possibly gdk-pixbuf Reply with quote

After a weekly world update I started noticing something weird in the behaviour of my system with character encodings.
First symptom: typing something with an accent like "á" in rxvt-unicode and copying to the clippboard and pasting it in a webkit-gtk browser like midori spits
Code:

Gdk-WARNING **: Error converting selection from UTF8_STRING


Also on the same terminal it gives
Code:

$ á
bash: $'\303\241': command not found

whereas the answer before would've been
Code:

bash: á: command not found

The only thing suspicious in the last emerge world (it was only 26 packages) is
x11-libs/gdk-pixbuf-2.28.2 which might be responsible for the Gdk Warning above, but this was only a recompile I suspect due to the globalization of my "X" use-flag.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum