Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installing older version of cgminer.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
dstathis
n00b
n00b


Joined: 15 Jan 2014
Posts: 4

PostPosted: Wed Jan 15, 2014 7:22 am    Post subject: Installing older version of cgminer. Reply with quote

I am trying to install cgminer 3.7 through portage.

When I try to emerge directly I get
Code:
# emerge --ask net-misc/cgminer-3.7.2
!!! 'net-misc/cgminer-3.7.2' is not a valid package atom.
!!! Please check ebuild(5) for full details.


I think I am doing something wrong though because I get the same thing for 3.9.0.1

Code:
# emerge --ask net-misc/cgminer-3.9.0.1
!!! 'net-misc/cgminer-3.9.0.1' is not a valid package atom.
!!! Please check ebuild(5) for full details.


Despite the fact that 3.9.0.1 clearly exists

Code:
# emerge --ask cgminer

 * IMPORTANT: 8 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] net-misc/cgminer-3.9.0.1  USE="avalon ncurses udev -bflsc -bitforce -bitfury -doc -drillbit -examples -hardened -icarus -klondike -modminer"

Would you like to merge these packages? [Yes/No] No

Quitting.


I am a Gentoo noob and I am probably just not understanding the syntax. Can someone explain to me how to get version 3.7?
Back to top
View user's profile Send private message
soka
Tux's lil' helper
Tux's lil' helper


Joined: 27 Dec 2006
Posts: 92
Location: Argentina

PostPosted: Wed Jan 15, 2014 11:39 am    Post subject: Reply with quote

You are missing "=" in the emerge command.
Code:
emerge --ask =net-misc/cgminer-3.7.2


Also to avoid futures update you can add cgminer versions greater than 3.7.2 to package.mask and the emerge ditectly.

Code:
echo ">=net-misc/cgminer-3.7.3" >> /etc/portage/package.mask
emerge -va cgminer
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 10927

PostPosted: Thu Jan 16, 2014 12:09 am    Post subject: Re: Installing older version of cgminer. Reply with quote

dstathis wrote:
I am trying to install cgminer 3.7 through portage.
Code:
!!! Please check ebuild(5) for full details.
Portage gives you this advice for good reason. The referenced man page describes atom syntax in great detail. You could also use <cgminer-3.8 to specify any version older than 3.8. You will probably need to quote that to prevent your shell interpreting the less than sign.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum