Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sometimes I hate having to upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1523

PostPosted: Tue Jan 14, 2014 12:21 pm    Post subject: Sometimes I hate having to upgrade Reply with quote

Hung on to kde*-4.10.5 and nvidia-drivers-319.49 for as long as I could (they were working, and I didn't want to fix them). Eventually of course, they passed from the portage tree, and I succumbed did the upgrade. Of course, it has been a complete disaster.

The biggest issues involve the rotation of the display, which was working perfectly before.

I have a fairly simple xorg.conf:

Code:

Section "Module"
    Load            "dbe"
    Load            "extmod"
    Load            "glx"
    Load            "record"
EndSection

Section "Monitor"
    Identifier      "Monitor0"
    VendorName      "Monitor Vendor"
    ModelName       "Monitor Model"
    Option          "DPMS"
EndSection

Section "Device"
    Identifier      "Device0"
    Driver          "nvidia"
    BusID           "PCI:1:0:0"
    Option          "UseEdidDpi"    "false"
EndSection

Section "Screen"
    Identifier      "Screen0"
    Monitor         "Monitor0"
    Device          "Device0"
    Option          "metamodes" "nvidia-auto-select +0+0 {rotation=90}"
EndSection


Again, this worked fine before, bringing up both kdm and the kde desktop rotated. Now, neither one of them are rotated.

Even having to configure the desktop on each login wouldn't be so bad, but the problem described here:

http://forum.kde.org/viewtopic.php?f=17&t=110536

has returned with a vengeance. Even worse, the trick described in that post to return the desktop to the proper size:

Code:

xrandr --output DVI-I-1 --auto


no longer works. I now have a massive virtual desktop that I don't want, and the whole thing is completely unusable.

Any suggestions to get this working again would be hugely appreciated.
Back to top
View user's profile Send private message
aCOSwt
Bodhisattva
Bodhisattva


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Tue Jan 14, 2014 12:42 pm    Post subject: Re: Sometimes I hate having to upgrade Reply with quote

curmudgeon wrote:
Sometimes I hate having to upgrade

Well... no one forces you to.
In addition... "upgrading" does not necessarily mean increasing version numbers.

- In the particular case of the nvidia-drivers, when 319.49 was dropped, you could have considered that "downgrading" to 304.117 was the recommended and preferred choice.
So you can still do that or test if the very new 331.38 bumped yesterday can help.

- In the particular case of KDE, after having failed requesting the devs to keep the 4.X.5 in the tree until 4.X+1.5 is stabilized, I decided to :
Mask all >=4.X.5 packages and copy all 4.X.5 ebuilds in my local overlay.
If you decide to downgrade your KDE-4.11 down to your good old 4.10.5, I can send you the appropriate mask and an archive with the ebuilds.
_________________
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3688
Location: Dallas area

PostPosted: Tue Jan 14, 2014 12:53 pm    Post subject: Re: Sometimes I hate having to upgrade Reply with quote

aCOSwt wrote:
- In the particular case of KDE, after having failed requesting the devs to keep the 4.X.5 in the tree until 4.X+1.5 is stabilized, I decided to :
Mask all >=4.X.5 packages and copy all 4.X.5 ebuilds in my local overlay.
If you decide to downgrade your KDE-4.11 down to your good old 4.10.5, I can send you the appropriate mask and an archive with the ebuilds.


It's good that we can use local overlays, but it's sad that the devs don't seem
to care about keeping things around that were working perfectly fine.
I've been down that road with trying to convince them about old versions of udev.
Keeping something around, with the understanding that it won't be fixed should be ok, it's not any real work for them.

Having said that, one also needs the tar files as well as any patches alongside the ebuilds.
As the tar files won't stay around very long in the repositories.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
aCOSwt
Bodhisattva
Bodhisattva


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Tue Jan 14, 2014 1:12 pm    Post subject: Re: Sometimes I hate having to upgrade Reply with quote

Anon-E-moose wrote:
Keeping something around, with the understanding that it won't be fixed should be ok, it's not any real work for them.

I had thought that too. But... it appears that devs are just glad to drop (as per Andreas K. Hüttel's comment #4) :roll:
Anon-E-moose wrote:
the tar files won't stay around very long in the repositories.

You are correct, however, they can stay much longer in your ${DISTDIR}.
_________________
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Tue Jan 14, 2014 1:56 pm    Post subject: Re: Sometimes I hate having to upgrade Reply with quote

Anon-E-moose wrote:
It's good that we can use local overlays, but it's sad that the devs don't seem
to care about keeping things around that were working perfectly fine.
I've been down that road with trying to convince them about old versions of udev.

You try that, then have a look how long it takes until your ebuild breaks while simply keeping it around. The reality is you just can't leave it there and be done with it, with the constant change of dependencies, eclasses, EAPI conventions etc. And you will get bug reports - for old, 'just kept around' versions.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
aCOSwt
Bodhisattva
Bodhisattva


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Tue Jan 14, 2014 2:13 pm    Post subject: Re: Sometimes I hate having to upgrade Reply with quote

genstorm wrote:
You try that, then have a look how long it takes until your ebuild breaks while simply keeping it around. The reality is you just can't leave it there and be done with it, with the constant change of dependencies, eclasses, EAPI conventions etc.

I cannot tell for udev.
I can tell for kde 4.8, 4.9, 4.10, that the reality is that it actually caused 0 problem keeping 4.X.5 until 4.X+1.5 got stabilized, this while going on proceeding to my weekly updates of all other packages to last stable.
_________________
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3688
Location: Dallas area

PostPosted: Tue Jan 14, 2014 2:16 pm    Post subject: Re: Sometimes I hate having to upgrade Reply with quote

genstorm wrote:
Anon-E-moose wrote:
It's good that we can use local overlays, but it's sad that the devs don't seem
to care about keeping things around that were working perfectly fine.
I've been down that road with trying to convince them about old versions of udev.

You try that, then have a look how long it takes until your ebuild breaks while simply keeping it around. The reality is you just can't leave it there and be done with it, with the constant change of dependencies, eclasses, EAPI conventions etc. And you will get bug reports - for old, 'just kept around' versions.


I'm still running udev 171-r6 and it runs fine.
Oh I've had to mask a few (very few) packages in the scheme of things,
but the rest of the desktop is modern.

So I think what I said is accurate. YMMV.

It is no real work for devs, and any bugs could and should be dismissed as it's an old ebuild.
But it would hurt absolutely nothing to leave them around...well except for the insane march to the one true way. :roll:
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
aCOSwt
Bodhisattva
Bodhisattva


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Tue Jan 14, 2014 2:29 pm    Post subject: Re: Sometimes I hate having to upgrade Reply with quote

Anon-E-moose wrote:
But it would hurt absolutely nothing to leave them around...well except for the insane march to the one true way. :roll:
++

Arguments such as the constant change of dependencies, eclasses, EAPI conventions etc are certainly valid objections but they remain purely theoretical objections.
Such purely theoretical objections should always just vanish when the true reality of one specific case is that : It just actually works here and now!
Who wants his system to theoretically work ? I personally prefer it to actually work here and now!
_________________
Back to top
View user's profile Send private message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1523

PostPosted: Tue Jan 14, 2014 4:49 pm    Post subject: Re: Sometimes I hate having to upgrade Reply with quote

aCOSwt wrote:
curmudgeon wrote:
Sometimes I hate having to upgrade

Well... no one forces you to.


Yes I know, but it becomes difficult when you have an unrelated problem, and the support person just keeps focusing on "why are you running such an old version of foo?"

aCOSwt wrote:
In addition... "upgrading" does not necessarily mean increasing version numbers.


I suppose technically not, but in terms of usage as far as language goes, most people would define upgrading as getting something replaced by a newer version.

aCOSwt wrote:
- In the particular case of the nvidia-drivers, when 319.49 was dropped, you could have considered that "downgrading" to 304.117 was the recommended and preferred choice.


I could have considered it, but generally tend not to unless I have a decent reason in advance, which I did not in this case (how was I supposed to know the newer version was so bad?). And if everybody knows that the newer version is so much worse, why is the older version getting removed from the tree (and more relevant - why did 331.20 get marked stable? - that seems like a very sick joke).

aCOSwt wrote:
So you can still do that or test if the very new 331.38 bumped yesterday can help.


I hadn't really paid enough attention to the drivers as a possible source of the problem. I actually looked for something in the same series (319.x), and found 319.76. I installed that version, and was pleasantly surprised to see that all of the problems were gone, and that everything was working normally again.

aCOSwt wrote:
- In the particular case of KDE, after having failed requesting the devs to keep the 4.X.5 in the tree until 4.X+1.5 is stabilized, I decided to :
Mask all >=4.X.5 packages and copy all 4.X.5 ebuilds in my local overlay.
If you decide to downgrade your KDE-4.11 down to your good old 4.10.5, I can send you the appropriate mask and an archive with the ebuilds.


I might take you up on that in the future. I was glad to see that the developers ended up allowing the installation of kde 4.11* without semantic desktop - an OMDB option (meaning over my dead body does semantic desktop go onto any of my machines). If semantic desktop ever becomes forced, then I am never upgrading past the last semantic desktop free version (and looking for another desktop environment).
Back to top
View user's profile Send private message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1523

PostPosted: Tue Jan 14, 2014 4:59 pm    Post subject: Re: Sometimes I hate having to upgrade Reply with quote

Anon-E-moose wrote:
I'm still running udev 171-r6 and it runs fine.
Oh I've had to mask a few (very few) packages in the scheme of things,
but the rest of the desktop is modern.


I always tell people that the reason I run gentoo is that it is the easiest distribution for overcoming developer idiocies (both distribution idiocies and upstream idiocies).

One other package that I absolutely refuse to upgrade is polkit (still on the long gone 0.104-r1). So far all of the packages depending on polkit still work with this version. Why am I still running this version? The idea of having to install and run a complete javascript engine for configuration (especially mozilla's junk), which later versions require, simply disgusts me.
Back to top
View user's profile Send private message
aCOSwt
Bodhisattva
Bodhisattva


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Tue Jan 14, 2014 5:49 pm    Post subject: Re: Sometimes I hate having to upgrade Reply with quote

curmudgeon wrote:
And if everybody knows that the newer version is so much worse, why is the older version getting removed from the tree (and more relevant - why did 331.20 get marked stable? - that seems like a very sick joke).

That is a good question indeed.
In terms of stability of this particular package I personally tend to rely more on what nvidia officially tells there : http://www.nvidia.fr/Download/Find.aspx?lang=fr regarding my particular device than on what the devs can state.
curmudgeon wrote:
aCOSwt wrote:
- In the particular case of the nvidia-drivers, when 319.49 was dropped, you could have considered that "downgrading" to 304.117 was the recommended and preferred choice.

I could have considered it, but generally tend not to unless I have a decent reason in advance... I actually looked for something in the same series (319.x), and found 319.76. I installed that version.

Now, concerning 319.76 you seem happy with, you get a decent reason for avoiding it... in advance. :wink:
(Being said that the summary has changed a lot of times and that the current one does not reflect the reality of all the contributions : 319.49 was the last not concerned) => As of today 304.117 is the recommended one... unless the very new 331.38 proves itself reliable.
_________________
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1684
Location: Here and Away Again

PostPosted: Tue Jan 14, 2014 6:59 pm    Post subject: Re: Sometimes I hate having to upgrade Reply with quote

curmudgeon wrote:
One other package that I absolutely refuse to upgrade is polkit (still on the long gone 0.104-r1). So far all of the packages depending on polkit still work with this version. Why am I still running this version? The idea of having to install and run a complete javascript engine for configuration (especially mozilla's junk), which later versions require, simply disgusts me.

I tend to prefer no polkit at all, which obviously brings its own caveats (are there anything other than perhaps not getting support when things break?).

aCOSwt wrote:
As of today 304.117 is the recommended one... unless the very new 331.38 proves itself reliable.

I can say that Terraria doesn't seem to go all segmentation fault at me with 331.38, which it does with at least 331.20 and I believe 319.76 is the other I tried (304.117 works too). That's the only thing I noticed not working with 331.20, or well, that's the only thing I've been aware of... I think.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum