Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wicd Failed to connect to socket /var/run/dbus/system_bus_s
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 914

PostPosted: Mon Jan 13, 2014 2:10 pm    Post subject: wicd Failed to connect to socket /var/run/dbus/system_bus_s Reply with quote

I'm not using XFCE or any desktop manager. I am just using a window manager. I just installed wicd and I get this error:

Code:
one@localhost ~ $ wicd-
wicd-cli     wicd-client  wicd-curses  wicd-gtk     
one@localhost ~ $ wicd-gtk
Traceback (most recent call last):
  File "/usr/share/wicd/gtk/wicd-client.py", line 63, in <module>
    from wicd import dbusmanager
  File "/usr/lib64/python2.7/site-packages/wicd/dbusmanager.py", line 93, in <module>
    DBUS_MANAGER = DBusManager()
  File "/usr/lib64/python2.7/site-packages/wicd/dbusmanager.py", line 57, in __init__
    self._bus = dbus.SystemBus()
  File "/usr/lib64/python2.7/site-packages/dbus/_dbus.py", line 194, in __new__
    private=private)
  File "/usr/lib64/python2.7/site-packages/dbus/_dbus.py", line 100, in __new__
    bus = BusConnection.__new__(subclass, bus_type, mainloop=mainloop)
  File "/usr/lib64/python2.7/site-packages/dbus/bus.py", line 122, in __new__
    bus = cls._new_for_bus(address_or_type, mainloop=mainloop)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.FileNotFound: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
one@localhost ~ $
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 252
Location: Germany

PostPosted: Thu Jan 23, 2014 12:53 pm    Post subject: Reply with quote

You probably don't have a dbus daemon running. Try:
Code:
/etc/init.d/dbus start

or permanently enable it at boot:
Code:
rc-update add dbus

Also, you may want to start the wicd daemon at boot:
Code:
rc-update add wicd
Back to top
View user's profile Send private message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 914

PostPosted: Thu Jan 30, 2014 2:10 pm    Post subject: Reply with quote

That did it, thanks!
Back to top
View user's profile Send private message
HeXiLeD
Veteran
Veteran


Joined: 20 Aug 2005
Posts: 1068
Location: Online

PostPosted: Wed Feb 19, 2014 4:49 am    Post subject: Reply with quote

I have the exact same problem and this solution as well as many others found, did not solve the problem.
The problem happend with 1.7.2.4-r3 as well as the previous stable package
_________________
443640, Questioning, Unsolved, BinHost
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum