Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Steam Teamfortress 2 rendering problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
andresrcom
n00b
n00b


Joined: 13 Jan 2014
Posts: 2

PostPosted: Mon Jan 13, 2014 2:03 pm    Post subject: [Solved] Steam Teamfortress 2 rendering problems Reply with quote

I have installed steam and teamfortress2. After launch i have troubles with game rendering. Here is a screenshot: http://s1292.photobucket.com/user/andresrcom/media/2014-01-13_00001_zps51c23053.jpg.html when playing there is the same sittuation, only dark textures and it is not possible to recognize other players.

intel hd 3000 - my video card

Code:

lspci | grep "VGA"
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)


Code:

glxinfo | grep OpenGL

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.1.6
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 9.1.6
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:



Has anybody faced this problem before?


Last edited by andresrcom on Tue Jan 14, 2014 8:56 am; edited 1 time in total
Back to top
View user's profile Send private message
hibajugala
n00b
n00b


Joined: 23 Nov 2013
Posts: 4
Location: Ontario, Canada

PostPosted: Tue Jan 14, 2014 2:54 am    Post subject: Reply with quote

Do you have libtxc_dxtn (32 bit) installed?
I had black textures running steam games through wine where the textures were all black without it. Although attempting to run tf2 natively gave me an error about it, so maybe you were able to bypass that somehow?
Back to top
View user's profile Send private message
andresrcom
n00b
n00b


Joined: 13 Jan 2014
Posts: 2

PostPosted: Tue Jan 14, 2014 8:55 am    Post subject: Reply with quote

Thank you for the reply.
I have forgotten to mention that I installed steam from the overlay https://github.com/anyc/steam-overlay
I have added some use flags and recompiled the packages
Code:

>=games-util/steam-games-meta-0 s3tc steamgames_source_engine steamgames_tf2
>=media-libs/libtxc_dxtn-1.0.1-r1 abi_x86_32

Now everything works perfectly.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum