Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome-session crashes "oh no something's gone wrong" screen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
alexbuell
Guru
Guru


Joined: 18 Jul 2002
Posts: 481
Location: "Hemp"shire, UK

PostPosted: Sat Jan 11, 2014 12:19 am    Post subject: gnome-session crashes "oh no something's gone wrong&quo Reply with quote

Hi guys,

This has been driving me nuts for the last few days, in my attempts to get Gnome 3.8 up and running under 32bit x86, I am experiencing the following:

Code:

Jan 11 00:12:24 lithium.local.net gnome-session[9851]: gnome-session[9851]: WARNING: Failed to connect to systemd: Error calling StartServiceByName for org.freedesktop.login1: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1
Jan 11 00:12:24 lithium.local.net gnome-session[9851]: gnome-session[9851]: GLib-GObject-WARNING: invalid (NULL) pointer instance
Jan 11 00:12:24 lithium.local.net gnome-session[9851]: gnome-session[9851]: GLib-GObject-CRITICAL: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Jan 11 00:12:24 lithium.local.net gnome-session[9851]: gnome-session[9851]: GLib-GIO-CRITICAL: g_dbus_proxy_call_sync_internal: assertion `G_IS_DBUS_PROXY (proxy)' failed
Jan 11 00:12:24 lithium.local.net gnome-session[9851]: gnome-session[9851]: WARNING: Could not get session id for session. Check that logind is properly installed and pam_systemd is getting used at login.


I have re-emerged various parts i.e. gnome-session, systemd, dbus, dbus-glib etc but haven't been able to get anywhere. :-(

Help!
_________________
Cheers,
Alex.

Linux - the best text adventure game ever.
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 252
Location: Germany

PostPosted: Sat Jan 11, 2014 10:12 am    Post subject: Reply with quote

Some ideas:

have you emerge systemd with the "pam" USE flag?

Make sure you have a line like:
Code:
session        required    pam_systemd.so

in /etc/pam.d/system-auth. And perhaps in the file belonging to your login manager, if you use one. I have, for example, the following in /etc/pam.d/lightdm:
Code:
session   optional   pam_systemd.so


And finally, are you actually using systemd as your init instead of openRC (i.e. booting your kernel with init=/usr/lib/systemd/systemd)? AFAIK systemd needs to be running in order for logind to work.
Back to top
View user's profile Send private message
alexbuell
Guru
Guru


Joined: 18 Jul 2002
Posts: 481
Location: "Hemp"shire, UK

PostPosted: Sat Jan 11, 2014 4:51 pm    Post subject: Reply with quote

Kompi wrote:
Some ideas:

have you emerge systemd with the "pam" USE flag?

Make sure you have a line like:
Code:
session        required    pam_systemd.so

in /etc/pam.d/system-auth. And perhaps in the file belonging to your login manager, if you use one. I have, for example, the following in /etc/pam.d/lightdm:
Code:
session   optional   pam_systemd.so


And finally, are you actually using systemd as your init instead of openRC (i.e. booting your kernel with init=/usr/lib/systemd/systemd)? AFAIK systemd needs to be running in order for logind to work.


Yes - systemd is definltely emerged with the pam USE flag. In /etc/pam.d/system-auth, I had session optional pam_systemd.so in it, changed it to pam_systemd required pam_systemd.so, and the messages about gnome-session have now disappeared. But still getting the screen with "Oh no something's gone wrong" ...

But I did find something very interesting. It seems systemd is somehow calling openrc init.d files, which shouldn't be happening at all. On my two other boxes, the gentoo-local-baselayout1.service is not present, and those two are working just fine. On this box, gentoo-local-baselayout1.service is present.

I have tried disabling and deleting gentoo-local-baselayout1.service with systemctl but cannot find it anywhere in the file system!

Further thoughts?
_________________
Cheers,
Alex.

Linux - the best text adventure game ever.
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 252
Location: Germany

PostPosted: Sat Jan 11, 2014 6:37 pm    Post subject: Reply with quote

alexbuell wrote:
I have tried disabling and deleting gentoo-local-baselayout1.service with systemctl but cannot find it anywhere in the file system!

Hmm I think this service is created on the fly by the generator /usr/lib/systemd/system-generators/gentoo-local-generator, which is part of sys-apps/gentoo-systemd-integration.

Why it is generated on this machine, but not the others, I don't really know. I have no such service in my system. Maybe you have a <sys-apps/baselayout-2 merged? Or maybe some service depends on a service that is only available as and init.d script, but not as a .service file? Which services are started via /etc/init.d?


With regard to the "oh no" screen. Do you have anything in ~/.xsession-errors? If not, try running gdm (if you are using gdm) with debug enabled: Edit /etc/gdm/custom.conf, at the end add:
Code:
[debug]
Enable=true

You should either get some logs in /var/log/gdm/ or maybe something in the journal (try something like: systemctl --all -n 1000 status gdm.service).
Back to top
View user's profile Send private message
alexbuell
Guru
Guru


Joined: 18 Jul 2002
Posts: 481
Location: "Hemp"shire, UK

PostPosted: Sat Jan 11, 2014 8:28 pm    Post subject: Reply with quote

I sorted out my systemd... turns out a firewall script that's run by the NetworkManager dispatcher service kept getting killed after 3 seconds. I disabled it and it seems to be working just fine now...

As for the "oh no something's wrong'" screen, I traced it to this:

Code:

OpenGL Warning: glFlushVertexArrayRangeNV not found in mesa table
OpenGL Warning: glVertexArrayRangeNV not found in mesa table
OpenGL Warning: glCombinerInputNV not found in mesa table
OpenGL Warning: glCombinerOutputNV not found in mesa table
OpenGL Warning: glCombinerParameterfNV not found in mesa table
OpenGL Warning: glCombinerParameterfvNV not found in mesa table
OpenGL Warning: glCombinerParameteriNV not found in mesa table
OpenGL Warning: glCombinerParameterivNV not found in mesa table
OpenGL Warning: glFinalCombinerInputNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterivNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glDeleteFencesNV not found in mesa table
OpenGL Warning: glFinishFenceNV not found in mesa table
OpenGL Warning: glGenFencesNV not found in mesa table
OpenGL Warning: glGetFenceivNV not found in mesa table
OpenGL Warning: glIsFenceNV not found in mesa table
OpenGL Warning: glSetFenceNV not found in mesa table
OpenGL Warning: glTestFenceNV not found in mesa table


This box is a VM running on VirtualBox, and has the appropriate drivers (vboxvideo and xf86-video-virtualbox) installed and they work just fine.
I had a brainwave and did this:

Code:

xinit /usr/bin/twm


Bingo. It works just fine so definitely not a X problem.

I tried to get gnome-fallback working without success, there must be a way to force gnome to use it?
_________________
Cheers,
Alex.

Linux - the best text adventure game ever.
Back to top
View user's profile Send private message
Kompi
Apprentice
Apprentice


Joined: 05 Oct 2002
Posts: 252
Location: Germany

PostPosted: Sun Jan 12, 2014 9:20 am    Post subject: Reply with quote

Hmm, I'd guess even though this is not a problem for X or twm, it is for gnome because it needs 3d acceleration via openGL for the shell to work. I don't know how capable the virtualbox driver is in this regard, but according to this page http://www.webupd8.org/2011/05/virtualbox-408-released-with-gnome.html you have to enable the "3d accel" box in you machine's config. (I mention it because I think normally it complaints that this option is only useful for windows guests).

BTW, the gnome fallback mode does need 3d accel as well since version 3.8. Gnome dropped the 2d fallback desktop since gnome over the LLVMpipe driver should work for all configurations without hardware 3d acceleration. So I am very positive that you problem is due to some issue with mesa/opengl.

The problem might be related to you virtualbox version. According to this bug report https://www.virtualbox.org/ticket/11894 you my need version >=4.3, which is in the unstable tree in gentoo. If you have the stable version merged, perhaps upgrading to a 4.3 fixes the issue.

If nothing works, a possible workaround may be to try using LLVMpipe for software 3d acceleration. However, I guess the virtualbox driver will perform better.
Back to top
View user's profile Send private message
alexbuell
Guru
Guru


Joined: 18 Jul 2002
Posts: 481
Location: "Hemp"shire, UK

PostPosted: Tue Feb 18, 2014 11:26 pm    Post subject: Reply with quote

Kompi wrote:
Hmm, I'd guess even though this is not a problem for X or twm, it is for gnome because it needs 3d acceleration via openGL for the shell to work. I don't know how capable the virtualbox driver is in this regard, but according to this page http://www.webupd8.org/2011/05/virtualbox-408-released-with-gnome.html you have to enable the "3d accel" box in you machine's config. (I mention it because I think normally it complaints that this option is only useful for windows guests).

BTW, the gnome fallback mode does need 3d accel as well since version 3.8. Gnome dropped the 2d fallback desktop since gnome over the LLVMpipe driver should work for all configurations without hardware 3d acceleration. So I am very positive that you problem is due to some issue with mesa/opengl.

The problem might be related to you virtualbox version. According to this bug report https://www.virtualbox.org/ticket/11894 you my need version >=4.3, which is in the unstable tree in gentoo. If you have the stable version merged, perhaps upgrading to a 4.3 fixes the issue.

If nothing works, a possible workaround may be to try using LLVMpipe for software 3d acceleration. However, I guess the virtualbox driver will perform better.


Still being an issue in 4.3... not sure what else I can do now. Maybe I will do a clean Gentoo VM build and see if that works.
_________________
Cheers,
Alex.

Linux - the best text adventure game ever.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum