Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Grub 2 won't detect Windows in UEFI
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Slabity
n00b
n00b


Joined: 26 Dec 2013
Posts: 12

PostPosted: Fri Jan 10, 2014 7:52 am    Post subject: Grub 2 won't detect Windows in UEFI Reply with quote

I set up my partitions as such:

Code:
/dev/sda1    fat32    EFI
/dev/sda2    ext4     Gentoo
/dev/sda3    ntfs     Windows


I installed Gentoo first, without any bootloader. Then I successfully installed Windows, which properly put its own boot loader on the EFI partition.

After that, I install grub and os-prober in gentoo. My issue is that os-prober doesn't detect Windows at all, which therefore causes grub to only create a Linux entry.

Anyone know of any possible solutions? These are both fresh installs, and I have ntfs3g working. I might be just overlooking something stupid, but I can't seem to find any proper fix online.
Back to top
View user's profile Send private message
RazielFMX
l33t
l33t


Joined: 23 Apr 2005
Posts: 706
Location: NY, USA

PostPosted: Thu Jan 16, 2014 4:04 pm    Post subject: Reply with quote

I am very new to UEFI, but a few quick questions:

1) What version of Windows did you install?
2) Did you install grub from a UEFI booted medium? I had to load my EFI kernel onto a usb stick and boot from there to register my /boot/efi/efi/boot/bootx64.efi based kernel as an allowed boot device using /usr/sbin/efibootmgr (note: my EFI parition mounts to /boot/efi, not /boot, to be compatible with rEFInd and most other EFI tools, and I have a stand along /boot on /dev/sda2).

I ended up moving to rEFInd from a raw kernel boot for ease of upgrading my kernel (just copy it to /boot and good to go). rEFInd plays nice with multiple operating systems and was really easy to use so I recommend trying that if all else fails (but let's try to get your grub2 working).

The following resources might be really helpful (you probably have already read them, but I like to add info for those searching for similar issues later):

http://wiki.gentoo.org/wiki/EFI_stub_kernel
http://wiki.gentoo.org/wiki/UEFI_Gentoo_Quick_Install_Guide
http://wiki.gentoo.org/wiki/GRUB2#UEFI.2FGPT
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum