Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
VirtualBox - How to resize screen.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
nezero
n00b
n00b


Joined: 08 Jan 2014
Posts: 3

PostPosted: Thu Jan 09, 2014 9:14 am    Post subject: VirtualBox - How to resize screen. Reply with quote

Hi All,

I'm new to managing a Gentoo system, though I've previously used pre installed Gentoo machines.

I have the current VirtualBox set up.

Ubuntu 12.04 (host) - Gentoo (guest)

Installing Gentoo from these instructions seemed to work fine, but my terminal window is tiny and I can't figure out how to resize it, can anyone give me some pointers?

Please let me know what info you need to help solve the problem.

I've also read a similar post that suggests a Gentoo Virtual Box WiKi page for setting it up. This WiKi page no longer exists and i can't find a new one.

I can't seem to get Copy/Paste going either! So i may have to pipe command results into a file and then pipe the file into wgetpaste to show you the results.

Here are the results of commands others have asked for in similar posts (bpaste)

Code:

uname -a
Linux liam-laptop 3.10.17-gentoo #1 SMP Fri Jan 3 12:03:28 GMT 2014 x86_64 Intel(R) Core(TM) i7-3632QM CPU @ 2.20GHz GenuineIntel GNU/Linux

rc-update -v show
             bootmisc | boot                         
         busybox-ntpd |                             
     busybox-watchdog |                             
          consolefont |                             
               cronie |                             
          crypto-loop |                             
                 dbus |                             
                devfs |                       sysinit
               dhcpcd |      default                 
                dmesg |                       sysinit
                 fsck | boot                         
             hostname | boot                         
              hwclock | boot                         
              keymaps | boot                         
            killprocs |              shutdown       
    kmod-static-nodes |                             
                local |      default                 
           localmount | boot                         
             loopback | boot                         
              modules | boot                         
             mount-ro |              shutdown       
                 mtab | boot                         
           net.enp3s0 |      default                 
               net.lo |                             
             netmount |      default                 
                 nscd |                             
              numlock |                             
              pciparm |                             
               procfs | boot                         
            pydoc-2.7 |                             
            pydoc-3.3 |                             
                 root | boot                         
               rsyncd |                             
            savecache |              shutdown       
                 sshd |      default                 
                 swap | boot                         
            swapfiles | boot                         
              swclock |                             
               sysctl | boot                         
                sysfs |                       sysinit
            syslog-ng |      default                 
         termencoding | boot                         
         tmpfiles.dev |                       sysinit
       tmpfiles.setup | boot                         
                 udev |                       sysinit
           udev-mount |                       sysinit
              urandom | boot                         
 virtualbox-guest-additions |      default                 

/etc/init.d/virtualbox-guest-additions start
* WARNING: virtualbox-guest-additions has already been started
Back to top
View user's profile Send private message
gotyaoi
n00b
n00b


Joined: 01 Apr 2013
Posts: 71

PostPosted: Thu Jan 09, 2014 8:40 pm    Post subject: Reply with quote

Virtualbox, unfortunately, doesn't supply drivers that support KMS as yet. It is sad. There is a manual way though.

If you're using grub2, there's a setting in /etc/default/grub, GRUB_GFXPAYLOAD_LINUX. You can set it to your desired resolution/bit-depth. Mine looks like GRUB_GFXPAYLOAD_LINUX=1280x1024x24 for example. You may have to experiment a bit to find one that works for you. More info on that here: http://wiki.gentoo.org/wiki/GRUB2

Make sure to regenerate your grub config after changing the setting.

if you're using grub legacy, you can use the vga parameter to the kernel, vga=xxx. check this chart for reference http://en.wikipedia.org/wiki/VESA_BIOS_Extensions#Linux_video_mode_numbers

Again, you may need to experiment to find one that your video card supports.

You also need to make sure you have a framebuffer configured in your kernel. I can't think of the path offhand, but it's under device drivers->graphics somewhere.

Honestly though, depending on what your processor supports, making the console bigger will only be slow and painful. I just connect to my VM via ssh most of the time.

Also, a lot of the virtualbox-guest-additions features will only work in a desktop environment, I think. Just a heads up.
Back to top
View user's profile Send private message
nezero
n00b
n00b


Joined: 08 Jan 2014
Posts: 3

PostPosted: Fri Jan 10, 2014 10:03 am    Post subject: Reply with quote

Thanks for your help. I'm doing it out of curiosity more then anything, as we should be able to do it I would like to know how!

When you say i should have a framebuffer configured, is that for the system or grub?

As the WiKi suggests that grub should have one by emerging with -truetype USE flag.

I tried setting it up but I can't be understanding the USE flags and reinstalling correctly, as I edited my /etc/portage/package.use and tried pretended to reinstall GRUB.
Code:

## required by x11-drivers/xf86-video-vmware-13.0.1
# required by x11-base/xorg-drivers-1.14[video_cards_vmware]
# required by x11-base/xorg-server-1.14.3-r2[xorg]
# required by x11-drivers/xf86-video-v4l-0.2.0
=x11-libs/libdrm-2.4.46 libkms
# required by media-libs/mesa-9.1.6
# required by x11-base/xorg-server-1.14.3-r2[-minimal]
# required by x11-drivers/xf86-video-vmware-13.0.1
# required by x11-base/xorg-drivers-1.14[video_cards_vmware]
=dev-libs/libxml2-2.9.1-r1 python
# required by x11-drivers/xf86-video-vmware-13.0.1
# required by x11-base/xorg-drivers-1.14[video_cards_vmware]
# required by x11-base/xorg-server-1.14.3-r2[xorg]
# required by x11-drivers/xf86-video-v4l-0.2.0
=media-libs/mesa-9.1.6 xa
# grub framebuffer
=sys-boot/grub-2.00_p5107-r2:2 -truetype

emerge --pretend --reinstall changed-use grub

These are the packages that would be merged, in order:

Calculating dependencies  ... done!

To me it looks like it won't do anything if I actually run it.

Added the following to my /etc/default/grub

Code:

# Set resolution and color depth
GRUB_GFXMODE=1024x768x32
 
# Keep resolution when loading the kernel
GRUB_GFXPAYLOAD_LINUX=keep

an ran
Code:
grub2-mkconfig -o /boot/grub/grub.cfg


Seeing as nothing changed when i rebooted, i can only assume that i don't have a frambuffer configured. You got any pointers on where i'm going wrong?
Back to top
View user's profile Send private message
gotyaoi
n00b
n00b


Joined: 01 Apr 2013
Posts: 71

PostPosted: Sat Jan 11, 2014 9:12 am    Post subject: Reply with quote

I think the wiki says that to have grub use the framebuffer, you need +truetype, not -truetype. I'd also try 1024x768x24 instead of 1024x768x32. There are a lot of things that the virtualbox hardware doesn't always support, and 32 bit color depth is sometimes one of them.

If it still doesn't work, make sure you have a framebuffer driver in your kernel. Go into menuconfig, then Device Drivers->Graphics Support->Support for frame buffer devices->VESA VGA graphics support should be on.
Back to top
View user's profile Send private message
litan
n00b
n00b


Joined: 13 Aug 2012
Posts: 29

PostPosted: Sun Jan 19, 2014 1:02 am    Post subject: Reply with quote

Hi nezero,

just a thought:
what is it exactly that you want?
More lines and colums in the console, so that you are able to have more text displayed,
or is it about the physical size, because you have an unreasonable high resolution?

if it is just the physical size of the console, just go to your VirtualBox menu
View -> Switch to Scale Mode
then resize the window. This does not need guest-additions, drivers or anything.

By the way: We are talking about a console, not a terminal emulator on a tiny graphical desktop, right?
If you want the other sort of resizing, it might be easier if you first install X.

Sorry if this was off-topic.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum