Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg does not work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
hasansahin
n00b
n00b


Joined: 03 Jun 2010
Posts: 12

PostPosted: Mon Jan 06, 2014 6:16 am    Post subject: Xorg does not work Reply with quote

Hello all,

I freshly installed Gentoo stable AMD64 on my desktop machine. During installation process I followed "gentoo handbook", "Xorg wiki" and "XFCE wiki" documents. There was no error, everything went smoothly.
(I have choosen to use genkernel)

VIDEO_CARDS="radeon"
INPUT_DEVICES="evdev"

(My graphic card is Ati Radeon 7790)

I only installed xorg-server : emerge -pv xorg-server

Quote:
You could install the xorg-x11 metapackage instead of the more lightweight xorg-server . Functionally, xorg-x11 and xorg-server are the same. However, xorg-x11 brings in many more packages that you probably don't need, such as a huge assortment of fonts in many different languages. They're not necessary for a working desktop


After installation, I did :

# emerge --update --deep --with-bdeps=y --newuse @world
# emerge --depclean
# revdep-rebuild
# etc-update

and reboot. Gentoo box started very well but when I use "startx" command, so many errors has been occured (no screen found and etc..)
I tried to use "Xorg -configure" but no chance. Same errors.

Quote:
The X server is designed to work out-of-the-box, with no need to manually edit Xorg's configuration files. It should detect and configure devices such as displays, keyboards, and mice.
You should first try using startx without editing any configuration files. If Xorg won't start, or there's some other problem, then you'll need to manually configure Xorg as shown in the next section.


Due to I could not see graphical screen, I did not post my error screens. Could you please help me? Thanks.
_________________
Anyone who has never made a mistake has never tried anything new.
Albert Einstein.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Mon Jan 06, 2014 8:50 am    Post subject: Reply with quote

Xorg log is created regardless of whether or not display is opened successfully - pastebin it.
Back to top
View user's profile Send private message
hasansahin
n00b
n00b


Joined: 03 Jun 2010
Posts: 12

PostPosted: Mon Jan 06, 2014 9:05 am    Post subject: Reply with quote

VoidMage wrote:
Xorg log is created regardless of whether or not display is opened successfully - pastebin it.


Ok thanks. How can I post it without X?
_________________
Anyone who has never made a mistake has never tried anything new.
Albert Einstein.
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Mon Jan 06, 2014 12:29 pm    Post subject: Reply with quote

You can use wgetpaste to put it in a pastebin.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Tue Jan 07, 2014 4:45 am    Post subject: Reply with quote

does
Code:

startxfce4

work?

i know startx wont work if you dont have the default terminal emulator, and forget to echo exec startxfce4 to .xinitrc
Back to top
View user's profile Send private message
hasansahin
n00b
n00b


Joined: 03 Jun 2010
Posts: 12

PostPosted: Tue Jan 07, 2014 6:19 am    Post subject: Reply with quote

Yesterday night, I tried everything but no chance.

Activated KMS support
Installed linux-firmware package (radeon firmware support)
Deactivated framebuffer

But always get an error like : "kms modesetting isn't supported"

I tried to load the modele as manually with : modprobe radeon modeset=0 and 1

but no chance.

I installed fglrx and now it works. Someone says that Radeon 7790 chipset is problematic with KMS/Radeon OSS drivers.
_________________
Anyone who has never made a mistake has never tried anything new.
Albert Einstein.
Back to top
View user's profile Send private message
hasansahin
n00b
n00b


Joined: 03 Jun 2010
Posts: 12

PostPosted: Tue Jan 07, 2014 8:18 am    Post subject: Reply with quote

https://wiki.gentoo.org/wiki/Radeon

This wiki page says that :

Quote:
If you compiled radeon directly into the kernel instead of as a module, make sure firmware for your model (check available ones in /lib/firmware/radeon) is included in kernel


If I complied as a module, no need to define .config file like below?

Code:
Device Drivers  --->
    Generic Driver Options  --->
        -*- Userspace firmware loading support
        [*] Include in-kernel firmware blobs in kernel binary
            (radeon/<YOUR-MODEL>.bin)
            (/lib/firmware) Firmware blobs root directory


Also, I could not find a string called : "Enable modesetting on radeon by default". There was only */M > Ati Radeon

Code:
<*/M> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) --->
            <*/M> ATI Radeon
            [*] Enable modesetting on radeon by default

_________________
Anyone who has never made a mistake has never tried anything new.
Albert Einstein.
Back to top
View user's profile Send private message
N8Fear
Tux's lil' helper
Tux's lil' helper


Joined: 15 Apr 2013
Posts: 140
Location: Berlin (Germany)

PostPosted: Tue Jan 07, 2014 8:49 am    Post subject: Reply with quote

Just try to include the firmwareblob in the config. Can't hurt I think... ;)
If you want more help you need to ive more info: as stated above emerge wgetpaste and run wgetpaste /vaR/log/Xorg.0.log and post the link here afterwards...
Back to top
View user's profile Send private message
hasansahin
n00b
n00b


Joined: 03 Jun 2010
Posts: 12

PostPosted: Tue Jan 07, 2014 9:04 am    Post subject: Reply with quote

N8Fear wrote:
Just try to include the firmwareblob in the config. Can't hurt I think... ;)
If you want more help you need to ive more info: as stated above emerge wgetpaste and run wgetpaste /vaR/log/Xorg.0.log and post the link here afterwards...


Ja, genau :P

When I go back to my home, I will do so. Thanks.
_________________
Anyone who has never made a mistake has never tried anything new.
Albert Einstein.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum