Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
unresolvable ruby deps [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
katfish
Tux's lil' helper
Tux's lil' helper


Joined: 14 Nov 2011
Posts: 147

PostPosted: Mon Mar 17, 2014 12:38 pm    Post subject: unresolvable ruby deps [solved] Reply with quote

hi, while upgrade world I'm facing an issue with ruby18, which im unable to solve by myself.

Code:
emerge world -uDNt  --keep-going  -av

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "virtual/rubygems[ruby_targets_ruby18]" have been masked.
!!! One of the following masked packages is required to complete your request:
- virtual/rubygems-1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Manuel Rüger <mrueg@gentoo.org> (16 Mar 2014)
# Ruby 1.8 has no longer been supported upstream since July 2013 and
# has known security issues (bug #492282). Ruby packages in general
# are no longer compatible with ruby 1.8. Removal is tracked in bug
# 434064.
#
# This mask also includes all packages still depending in ruby 1.8.
# Removal in 30 days


(dependency required by "dev-ruby/spider-0.4.4-r1::pentoo[-test]" [installed])
(dependency required by "app-text/cewl-5.0::pentoo" [installed])
(dependency required by "pentoo/pentoo-cracking-2013.1::pentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Equery doesn't find any package that depends on virtual/rubygems[ruby_targets_ruby18]

What else could pull the masked virtual in?

Code:
equery depends virtual/rubygems-1
 * These packages depend on virtual/rubygems-1:
dev-ruby/ethon-0.5.11 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                      (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
dev-ruby/fast_xs-0.8.0-r1 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                          (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
                          (ruby_targets_ruby20 ? virtual/rubygems[ruby_targets_ruby20])
dev-ruby/ffi-1.4.0 (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
                   (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
dev-ruby/hoe-2.13.0-r1 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                       (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
                       (ruby_targets_ruby20 ? virtual/rubygems[ruby_targets_ruby20])
                       (ruby_targets_jruby ? virtual/rubygems[ruby_targets_jruby])
dev-ruby/hpricot-0.8.6-r1 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                          (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
                          (ruby_targets_jruby ? virtual/rubygems[ruby_targets_jruby])
dev-ruby/http_configuration-1.0.2-r1 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                                     (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
dev-ruby/json-1.8.0 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                    (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
                    (ruby_targets_ruby20 ? virtual/rubygems[ruby_targets_ruby20])
                    (ruby_targets_jruby ? virtual/rubygems[ruby_targets_jruby])
dev-ruby/mime-types-1.23 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                         (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
                         (ruby_targets_ruby20 ? virtual/rubygems[ruby_targets_ruby20])
                         (ruby_targets_jruby ? virtual/rubygems[ruby_targets_jruby])
dev-ruby/mini_exiftool-1.0.1-r1 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                                (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
dev-ruby/nokogiri-1.5.5 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                        (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
                        (ruby_targets_jruby ? virtual/rubygems[ruby_targets_jruby])
dev-ruby/racc-1.4.9 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                    (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
                    (ruby_targets_ruby20 ? virtual/rubygems[ruby_targets_ruby20])
                    (ruby_targets_jruby ? virtual/rubygems[ruby_targets_jruby])
dev-ruby/rake-0.9.6 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                    (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
                    (ruby_targets_ruby20 ? virtual/rubygems[ruby_targets_ruby20])
                    (ruby_targets_jruby ? virtual/rubygems[ruby_targets_jruby])
dev-ruby/rake-compiler-0.8.1 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                             (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
                             (ruby_targets_jruby ? virtual/rubygems[ruby_targets_jruby])
dev-ruby/rdoc-4.0.1-r1 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                       (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
                       (ruby_targets_ruby20 ? virtual/rubygems[ruby_targets_ruby20])
                       (ruby_targets_jruby ? virtual/rubygems[ruby_targets_jruby])
dev-ruby/rexical-1.0.5-r1 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                          (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
                          (ruby_targets_ree18 ? virtual/rubygems[ruby_targets_ree18])
                          (ruby_targets_jruby ? virtual/rubygems[ruby_targets_jruby])
dev-ruby/ruby-progressbar-1.4.1 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                                (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
                                (ruby_targets_jruby ? virtual/rubygems[ruby_targets_jruby])
dev-ruby/rubyzip-0.9.9 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                       (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
                       (ruby_targets_ree18 ? virtual/rubygems[ruby_targets_ree18])
dev-ruby/spider-0.4.4-r1 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                         (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
dev-ruby/terminal-table-1.4.5 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                              (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
dev-ruby/typhoeus-0.6.3 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                        (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
dev-ruby/yard-0.8.7.2 (ruby_targets_ruby18 ? virtual/rubygems[ruby_targets_ruby18])
                      (ruby_targets_ruby19 ? virtual/rubygems[ruby_targets_ruby19])
                      (ruby_targets_jruby ? virtual/rubygems[ruby_targets_jruby])
net-libs/webkit-gtk-2.2.5-r200 (virtual/rubygems[ruby_targets_ruby20])
                               (virtual/rubygems[ruby_targets_ruby21])
                               (virtual/rubygems[ruby_targets_ruby19])
                               (virtual/rubygems[ruby_targets_ruby18])


Last edited by katfish on Mon Mar 17, 2014 3:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Mon Mar 17, 2014 2:04 pm    Post subject: Reply with quote

Well, that dev-ruby/spider is from an overlay - that's probably the place you should start checking.
Back to top
View user's profile Send private message
katfish
Tux's lil' helper
Tux's lil' helper


Joined: 14 Nov 2011
Posts: 147

PostPosted: Mon Mar 17, 2014 3:24 pm    Post subject: Reply with quote

recompiling spider and few others with ruby19 support solved that issue.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum