Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
RandR settings in xorg.conf break GTK themes (XFCE)
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 24 Feb 2007
Posts: 1707
Location: Poland => Lodz

PostPosted: Tue Oct 22, 2013 8:09 pm    Post subject: RandR settings in xorg.conf break GTK themes (XFCE) Reply with quote

I decided to clean things up and instead of running xrandr after login I devised such settings:
$ cat /etc/X11/xorg.conf.d/50-monitor.conf

Section "Monitor"
   Identifier    "U2410"
   Option       "PreferredMode" "1920x1200"

Section "Monitor"
   Identifier    "L72D"

   HorizSync    31.0-80.0
   VertRefresh    56-75

#   DisplaySize    337.92 270.93

   Modeline    "1280x1024@75"  138.75  1280 1368 1504 1728  1024 1027 1034 1072 -hsync +vsync

   Option       "PreferredMode" "1280x1024@75"
   Option      "RightOf"   "U2410"

Section "Device"
   Identifier    "Card0"
   Driver       "nouveau"

   BoardName   "NVIDIA NV4c"

   Option       "Monitor-DVI-I-1" "U2410"
   Option       "Monitor-DVI-I-2" "L72D"

I need the Modeline because my L72D has a borked EDID.

Now my ever-beloved (it's just fine so I've been using it for years) Clearlooks theme is not set.

If I run xrandr to add the modeline and set everything after starting XFCE then it looks just fine.

Now I seem to have some default theme with everything sharp and rectangular. Commenting out the monitor sections and options solves everything - no changes to gtkrc or anything else.

After starting XFCE from a VT and redirecting stdout and stderr to file I got this:
$ cat startxfce4.log
/usr/bin/startxfce4: Starting X server

X.Org X Server 1.14.3
Release Date: 2013-09-12
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.8.13-gentoo x86_64 Gentoo
Current Operating System: Linux atuin 3.10.7-gentoo-r1 #3 SMP PREEMPT Sat Oct 19 17:12:41 CEST 2013 x86_64
Kernel command line: dolvm rootfstype=ext4 real_root=/dev/atuin/slash console=tty1 k10temp.force=1
Build Date: 19 October 2013  05:55:46PM
Current version of pixman: 0.30.2
   Before reporting problems, check
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Oct 22 22:06:57 2013
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
resize called 3200 1200
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
QGtkStyle was unable to detect the current GTK+ theme.
** Message: applet now removed from the notification area

(xfsettingsd:10613): xfsettingsd-WARNING **: Unknown mode '1280x1024 @ 74,9' for output DVI-I-2.

The program 'xfsettingsd' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 132 error_code 8 request_code 139 minor_code 7)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

HP Linux Imaging and Printing System (ver. 3.13.9)
System Tray Status Service ver. 2.0

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/ RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
QGtkStyle was unable to detect the current GTK+ theme.

** (wrapper:10674): WARNING **: Binding 'XF86AudioLowerVolume' failed!

** (wrapper:10674): WARNING **: Binding 'XF86AudioRaiseVolume' failed!

** (wrapper:10674): WARNING **: Binding 'XF86AudioMute' failed!
xinit: connection to X server lost
xscreensaver: 22:07:05: SIGHUP received: restarting...
xscreensaver: 22:07:05: running as szczerb/szczerb (1000/1000)

waiting for X server to shut down xscreensaver: 22:07:05: Can't open display: :0.0
xscreensaver: 22:07:05: running as szczerb/szczerb (1000/1000)

xscreensaver: 22:07:05: Errors at startup are usually authorization problems.
              But you're not logging in as root (good!) so something
              else must be wrong.  Did you read the manual and the FAQ?


(EE) Server terminated successfully (0). Closing log file.

So QGtkStyle (probably called by hplip) is complaining but that's it.

Any thoughts?
Back to top
View user's profile Send private message

Joined: 05 Jan 2014
Posts: 1

PostPosted: Sun Jan 05, 2014 4:01 am    Post subject: Reply with quote

I ran into this same problem after changing my xorg.conf. Deleting the following file brought back my old theme:

It seemed to contain out of date info about the monitor config and was tripping up xfce.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum