Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
DHCPCD doesn't work at boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
moisespedro
n00b
n00b


Joined: 01 Jan 2014
Posts: 71

PostPosted: Fri Jan 03, 2014 2:22 pm    Post subject: DHCPCD doesn't work at boot Reply with quote

Hi, just got my first gentoo box running and I can't make the network to start at boot. I have to log as root, run dhcpcd once, kill the proccess, run it again and the it starts working (on enps02 interface, not really sure).
Back to top
View user's profile Send private message
moisespedro
n00b
n00b


Joined: 01 Jan 2014
Posts: 71

PostPosted: Fri Jan 03, 2014 10:31 pm    Post subject: Reply with quote

Anyone?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43799
Location: 56N 3W

PostPosted: Fri Jan 03, 2014 11:20 pm    Post subject: Reply with quote

moisespedro,

Thats net.enps02 ... see your other thread
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
tpereira
n00b
n00b


Joined: 21 Feb 2013
Posts: 23

PostPosted: Thu May 08, 2014 4:44 pm    Post subject: Reply with quote

Can you run dhcpcd -d several times and post results? I may have similar problems. Sometimes, I get a lease expired, than a timeout and end up with no ip address. Sometimes everything goes well.

I sort of solved it by doing the following:

1. add to /etc/conf.d/net
config_eth0="noop"

2. move the service net.eth0 to runlevel boot

3. add the service dhcpcd tp runlevel default

I know this is not really fixing the problem...
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Thu May 08, 2014 6:51 pm    Post subject: Reply with quote

tpereira ...

Not sure this is entirely the same problem ...though again, dhcpcd is being used outside of it being run by net.${IFACE}. Anyhow, here is a link to my reply to your other similar post

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum