Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problem getting kdm to start
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message

Joined: 22 Aug 2004
Posts: 25

PostPosted: Wed Jan 01, 2014 10:55 pm    Post subject: problem getting kdm to start Reply with quote

I just did a stage3 install, and I have startx working but I can't get kdm to work. The system boots up to level 3, and the command startx, works but I get three grafic terminals. If I close 2 of them and use the command startkde, KDE initiates with no problem. I attempted to make kdm run by using rc-update add kdm, but this did not work.
Everything is working great both as user and root, except for this one problem.
I looked for the /etc/X11/xorg.conf file, and it is non existant. How do I generate an /etc/X11/xorg.conf file?

# emerge --info
Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.16.0, 3.10.17-gentoo x86_64)
System uname: Linux-3.10.17-gentoo-x86_64-AMD_Athlon-tm-_II_X4_635_Processor-with-gentoo-2.2
KiB Mem: 6116560 total, 4469204 free
KiB Swap: 1696764 total, 1696764 free
Timestamp of tree: Tue, 31 Dec 2013 05:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash: 4.2_p45
dev-lang/python: 2.7.5-r3, 3.3.2-r2
dev-util/pkgconfig: 0.28
sys-apps/baselayout: 2.2
sys-apps/openrc: 0.12.4
sys-apps/sandbox: 2.6-r1
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.12.6, 1.13.4
sys-devel/binutils: 2.23.2
sys-devel/gcc: 4.7.3-r1
sys-devel/gcc-config: 1.7.3
sys-devel/libtool: 2.4.2
sys-devel/make: 3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc: 2.16.0
Repositories: gentoo
CFLAGS="-march=athlon64 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=athlon64 -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 audio berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli colord colordiff consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv ipv6 jpeg kde kipi lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qt3support qt4 readline sdl semantic-desktop session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog disk email numa" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

You can't run out of skill, but you sure can run out of luck.
Back to top
View user's profile Send private message

Joined: 21 Dec 2002
Posts: 301
Location: 39.885° N. -88.913° W.

PostPosted: Thu Jan 02, 2014 2:10 am    Post subject: Reply with quote

Add this if you don't have it.
DISPLAYMANAGER="kdm" into /etc/conf.d/xdm

Then do this.

# rc-update add xdm default

See if this will help you. This is what I have.

Not sure if you really need this file unless your having some other problem.
/etc/X11/xorg.conf file
Back to top
View user's profile Send private message

Joined: 22 Aug 2004
Posts: 25

PostPosted: Thu Jan 02, 2014 3:17 am    Post subject: Reply with quote

I updated /etc/conf.d/xdm, and found that it was selected for gdm. I changed it to kdm, but I didn't even emerge gdm.
Before my initial posting, I had attempted to do an rc-update, and it failed with an error message that kdm does not exist. I just finished attempting this same command again,
rc-update add kdm default
this is the error message ---* rc-update: service `kdm' does not exist
I used emerge search, and kdm is emerged

I will now do a reboot to see what happens.
You can't run out of skill, but you sure can run out of luck.
Back to top
View user's profile Send private message

Joined: 22 Aug 2004
Posts: 25

PostPosted: Thu Jan 02, 2014 4:29 am    Post subject: [solved] Reply with quote

I edited the /etc/conf.d/xdm file display_manager to kdm. I did the rc-update add xdm default again, and this time it worked. my system is now FULLY OPERATIONAL from scratch, using the stage 3 tarall!
Thanks for the help.
You can't run out of skill, but you sure can run out of luck.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum