Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Chinese as a second language, but I CANT speak chineses
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
zlodej
n00b
n00b


Joined: 01 Jan 2014
Posts: 1
Location: Sheffield

PostPosted: Wed Jan 01, 2014 9:25 pm    Post subject: Chinese as a second language, but I CANT speak chineses Reply with quote

I use XFCE4 and cinnamon
It is a new installation using systemd rather then openRC.
OpenRC used o give you a choice of second language So for example in mine case I have used locales for slovak, if not translated then Czech, then Briish english and keeping American Enlish and Russian as a backup
in systemdI could only chose one language (slovak) this has got interesting effect of things whitch are not translated to the target language dysplaying either in English or more commonly in chinese symbols.
this means that I can not debug anything based on terminals output, as it comes out in chinese.
Quote:
asi@broadband:~$ skype
bash: /opt/bin/skype: 无法执行二进制文件

The menu entries I can guess by icons
How can I change these chinese parts into English?

Update:
Code:
Locale not supported by C library.
   Using the fallback 'C' locale.

Which mean that chinese suppose to be the clocale
Question now stands:
How do I change 'C' Locale to English?
_________________
"How quick they grow"
"I miss them being so small"
Then give more purpose to your life after your children grown and Foster. It makes you far more usefull then being general manager of Hamburger restaurant chain
Back to top
View user's profile Send private message
fturco
Guru
Guru


Joined: 08 Dec 2010
Posts: 574
Location: Italy

PostPosted: Thu Jan 02, 2014 10:32 am    Post subject: Reply with quote

Did you read the Localization HOWTO? You may try to set the Slovak locale with the localectl command.
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6276

PostPosted: Thu Jan 02, 2014 12:51 pm    Post subject: Reply with quote

There seem to be a lot of misunderstandings.
FIrst of all, 'C' locale is not "Chinese" but "C"-the computer language (which means English without special number/sorting conventions).
Second, it is not possible for standard programs using locale to specify a language and a "fallback" language. Probably the chinese characters come from strange settings of your locale variables (type "locale" to see the settings); probably you have some "traditional" iso-xxxx character set while your terminal assume UTF-8, and by accident, the corresponding characters in UTF-8 are chinese characters. Nowadays, you almost certainly want to select only "sl_SL.UTF-8" (here I guessed only that sl and SL means slovak language/country - probably you know better).
Third, your error message means that you have specified a locale for which you have not generated the corresponding data with "locale-gen": You must only specify locales which you have listed in /etc/locale.gen (with the exception of "C" and "POSIX" [practically the same as "C"] which are always available); if you modify that file you must call locale-gen afterwards.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum