Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Trouble reading dependency graph
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
augustin2
Apprentice
Apprentice


Joined: 16 Mar 2012
Posts: 164
Location: France

PostPosted: Sat Dec 28, 2013 8:12 am    Post subject: [SOLVED]Trouble reading dependency graph Reply with quote

Hi

I have trouble uderstanding dependency graph.

Quote:
kitsune@localhost ~ $ equery g anki
* Searching for anki ...

* dependency graph for app-misc/anki-2.0.12
`-- app-misc/anki-2.0.12 amd64
`-- dev-lang/python-2.6.8-r3 (>=dev-lang/python-2.6.8-r3) amd64 [sqlite]
`-- dev-lang/python-2.7.5-r3 (>=dev-lang/python-2.7.5-r2) amd64 [sqlite]
`-- dev-lang/python-exec-2.0.1 (dev-lang/python-exec) amd64 [python_targets_python2_6(-)? python_targets_python2_7(-)? python_single_target_python2_6(+)? python_single_target_python2_7(+)?]
`-- dev-python/PyQt4-4.10.2 (dev-python/PyQt4) amd64 [X svg webkit]
`-- dev-python/httplib2-0.7.6 (>=dev-python/httplib2-0.7.4) amd64
`-- dev-python/beautifulsoup-3.2.1-r1 (dev-python/beautifulsoup) amd64
`-- dev-python/send2trash-1.2.0 (dev-python/send2trash) amd64
`-- media-sound/lame-3.99.5 (media-sound/lame) amd64
`-- dev-python/pyaudio-0.2.7 (>=dev-python/pyaudio-0.2.4) amd64
`-- media-video/mplayer-1.1.1-r1 (media-video/mplayer) amd64
`-- app-text/texlive-2012 (app-text/texlive) amd64
`-- app-text/dvipng-1.14 (app-text/dvipng) amd64
[ app-misc/anki-2.0.12 stats: packages (13), max depth (1) ]

* dependency graph for app-misc/anki-2.0.19
`-- app-misc/anki-2.0.19 [~amd64 keyword]
`-- dev-lang/python-2.6.8-r3 (>=dev-lang/python-2.6.8-r3) amd64 [sqlite]
`-- dev-lang/python-2.7.5-r3 (>=dev-lang/python-2.7.5-r2) amd64 [sqlite]
`-- dev-lang/python-exec-2.0.1 (dev-lang/python-exec) amd64 [python_targets_python2_6(-)? python_targets_python2_7(-)? python_single_target_python2_6(+)? python_single_target_python2_7(+)?]
`-- dev-python/PyQt4-4.10.2 (dev-python/PyQt4) amd64 [X svg webkit]
`-- dev-python/httplib2-0.7.6 (>=dev-python/httplib2-0.7.4) amd64
`-- dev-python/beautifulsoup-3.2.1-r1 (dev-python/beautifulsoup) amd64
`-- dev-python/send2trash-1.2.0 (dev-python/send2trash) amd64
`-- media-sound/lame-3.99.5 (media-sound/lame) amd64
`-- dev-python/pyaudio-0.2.7 (>=dev-python/pyaudio-0.2.4) amd64
`-- media-video/mplayer-1.1.1-r1 (media-video/mplayer) amd64
`-- app-text/texlive-2012 (app-text/texlive) amd64
`-- app-text/dvipng-1.14 (app-text/dvipng) amd64
[ app-misc/anki-2.0.19 stats: packages (13), max depth (1) ]

* dependency graph for app-misc/anki-2.0.20
`-- app-misc/anki-2.0.20 [~amd64 keyword]
`-- dev-lang/python-2.6.8-r3 (>=dev-lang/python-2.6.8-r3) amd64 [sqlite]
`-- dev-lang/python-2.7.5-r3 (>=dev-lang/python-2.7.5-r2) amd64 [sqlite]
`-- dev-lang/python-exec-2.0.1 (dev-lang/python-exec) amd64 [python_targets_python2_6(-)? python_targets_python2_7(-)? python_single_target_python2_6(+)? python_single_target_python2_7(+)?]
`-- dev-python/PyQt4-4.10.2 (dev-python/PyQt4) amd64 [X svg webkit]
`-- dev-python/httplib2-0.7.6 (>=dev-python/httplib2-0.7.4) amd64
`-- dev-python/beautifulsoup-3.2.1-r1 (dev-python/beautifulsoup) amd64
`-- dev-python/send2trash-1.2.0 (dev-python/send2trash) amd64
`-- media-sound/lame-3.99.5 (media-sound/lame) amd64
`-- dev-python/pyaudio-0.2.7 (>=dev-python/pyaudio-0.2.4) amd64
`-- media-video/mplayer-1.1.1-r1 (media-video/mplayer) amd64
`-- app-text/texlive-2012 (app-text/texlive) amd64
`-- app-text/dvipng-1.14 (app-text/dvipng) amd64
[ app-misc/anki-2.0.20 stats: packages (13), max depth (1) ]
kitusune@localhost ~ $

From this I understand:
1 - that there are several version of anki available in the portage tree
2 - that only anki-2.0.12 is in the stable branch

What I have trouble understanding is this part:
Quote:
* dependency graph for app-misc/anki-2.0.12
`-- app-misc/anki-2.0.12 amd64
`-- dev-lang/python-2.6.8-r3 (>=dev-lang/python-2.6.8-r3) amd64 [sqlite]
`-- dev-lang/python-2.7.5-r3 (>=dev-lang/python-2.7.5-r2) amd64 [sqlite]


Does this mean that :
1- the 2 versions of dev-lang/python are necessary to anki-2.0.12 with the sqlite USE flag enabled
or
2- the version 2.7.5-r3 with sqlite USE flag enabled is enough as it answers both requirements >=...2.6.8-r3 and >=...2.7.5-r2 ?
If the answer is 2, why does the graph speak of 2.6.8-r3 ?


Last edited by augustin2 on Sat Dec 28, 2013 12:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2372
Location: Hilbert space

PostPosted: Sat Dec 28, 2013 11:35 am    Post subject: Reply with quote

anki.ebuild wrote:
PYTHON_COMPAT=( python2_6 python2_7 )
PYTHON_REQ_USE="sqlite"

This tells you that you need either python2_6 or python2_7,
whatever version you get must be installed USE=+sqlite

Then everything will depend on your settings for PYTHON_TARGETS and PYTHON_SINGLE_TARGET

On my system, having PYTHON_SINGLE_TARGET=PYTHON_TARGET="python2_7",
anki will depend on my python2_7 implementation.

So clearly, answering your exact question : Your n° 2 is the correct one.
Why does the graph mention 2.6.8 like it does, I cannot tell.
_________________
Back to top
View user's profile Send private message
augustin2
Apprentice
Apprentice


Joined: 16 Mar 2012
Posts: 164
Location: France

PostPosted: Sat Dec 28, 2013 12:44 pm    Post subject: Reply with quote

Thank you very much.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum