Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] modprobe failure
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
yee
n00b
n00b


Joined: 16 Sep 2004
Posts: 39

PostPosted: Fri Dec 27, 2013 1:58 am    Post subject: [SOLVED] modprobe failure Reply with quote

I am having problems with X. I have traced the problem to the failure of the video driver kernel module, radeon. It fails to load automatically.

Trying "modprobe -v radeon", I realized that the problem lies in a dependency where modprobe attempts to load the module drm_kms_helper which fails due to an illegal option.

If I manually "modprobe -v drm_kms_helper" and then "modprobe -v radeon" works.

The illegal option is "insmod /lib/modules/....../drm_kms_helper edid_firmware=VGA-1:edid/1024x768.bin"

At one point, I did add this string to /etc/grub/grub.conf during my adventures in trying to figure out why X fails but have since removed it. Where else could modprobe be looking to add this string? Is the string in an environment variable that I am not aware of?

Conway Yee

It turns out that the option DOES lie in grub.conf. Apparently grub.conf DOES NOT HONOR THE # sign as a comment for everything that follows. The line in question has two pound signs. The first in front of the option for drm_kms_helper. The option was being passed to the kernel even though it follows the pound sign!

Conway Yee
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum