Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
First Gentoo build, having trouble getting X working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ptchinster
n00b
n00b


Joined: 26 Dec 2013
Posts: 3

PostPosted: Thu Dec 26, 2013 10:28 pm    Post subject: First Gentoo build, having trouble getting X working Reply with quote

I inherited i nice new Alienware laptop from a friend, who had Gentoo running it. I've been using Arch for the last few years and have been meaning to switch to Gentoo, and figured it was a good opportunity to do so.

I got a base system running, and when i went to try to get X working (with XFCE4 to come next), i keep getting no device found errors. Ive compiled the drivers into the kernel, ive included the right settings in my make.conf file (i think), and i think my problem is that im not telling it to switch over to the NVIDIA card from the onboard intel one...

Error log when running 'startx' : http://bpaste.net/show/161964/

lspcia -kvm : http://bpaste.net/show/161965/

cat make.conf : http://bpaste.net/show/161966/

Ive run into other posts talking about bumblebee, but the guy who had the laptop before me ran gentoo on it and didnt use bumblebee.

Any hints would be appreciated!
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Fri Dec 27, 2013 1:53 am    Post subject: Reply with quote

What's the output of 'emerge -1pv xf86-video-nouveau mesa xorg-server libdrm' ?
Basic KMS setup seems OK, at least xserver doesn't complain about it, but pastebin your kernel config for completeness.
Back to top
View user's profile Send private message
ptchinster
n00b
n00b


Joined: 26 Dec 2013
Posts: 3

PostPosted: Fri Dec 27, 2013 3:20 am    Post subject: Reply with quote

VoidMage wrote:
What's the output of 'emerge -1pv xf86-video-nouveau mesa xorg-server libdrm' ?
Basic KMS setup seems OK, at least xserver doesn't complain about it, but pastebin your kernel config for completeness.


emerge -1pv xf86-video-nouveau mesa xorg-server libdrm
http://bpaste.net/show/162023/

zcat /proc/config.gz
http://bpaste.net/show/162025/
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Fri Dec 27, 2013 7:03 am    Post subject: Reply with quote

ptchinster wrote:
emerge -1pv xf86-video-nouveau mesa xorg-server libdrm
http://bpaste.net/show/162023/


:roll: '-v' wasn't a typo...
Back to top
View user's profile Send private message
ptchinster
n00b
n00b


Joined: 26 Dec 2013
Posts: 3

PostPosted: Fri Dec 27, 2013 2:44 pm    Post subject: Reply with quote

VoidMage wrote:
ptchinster wrote:
emerge -1pv xf86-video-nouveau mesa xorg-server libdrm
http://bpaste.net/show/162023/


:roll: '-v' wasn't a typo...


oops...
http://pastebin.com/raw.php?i=5bryhy98
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum