Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PolicyKit broken after update to KDE 4.11.2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
nipennem
n00b
n00b


Joined: 29 Jul 2011
Posts: 3

PostPosted: Thu Dec 26, 2013 1:11 pm    Post subject: PolicyKit broken after update to KDE 4.11.2 Reply with quote

I recently updated my desktop to KDE 4.11.2. The system was working perfectly fine before the update.

After rebooting, I noticed I was unable to mount filesystems in KDE. For some silly reason it seems the 'Actions Policy' module was removed from System Settings without providing a useful replacement, so I cannot attempt to fix things from there.

With ck-list-sessions I still see that a session is active on /dev/tty7 etc. But even command-line mounting with udisks just gives me "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.". Occasionally, I also get "not authorized". When I try to use pkexec I always get "not authorized".

Any ideas?
Back to top
View user's profile Send private message
jesnow
Guru
Guru


Joined: 26 Apr 2006
Posts: 581

PostPosted: Wed Jul 02, 2014 6:33 pm    Post subject: Reply with quote

Previous discussion on this here:
https://forums.gentoo.org/viewtopic-t-970714-highlight-jesnow.html

Read to the emd for the solution.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum