Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ruby 2.1 will be pulled in
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Mike81
n00b
n00b


Joined: 05 Jan 2011
Posts: 39

PostPosted: Sun Dec 29, 2013 11:51 am    Post subject: Ruby 2.1 will be pulled in Reply with quote

Hi,

I am on "~ARCH" and this is what emerge wants to update:
Code:

# emerge --ask --verbose --update --deep --with-bdeps=y --tree --newuse world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] dev-lang/ruby-2.1.0:2.1 [1.9.3_p484:1.9, 2.0.0_p353:2.0] USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -rubytests -socks5 -tk -xemacs"
[ebuild     U  ]  dev-ruby/rdoc-4.0.1-r2 [4.0.1-r1] USE="-doc {-test}" RUBY_TARGETS="ruby19 ruby20 ruby21%* -jruby -ruby18" 0 kB
[ebuild   R    ]   dev-ruby/racc-1.4.10  USE="-doc {-test}" RUBY_TARGETS="ruby19 ruby20 ruby21%* -jruby -ruby18" 0 kB
[ebuild   R    ]   dev-ruby/json-1.8.1  USE="-doc {-test}" RUBY_TARGETS="ruby19 ruby20 ruby21%* -jruby -ruby18" 0 kB
[ebuild     U  ]    dev-ruby/rake-0.9.6-r1 [0.9.6] USE="-doc {-test}" RUBY_TARGETS="ruby19 ruby20 ruby21%* -jruby -ruby18" 0 kB
[ebuild  NS    ]     virtual/rubygems-7:ruby21 [4:ruby19, 6:ruby20] RUBY_TARGETS="(ruby21)" 0 kB
[ebuild     U  ]      dev-ruby/rubygems-2.0.14 [2.0.10] USE="-server {-test}" RUBY_TARGETS="ruby19 ruby20 ruby21%* -jruby -ruby18" 330 kB
[ebuild  NS    ]       dev-lang/ruby-2.1.0:2.1 [1.9.3_p484:1.9, 2.0.0_p353:2.0] USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -rubytests -socks5 -tk -xemacs" 11,728 kB
[ebuild     U  ]        sys-libs/readline-6.2_p5 [6.2_p4] USE="-static-libs" 3 kB

Total: 14 packages (10 upgrades, 2 in new slots, 2 reinstalls), Size of downloads: 15,035 kB

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-lang/ruby-2.1.0
# required by virtual/rubygems-7
# required by dev-ruby/rake-0.9.6-r1[-test,ruby_targets_ruby21]
# required by dev-ruby/racc-1.4.10[-test,ruby_targets_ruby20]
# required by dev-ruby/rdoc-4.0.1-r2[ruby_targets_ruby20]
# required by dev-lang/ruby-1.9.3_p484[rdoc]
# required by dev-ruby/json-1.8.1[ruby_targets_ruby19]
# required by dev-lang/ruby-2.0.0_p353
# required by virtual/rubygems-6
>=dev-ruby/rubygems-2.0.14 ruby_targets_ruby21
# required by dev-ruby/rdoc-4.0.1-r2[ruby_targets_ruby21]
# required by dev-lang/ruby-2.1.0[rdoc]
# required by virtual/rubygems-7
# required by dev-ruby/rake-0.9.6-r1[-test,ruby_targets_ruby21]
# required by dev-ruby/racc-1.4.10[-test,ruby_targets_ruby20]
>=dev-ruby/json-1.8.1 ruby_targets_ruby21
# required by dev-lang/ruby-2.1.0[rdoc]
# required by virtual/rubygems-7
# required by dev-ruby/rake-0.9.6-r1[-test,ruby_targets_ruby21]
# required by dev-ruby/racc-1.4.10[-test,ruby_targets_ruby20]
>=dev-ruby/rdoc-4.0.1-r2 ruby_targets_ruby21
# required by dev-lang/ruby-2.1.0
# required by virtual/rubygems-7
# required by dev-ruby/racc-1.4.10
# required by dev-ruby/rdoc-4.0.1-r2[ruby_targets_ruby20]
# required by dev-lang/ruby-1.9.3_p484[rdoc]
# required by dev-ruby/rubygems-2.0.14[ruby_targets_ruby19]
# required by dev-lang/ruby-2.0.0_p353
# required by dev-ruby/json-1.8.1[ruby_targets_ruby20]
>=dev-ruby/rake-0.9.6-r1 ruby_targets_ruby21
# required by dev-ruby/rdoc-4.0.1-r2[ruby_targets_ruby21]
# required by dev-lang/ruby-2.1.0[rdoc]
# required by virtual/rubygems-7
# required by dev-ruby/rake-0.9.6-r1[-test,ruby_targets_ruby21]
# required by dev-ruby/json-1.8.1[-doc,-test,ruby_targets_ruby19]
# required by dev-lang/ruby-2.0.0_p353
# required by dev-ruby/rubygems-2.0.14[ruby_targets_ruby20]
# required by virtual/rubygems-4
>=dev-ruby/racc-1.4.10 ruby_targets_ruby21


I have set

Code:

RUBY_TARGETS="ruby19 ruby20"

in my /etc/portage/make.conf.


  • Why will dev-lang/ruby-2.1.0:2.1 be pulled in?
  • If I add rub21 to RUBY_TARGETS I would expect that I don't have to make the package.use changes (I never had to do that for ruby19 or ruby20). But it doesn't change anything. Or does the error from https://bugs.gentoo.org/show_bug.cgi?id=483254 now pops up for 2.1, too?!
Back to top
View user's profile Send private message
Whissi
n00b
n00b


Joined: 12 Jan 2011
Posts: 9

PostPosted: Sun Dec 29, 2013 12:14 pm    Post subject: Reply with quote

I think ruby-2.1.0 got pulled in, because you have installed "dev-lang/ruby" (no specific version/slot). Now, because a new version became available, it was pulled in.

Regarding the second question, why adding "ruby21" to RUBY_TARGETS didn't work I have no answer. I had the same problem. I solved this by adding a temporarily mask for =dev-lang/ruby-2.1.0:2.1. Now I was able to update the system without further modifications.
After the system was updated, I removed the mask entry for ruby-2.1, added "ruby21" to RUBY_TARGETS in my "/etc/portage/make.conf" and everything went fine.
_________________
Regards,
Whissi
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum