Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] XFCE Permissions and Suspend Questions
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
stoa
n00b
n00b


Joined: 23 Dec 2013
Posts: 10

PostPosted: Mon Dec 23, 2013 5:19 pm    Post subject: [SOLVED] XFCE Permissions and Suspend Questions Reply with quote

Hi everyone:

I just completed my first Gentoo install a couple of weeks ago and am having a few small issues with XFCE.

First, I can only intermittantly autmount USB flash drives; even when they show up in filemanager, I cannot access them. The error I receive is "Permission Denied." I do have udisks installed and I have enabled hotplugging in the XFCE settings manager. I can mount usb drives in the shell as root using udisks (at least I was able to - I haven't checked in about a week.)

Second, I am missing the ability to suspend or swith user - the icons are grey-ed out. This post https://forums.gentoo.org/viewtopic-t-835178-start-0.html dealt with both issues, but the post is over 3 1/2 years old and concerns HAL, in part.

Please let me know what further information you need and I look forward to any suggestions that may help. Thanks.


Last edited by stoa on Tue Dec 24, 2013 2:12 am; edited 1 time in total
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1361
Location: Montréal

PostPosted: Mon Dec 23, 2013 8:26 pm    Post subject: Reply with quote

Hello,

If you start Xorg via a display manager (Xdm, Kdm, Gdm, Lxdm, etc) in principle they take in charge of starting a ConsoleKit session for the user. An active Consolekit session allow to suspend, change user, etc.

If you start Xorg with the startx command, you may need to start Xfce with ConsoleKit in your ~/.xinitrc like this
Code:
exec ck-launch-session dbus-launch --sh-syntax --exit-with-session startxfce4

You can check anytime the list of ConsoleKit sessions open with the command
Code:
ck-list-sessions

A consoleKit session should resolv your issues at least for suspend.

Access the blocks devices for a non root user may depend on the disk group he have to be in. Some USE flags like dbus, gvfs, udev and udisks may change the behavior of Thunar. Dbus is not only a bus, it's a buss, it decide a lot of what a user can access in an X session.

You can allow a non root user to mount and unmount filesystems in /etc/fstab too.
_________________
Paul
Back to top
View user's profile Send private message
stoa
n00b
n00b


Joined: 23 Dec 2013
Posts: 10

PostPosted: Mon Dec 23, 2013 10:48 pm    Post subject: Reply with quote

Hi Logicien, thanks for the reply. I had initially set up ConsoleKit when installing the OS, but it was throwing errors on boot so I disabled it. I'm not sure the kernel configuration is correct - I'll have to check. The output from ck-list-sessions was

Code:
ck-list-sessions
** Message: Failed to connect to the D-Bus daemon: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory


I do have the udev, gvfs, X, dbus, and udisks USE flags set.

Even though the ConsoleKit wiki claims it is for multi-user set-ups (which, unless you count root, this is a single-user machine), it also claims it won't hurt on a single-user. So, I'll dig into the kernel config and make sure its set for auditing and re-enable ConsoleKit.

I really don't want to get into adding to /etc/fstab, although I've had to do that before and it does work, but not well. Usually (I use xfce on four different distros) gvfs does the trick.

Thanks again.
Back to top
View user's profile Send private message
stoa
n00b
n00b


Joined: 23 Dec 2013
Posts: 10

PostPosted: Tue Dec 24, 2013 2:11 am    Post subject: Reply with quote

Logicien:

The solution was a combination of d-bus, which gave automount to usb and other drives, and ConsoleKit which gave the permissions to enter them and also enabled suspend.

For the benefit of others who may have this problem, my ck-list-sessions is now:

Code:
gentoo ~ # ck-list-sessions
Session1:
   unix-user = '1000'
   realname = '(null)'
   seat = 'Seat1'
   session-type = ''
   active = FALSE
   x11-display = ''
   x11-display-device = ''
   display-device = '/dev/tty1'
   remote-host-name = ''
   is-local = TRUE
   on-since = '2013-12-24T01:53:48.778638Z'
   login-session-id = '2'
   idle-since-hint = '2013-12-24T01:54:22.190996Z'
Session2:
   unix-user = '1000'
   realname = '(null)'
   seat = 'Seat1'
   session-type = ''
   active = TRUE
   x11-display = ':0'
   x11-display-device = '/dev/tty7'
   display-device = '/dev/tty1'
   remote-host-name = ''
   is-local = TRUE
   on-since = '2013-12-24T01:53:56.644412Z'
   login-session-id = '2'
gentoo ~ #


I'm back to getting the errors scrolling by at boot re: ConsoleKit, but it's working.

Thanks much for your help, and I'll mark this as solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum