Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to get Intel drivers to work with my system?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
urbasiuse
n00b
n00b


Joined: 19 Dec 2013
Posts: 2

PostPosted: Thu Dec 19, 2013 10:29 am    Post subject: How to get Intel drivers to work with my system? Reply with quote

Hello. It's been 4 days since I am trying to get my graphics to work. It's very strange issue, so I will start from my /etc/portage/make.conf file - there is VIDEO_CARDS=intel, there is proper USE flags. X server and XFCE4 are working, but only vesa driver. I don't have xorg.conf file in /etc/X11, so system uses it's location xorg.conf in /usr/share/X11/xorg.conf.d/. I can't use this command X -configure and I get this 'Server is already active for display 0'. Vesa is not that bad, but resolution is small. My computer is laptop Asus A53S and it has hybrid video card. It's Nvidia GT 540M. I heard about optimus technology and I don't know what to do. I spent 4 days in Gentoo. It was great experience. I learned a lot! Never been so far. Two years ago I failed a lot while trying to install it, but these time it was better. It's fun. Any help would be great! I will provide you with more information. Sorry for bad english grammar.
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Thu Dec 19, 2013 1:24 pm    Post subject: Reply with quote

You have an nvidia dedicated graphics card and want the CPU embedded intel HD?

On my intel-only laptop I have this in my make.conf:
Code:
~ $ grep VIDEO /etc/portage/make.conf
VIDEO_CARDS="i965 intel fbdev vesa"
You might want to try to add "nvidia" to the value.

However, X needs to know which driver to use, so you will need an xorg.conf file for either.

Mixing Intel HD and nvidia is discussed here.

Setting up nvidia graphics is documented here.

I'd ditch the inferior intel HD anytime if I'd have a dedicated nvidia card in my laptop...
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
urbasiuse
n00b
n00b


Joined: 19 Dec 2013
Posts: 2

PostPosted: Thu Dec 19, 2013 4:04 pm    Post subject: Reply with quote

I checked your links, but it does not help me at all. I downloaded nvidia drivers. Then I used command nvidia-xconfig. Then I used start and there was famous no screens found error. Later I modified xorg.conf and added BusID line and then some magic happened. It looks like system accepts extensions.

Loading extension GLX
Loading extension NV-GLX
Loading extension NV-CONTROL
setversion 1.4 failed

And that's it. There is no graphical display.

I can't understand why system doesn't use intel driver. I don't know what to do at all. I am stuck.
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Thu Dec 19, 2013 5:42 pm    Post subject: Reply with quote

Okay. The long version, then, maybe we can sort this out. ;)

Intel Graphics Drivers:
These need KMS activated in the kernel. So the kernel running should be compiled with these options:
Code:
 ~ $ grep -P "DRM_(KMS|I9)" /usr/src/linux/.config
CONFIG_DRM_KMS_HELPER=y
CONFIG_DRM_I915=y
CONFIG_DRM_I915_KMS=y
# CONFIG_DRM_I915_PRELIMINARY_HW_SUPPORT is not set
If you do not have these, your system will boot in a low resolution console. If KMS is enabled, the console resolution *should* match your screen resolution. However, apart from this, X can't use the intel driver without KMS enabled.

Nvidia Graphics Drivers:
First of all: The framebuffer driver nvidiafb is incompatible with current graphics driver. So it must be deactivated in your kernel like this:
Code:
 ~ $ grep FB_NVIDIA /usr/src/linux/.config
# CONFIG_FB_NVIDIA is not set
The easiest way to get the driver is to add "nvidia" to your VIDEO_CARDS list in /etc/portage/make.conf, followed by an "emerge --update --deep --newuse @world".

However, you have to set opengl to actually use the driver:
Code:
 ~ # eselect opengl list
Available OpenGL implementations:
  [1]   xorg-x11 *
  [2]   nvidia
 ~ # eselect opengl set 2
Switching to nvidia OpenGL interface... done
Actually, after installing the nvidia-drivers package, it should already be set to use nvidia for OpenGL. But better make sure it is so.

After using nvidia-xconfig, make sure /etc/X11/xorg.conf looks sane to you.

And if you follow the nvidia guide I linked, there should be no reason why your setup shouldn't work. If you can't get it to run, please post the output of:
Code:
~ # modprobe -v -v nvidia
and
Code:
 ~ # lspci -v -k | grep -A 10 -i VGA

_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Thu Dec 19, 2013 6:10 pm    Post subject: Reply with quote

btw: Are you in the video group?
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum