Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome3.8 systemd lead gentoo with grub1 for non-genkernel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
83657664
n00b
n00b


Joined: 16 Mar 2011
Posts: 50

PostPosted: Tue Dec 17, 2013 5:43 am    Post subject: gnome3.8 systemd lead gentoo with grub1 for non-genkernel Reply with quote

hi,guys.
openrc still work,how systemd boot with system,
i follow http://wiki.gentoo.org/wiki/Systemd#Kernel,but it didn't answer my question.
gnome3.8 systemd lead gentoo with grub1 for non-genkernel user.
i want the systemd worked,boot gnome 3.8.
can anyone help!!!
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1371

PostPosted: Tue Dec 17, 2013 3:06 pm    Post subject: Reply with quote

grub kernel cmdline has to specify init with non default systemd, add:
init=/usr/lib/systemd/systemd

... not sure if I understand your sentences.
_________________
fun2gen2
Back to top
View user's profile Send private message
83657664
n00b
n00b


Joined: 16 Mar 2011
Posts: 50

PostPosted: Wed Dec 18, 2013 4:09 am    Post subject: Reply with quote

title Gentoo Linux 3.10.17
root (hd0,0)
kernel /boot/kernel-3.10.17-gentoo root=/dev/sda9 init=/usr/lib/systemd/systemd

is that right?
but when i type
Code:
localhost ~ # systemctl start gdm.service
Failed to get D-Bus connection: No connection to service manager.

it seems systemd did not start.
what i do now?
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1371

PostPosted: Wed Dec 18, 2013 10:52 am    Post subject: Reply with quote

83657664 wrote:
title Gentoo Linux 3.10.17
root (hd0,0)
kernel /boot/kernel-3.10.17-gentoo root=/dev/sda9 init=/usr/lib/systemd/systemd

is that right?
but when i type
Code:
localhost ~ # systemctl start gdm.service
Failed to get D-Bus connection: No connection to service manager.

it seems systemd did not start.
what i do now?

It seems to have started at your machine to me: but dbus!
You are a step further! Next steps:
Code:
systemctl enable gdm.service
systemctl set-default graphical.target
systemctl get-default
# should show now!
# reboot


If you want to experiment yourself,
also remember following commands as root to diagnose systemd:
Code:
journalctl -b
# shows you the actual boot log
systemctl
# show the list of services
systemctl status <unit>
# shows the state of a service
systemctl disable <unit>
# don't willingly activate
systemctl mask <unit>
# prevent a service to ever load automatically
systemctl isolate multi-user.target
# change runlevel, later on you can:
systemctl isolate graphical.target


PS: I am a Kde user. As I know Gdm has problems :(
To start a Gnome session you can also try lightdm or kdm as a displaymanager.

PS2: If you cannot solve your problem now we might further look at your kernel .config.
_________________
fun2gen2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum