Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Missing non english (polish) characters
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
hubertnnn
n00b
n00b


Joined: 26 Oct 2013
Posts: 28

PostPosted: Fri Nov 29, 2013 8:13 am    Post subject: Missing non english (polish) characters Reply with quote

I have this issue since installation of gentoo. When I type alt + a insted of ą I dont have anything in X. Same for other polish characters. In console (alt + ctrl + Fx) those characters work fine. From some forums I found that solution is to modify xorg.conf but it didnt help me.

My xorg.conf:
Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 319.60  (buildmeister@swio-display-x64-rhel04-15)  Wed Sep 25 15:17:31 PDT 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbLayout"  "pl"
    #Option         "XkbModel"   "pc105"
    #Option         "XkbVariant" "nodeadkeys"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection



I tried to run X with and witout Xkbmodel and Xkbvariant but nothing worked

edit:
I found that file /etc/X11/Sessions/Gnome contains following line with different parameters
Code:
setxkbmap `cat "$userxkbmap"`

so I did
Code:
setxkbmap pl

And it works (I guess untill next restart). Its only a way around but may help if someone got here with same issue. The question is why do I have to do it manually if layout is set in xorg.conf?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Fri Nov 29, 2013 1:24 pm    Post subject: Reply with quote

That's quite simple really.
It (most likely) isn't set in this xorg.conf.

Without seeing your xorg log, we can't be certain, but (again - most likely) you're using xf86-input-evdev, so you actually didn't configure it at all.
PS: you might want to add something like 'terminate:ctrl_alt_bksp' to your XkbOptions.

PPS: actually, it seems the only section that has any real meaning in your xorg.conf is 'Device'.
Back to top
View user's profile Send private message
hubertnnn
n00b
n00b


Joined: 26 Oct 2013
Posts: 28

PostPosted: Fri Nov 29, 2013 4:13 pm    Post subject: Reply with quote

Looks like you are correct. This 3 lines in log seem weird and may be the source of problem:
Code:

[    42.196] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    42.196] (WW) Disabling Keyboard0
...
[    47.919] (**) Option "xkb_layout" "us"

So if I cant configure it in xorg.conf then where?


Full Xorg.0.log:
Code:

[    41.809]
X.Org X Server 1.14.4
Release Date: 2013-10-31
[    41.810] X Protocol Version 11, Revision 0
[    41.810] Build Operating System: Linux 3.9.11-ck x86_64 Gentoo
[    41.810] Current Operating System: Linux asus 3.9.11-ck #2 SMP Sun Oct 27 23:17:38 CET 2013 x86_64
[    41.810] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-3.9.11-ck root=UUID=ada5f572-6dc2-4348-9090-2324e894cfcd ro
[    41.810] Build Date: 14 November 2013  02:38:59PM
[    41.810] 
[    41.810] Current version of pixman: 0.30.2
[    41.810]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    41.810] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    41.810] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Nov 29 08:31:35 2013
[    41.912] (==) Using config file: "/etc/X11/xorg.conf"
[    41.912] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    42.060] (==) ServerLayout "Layout0"
[    42.060] (**) |-->Screen "Screen0" (0)
[    42.060] (**) |   |-->Monitor "Monitor0"
[    42.060] (**) |   |-->Device "Device0"
[    42.060] (**) |-->Input Device "Keyboard0"
[    42.060] (**) |-->Input Device "Mouse0"
[    42.060] (==) Automatically adding devices
[    42.061] (==) Automatically enabling devices
[    42.061] (==) Automatically adding GPU devices
[    42.194] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    42.194]    Entry deleted from font path.
[    42.194] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    42.194]    Entry deleted from font path.
[    42.194] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    42.194]    Entry deleted from font path.
[    42.196] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    42.196]    Entry deleted from font path.
[    42.196]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    42.196] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    42.196]    Entry deleted from font path.
[    42.196]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    42.196] (==) FontPath set to:
   /usr/share/fonts/misc/
[    42.196] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    42.196] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    42.196] (WW) Disabling Keyboard0
[    42.196] (WW) Disabling Mouse0
[    42.196] (II) Loader magic: 0x7fcc00
[    42.196] (II) Module ABI versions:
[    42.196]    X.Org ANSI C Emulation: 0.4
[    42.196]    X.Org Video Driver: 14.1
[    42.196]    X.Org XInput driver : 19.1
[    42.196]    X.Org Server Extension : 7.0
[    42.197] (II) xfree86: Adding drm device (/dev/dri/card0)
[    42.200] (--) PCI:*(0:1:0:0) 10de:0a34:1043:1ae2 rev 162, Mem @ 0xfc000000/16777216, 0xd0000000/268435456, 0xce000000/33554432, I/O @ 0x0000cc00/128, BIOS @ 0x????????/524288
[    42.233] Initializing built-in extension Generic Event Extension
[    42.233] Initializing built-in extension SHAPE
[    42.233] Initializing built-in extension MIT-SHM
[    42.233] Initializing built-in extension XInputExtension
[    42.233] Initializing built-in extension XTEST
[    42.233] Initializing built-in extension BIG-REQUESTS
[    42.233] Initializing built-in extension SYNC
[    42.233] Initializing built-in extension XKEYBOARD
[    42.233] Initializing built-in extension XC-MISC
[    42.233] Initializing built-in extension XINERAMA
[    42.233] Initializing built-in extension XFIXES
[    42.233] Initializing built-in extension RENDER
[    42.233] Initializing built-in extension RANDR
[    42.233] Initializing built-in extension COMPOSITE
[    42.233] Initializing built-in extension DAMAGE
[    42.233] Initializing built-in extension MIT-SCREEN-SAVER
[    42.233] Initializing built-in extension DOUBLE-BUFFER
[    42.233] Initializing built-in extension RECORD
[    42.233] Initializing built-in extension DPMS
[    42.233] Initializing built-in extension X-Resource
[    42.233] Initializing built-in extension XVideo
[    42.233] Initializing built-in extension XVideo-MotionCompensation
[    42.233] Initializing built-in extension XFree86-VidModeExtension
[    42.233] Initializing built-in extension XFree86-DGA
[    42.233] Initializing built-in extension XFree86-DRI
[    42.233] Initializing built-in extension DRI2
[    42.233] (II) LoadModule: "glx"
[    42.597] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    43.966] (II) Module glx: vendor="NVIDIA Corporation"
[    43.966]    compiled for 4.0.2, module version = 1.0.0
[    43.966]    Module class: X.Org Server Extension
[    43.966] (II) NVIDIA GLX Module  331.20  Wed Oct 30 17:36:48 PDT 2013
[    43.974] Loading extension GLX
[    43.974] (II) LoadModule: "nvidia"
[    43.974] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[    44.128] (II) Module nvidia: vendor="NVIDIA Corporation"
[    44.128]    compiled for 4.0.2, module version = 1.0.0
[    44.128]    Module class: X.Org Video Driver
[    44.143] (II) NVIDIA dlloader X Driver  331.20  Wed Oct 30 17:16:53 PDT 2013
[    44.143] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    44.144] (++) using VT number 7

[    44.164] (II) Loading sub module "fb"
[    44.164] (II) LoadModule: "fb"
[    44.164] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    44.263] (II) Module fb: vendor="X.Org Foundation"
[    44.263]    compiled for 1.14.4, module version = 1.0.0
[    44.263]    ABI class: X.Org ANSI C Emulation, version 0.4
[    44.263] (WW) Unresolved symbol: fbGetGCPrivateKey
[    44.263] (II) Loading sub module "wfb"
[    44.263] (II) LoadModule: "wfb"
[    44.263] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[    44.271] (II) Module wfb: vendor="X.Org Foundation"
[    44.271]    compiled for 1.14.4, module version = 1.0.0
[    44.271]    ABI class: X.Org ANSI C Emulation, version 0.4
[    44.271] (II) Loading sub module "ramdac"
[    44.271] (II) LoadModule: "ramdac"
[    44.271] (II) Module "ramdac" already built-in
[    44.284] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    44.284] (==) NVIDIA(0): RGB weight 888
[    44.284] (==) NVIDIA(0): Default visual is TrueColor
[    44.284] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    44.286] (**) NVIDIA(0): Enabling 2D acceleration
[    44.855] (II) NVIDIA(0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[    44.855] (II) NVIDIA(0):     stereo.
[    44.855] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20130102)
[    44.868] (II) NVIDIA(0): NVIDIA GPU GeForce GT 240M (GT216) at PCI:1:0:0 (GPU-0)
[    44.868] (--) NVIDIA(0): Memory: 1048576 kBytes
[    44.868] (--) NVIDIA(0): VideoBIOS: 70.16.24.00.05
[    44.868] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    44.874] (--) NVIDIA(0): Valid display device(s) on GeForce GT 240M at PCI:1:0:0
[    44.874] (--) NVIDIA(0):     CRT-0
[    44.874] (--) NVIDIA(0):     LGD (DFP-0) (boot, connected)
[    44.874] (--) NVIDIA(0):     DFP-1
[    44.874] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[    44.874] (--) NVIDIA(0): LGD (DFP-0): Internal Dual Link LVDS
[    44.874] (--) NVIDIA(0): LGD (DFP-0): 330.0 MHz maximum pixel clock
[    44.874] (--) NVIDIA(0): DFP-1: Internal Single Link TMDS
[    44.874] (--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
[    44.874] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[    44.874] (**) NVIDIA(0):     device LGD (DFP-0) (Using EDID frequencies has been
[    44.874] (**) NVIDIA(0):     enabled on all display devices.)
[    44.875] (==) NVIDIA(0):
[    44.875] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[    44.875] (==) NVIDIA(0):     will be used as the requested mode.
[    44.875] (==) NVIDIA(0):
[    44.876] (II) NVIDIA(0): Validated MetaModes:
[    44.876] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select"
[    44.876] (II) NVIDIA(0): Virtual screen size determined to be 1600 x 900
[    46.211] (--) NVIDIA(0): DPI set to (106, 108); computed from "UseEdidDpi" X config
[    46.211] (--) NVIDIA(0):     option
[    46.211] (--) Depth 24 pixmap format is 32 bpp
[    46.211] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
[    46.220] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[    46.220] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[    46.220] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[    46.220] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[    46.220] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[    46.220] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[    46.220] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[    46.220] (II) NVIDIA(0):     Config Options in the README.
[    46.227] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[    46.594] Loading extension NV-GLX
[    46.648] (==) NVIDIA(0): Disabling shared memory pixmaps
[    46.648] (==) NVIDIA(0): Backing store disabled
[    46.648] (==) NVIDIA(0): Silken mouse enabled
[    46.649] (**) NVIDIA(0): DPMS enabled
[    46.649] Loading extension NV-CONTROL
[    46.649] Loading extension XINERAMA
[    46.649] (II) Loading sub module "dri2"
[    46.649] (II) LoadModule: "dri2"
[    46.649] (II) Module "dri2" already built-in
[    46.649] (II) NVIDIA(0): [DRI2] Setup complete
[    46.649] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    46.649] (--) RandR disabled
[    46.680] (II) Initializing extension GLX
[    47.826] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[    47.826] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    47.826] (II) LoadModule: "evdev"
[    47.845] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[    47.918] (II) Module evdev: vendor="X.Org Foundation"
[    47.918]    compiled for 1.14.4, module version = 2.8.2
[    47.919]    Module class: X.Org XInput Driver
[    47.919]    ABI class: X.Org XInput driver, version 19.1
[    47.919] (II) Using input driver 'evdev' for 'Power Button'
[    47.919] (**) Power Button: always reports core events
[    47.919] (**) evdev: Power Button: Device: "/dev/input/event2"
[    47.919] (--) evdev: Power Button: Vendor 0 Product 0x1
[    47.919] (--) evdev: Power Button: Found keys
[    47.919] (II) evdev: Power Button: Configuring as keyboard
[    47.919] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event2"
[    47.919] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    47.919] (**) Option "xkb_rules" "evdev"
[    47.919] (**) Option "xkb_model" "pc104"
[    47.919] (**) Option "xkb_layout" "us"
[    47.987] (II) config/udev: Adding input device Video Bus (/dev/input/event7)
[    47.987] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[    47.987] (II) Using input driver 'evdev' for 'Video Bus'
[    47.987] (**) Video Bus: always reports core events
[    47.987] (**) evdev: Video Bus: Device: "/dev/input/event7"
[    47.987] (--) evdev: Video Bus: Vendor 0 Product 0x6
[    47.987] (--) evdev: Video Bus: Found keys
[    47.987] (II) evdev: Video Bus: Configuring as keyboard
[    47.988] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:36/LNXVIDEO:00/input/input7/event7"
[    47.988] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[    47.988] (**) Option "xkb_rules" "evdev"
[    47.988] (**) Option "xkb_model" "pc104"
[    47.988] (**) Option "xkb_layout" "us"
[    47.989] (II) config/udev: Adding input device Lid Switch (/dev/input/event1)
[    47.989] (II) No input driver specified, ignoring this device.
[    47.989] (II) This device may have been added with another device file.
[    47.990] (II) config/udev: Adding input device Sleep Button (/dev/input/event0)
[    47.990] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[    47.990] (II) Using input driver 'evdev' for 'Sleep Button'
[    47.990] (**) Sleep Button: always reports core events
[    47.990] (**) evdev: Sleep Button: Device: "/dev/input/event0"
[    47.990] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[    47.990] (--) evdev: Sleep Button: Found keys
[    47.990] (II) evdev: Sleep Button: Configuring as keyboard
[    47.990] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input0/event0"
[    47.990] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 8)
[    47.990] (**) Option "xkb_rules" "evdev"
[    47.990] (**) Option "xkb_model" "pc104"
[    47.990] (**) Option "xkb_layout" "us"
[    47.991] (II) config/udev: Adding drm device (/dev/dri/card0)
[    47.992] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event5)
[    47.992] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
[    47.992] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
[    47.992] (**) Logitech USB Receiver: always reports core events
[    47.992] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event5"
[    47.992] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52b
[    47.992] (--) evdev: Logitech USB Receiver: Found keys
[    47.992] (II) evdev: Logitech USB Receiver: Configuring as keyboard
[    47.992] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.1/usb7/7-2/7-2:1.0/input/input5/event5"
[    47.992] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 9)
[    47.992] (**) Option "xkb_rules" "evdev"
[    47.992] (**) Option "xkb_model" "pc104"
[    47.992] (**) Option "xkb_layout" "us"
[    47.994] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event6)
[    47.994] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall"
[    47.994] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
[    47.994] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
[    47.994] (**) Logitech USB Receiver: always reports core events
[    47.994] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event6"
[    47.994] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52b
[    47.994] (--) evdev: Logitech USB Receiver: Found 20 mouse buttons
[    47.994] (--) evdev: Logitech USB Receiver: Found scroll wheel(s)
[    47.994] (--) evdev: Logitech USB Receiver: Found relative axes
[    47.994] (--) evdev: Logitech USB Receiver: Found x and y relative axes
[    47.994] (--) evdev: Logitech USB Receiver: Found absolute axes
[    47.994] (II) evdev: Logitech USB Receiver: Forcing absolute x/y axes to exist.
[    47.994] (--) evdev: Logitech USB Receiver: Found keys
[    47.994] (II) evdev: Logitech USB Receiver: Configuring as mouse
[    47.994] (II) evdev: Logitech USB Receiver: Configuring as keyboard
[    47.994] (II) evdev: Logitech USB Receiver: Adding scrollwheel support
[    47.994] (**) evdev: Logitech USB Receiver: YAxisMapping: buttons 4 and 5
[    47.994] (**) evdev: Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    47.994] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.1/usb7/7-2/7-2:1.1/input/input6/event6"
[    47.994] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 10)
[    47.994] (**) Option "xkb_rules" "evdev"
[    47.994] (**) Option "xkb_model" "pc104"
[    47.994] (**) Option "xkb_layout" "us"
[    47.995] (II) evdev: Logitech USB Receiver: initialized for relative axes.
[    47.995] (WW) evdev: Logitech USB Receiver: ignoring absolute axes.
[    47.995] (**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
[    47.995] (**) Logitech USB Receiver: (accel) acceleration profile 0
[    47.995] (**) Logitech USB Receiver: (accel) acceleration factor: 2.000
[    47.995] (**) Logitech USB Receiver: (accel) acceleration threshold: 4
[    47.996] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/mouse1)
[    47.996] (II) No input driver specified, ignoring this device.
[    47.996] (II) This device may have been added with another device file.
[    47.997] (II) config/udev: Adding input device Asus Laptop extra buttons (/dev/input/event9)
[    47.997] (**) Asus Laptop extra buttons: Applying InputClass "evdev keyboard catchall"
[    47.997] (II) Using input driver 'evdev' for 'Asus Laptop extra buttons'
[    47.997] (**) Asus Laptop extra buttons: always reports core events
[    47.997] (**) evdev: Asus Laptop extra buttons: Device: "/dev/input/event9"
[    47.997] (--) evdev: Asus Laptop extra buttons: Vendor 0 Product 0
[    47.997] (--) evdev: Asus Laptop extra buttons: Found keys
[    47.997] (II) evdev: Asus Laptop extra buttons: Configuring as keyboard
[    47.997] (**) Option "config_info" "udev:/sys/devices/platform/asus_laptop/input/input9/event9"
[    47.997] (II) XINPUT: Adding extended input device "Asus Laptop extra buttons" (type: KEYBOARD, id 11)
[    47.997] (**) Option "xkb_rules" "evdev"
[    47.997] (**) Option "xkb_model" "pc104"
[    47.997] (**) Option "xkb_layout" "us"
[    47.998] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event3)
[    47.999] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    47.999] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[    47.999] (**) AT Translated Set 2 keyboard: always reports core events
[    47.999] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event3"
[    47.999] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[    47.999] (--) evdev: AT Translated Set 2 keyboard: Found keys
[    47.999] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[    47.999] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input3/event3"
[    47.999] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 12)
[    47.999] (**) Option "xkb_rules" "evdev"
[    47.999] (**) Option "xkb_model" "pc104"
[    47.999] (**) Option "xkb_layout" "us"
[    48.000] (II) config/udev: Adding input device ImPS/2 Logitech Wheel Mouse (/dev/input/event4)
[    48.000] (**) ImPS/2 Logitech Wheel Mouse: Applying InputClass "evdev pointer catchall"
[    48.000] (II) Using input driver 'evdev' for 'ImPS/2 Logitech Wheel Mouse'
[    48.000] (**) ImPS/2 Logitech Wheel Mouse: always reports core events
[    48.000] (**) evdev: ImPS/2 Logitech Wheel Mouse: Device: "/dev/input/event4"
[    48.000] (--) evdev: ImPS/2 Logitech Wheel Mouse: Vendor 0x2 Product 0x5
[    48.000] (--) evdev: ImPS/2 Logitech Wheel Mouse: Found 3 mouse buttons
[    48.000] (--) evdev: ImPS/2 Logitech Wheel Mouse: Found scroll wheel(s)
[    48.000] (--) evdev: ImPS/2 Logitech Wheel Mouse: Found relative axes
[    48.000] (--) evdev: ImPS/2 Logitech Wheel Mouse: Found x and y relative axes
[    48.000] (II) evdev: ImPS/2 Logitech Wheel Mouse: Configuring as mouse
[    48.000] (II) evdev: ImPS/2 Logitech Wheel Mouse: Adding scrollwheel support
[    48.000] (**) evdev: ImPS/2 Logitech Wheel Mouse: YAxisMapping: buttons 4 and 5
[    48.001] (**) evdev: ImPS/2 Logitech Wheel Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    48.001] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input4/event4"
[    48.001] (II) XINPUT: Adding extended input device "ImPS/2 Logitech Wheel Mouse" (type: MOUSE, id 13)
[    48.001] (II) evdev: ImPS/2 Logitech Wheel Mouse: initialized for relative axes.
[    48.001] (**) ImPS/2 Logitech Wheel Mouse: (accel) keeping acceleration scheme 1
[    48.001] (**) ImPS/2 Logitech Wheel Mouse: (accel) acceleration profile 0
[    48.001] (**) ImPS/2 Logitech Wheel Mouse: (accel) acceleration factor: 2.000
[    48.001] (**) ImPS/2 Logitech Wheel Mouse: (accel) acceleration threshold: 4
[    48.002] (II) config/udev: Adding input device ImPS/2 Logitech Wheel Mouse (/dev/input/mouse0)
[    48.002] (II) No input driver specified, ignoring this device.
[    48.002] (II) This device may have been added with another device file.
[    48.002] (II) config/udev: Adding input device PC Speaker (/dev/input/event8)
[    48.003] (II) No input driver specified, ignoring this device.
[    48.003] (II) This device may have been added with another device file.
[    53.858] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[    53.858] (II) NVIDIA(GPU-0):     stereo.
[    56.607] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[    56.608] (II) NVIDIA(GPU-0):     stereo.
[    60.595] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[    60.595] (II) NVIDIA(GPU-0):     stereo.
[    78.999] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[    78.999] (II) NVIDIA(GPU-0):     stereo.
[    81.286] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[    81.286] (II) NVIDIA(GPU-0):     stereo.
[    81.571] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[    81.571] (II) NVIDIA(GPU-0):     stereo.
[   547.817] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[   549.463] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[   549.463] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[   549.463] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[   549.463] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[   549.463] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[   549.463] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[   549.463] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[   549.463] (II) NVIDIA(0):     Config Options in the README.
[   549.465] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[   549.465] (II) NVIDIA(GPU-0):     stereo.
[   549.490] setversion 1.4 failed
[   881.018] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[   882.670] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[   882.670] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[   882.670] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[   882.670] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[   882.670] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[   882.670] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[   882.670] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[   882.670] (II) NVIDIA(0):     Config Options in the README.
[   882.671] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[   882.671] (II) NVIDIA(GPU-0):     stereo.
[  1429.638] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[  1431.283] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[  1431.283] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[  1431.283] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[  1431.283] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[  1431.283] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[  1431.283] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[  1431.283] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[  1431.283] (II) NVIDIA(0):     Config Options in the README.
[  1431.284] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[  1431.284] (II) NVIDIA(GPU-0):     stereo.
[  1451.186] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[  1452.829] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[  1452.829] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[  1452.829] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[  1452.829] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[  1452.829] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[  1452.829] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[  1452.829] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[  1452.829] (II) NVIDIA(0):     Config Options in the README.
[  1452.831] (II) NVIDIA(GPU-0): Display (LGD (DFP-0)) does not support NVIDIA 3D Vision
[  1452.831] (II) NVIDIA(GPU-0):     stereo.
[  1505.724] (II) evdev: ImPS/2 Logitech Wheel Mouse: Close
[  1505.724] (II) UnloadModule: "evdev"
[  1505.724] (II) evdev: AT Translated Set 2 keyboard: Close
[  1505.724] (II) UnloadModule: "evdev"
[  1505.724] (II) evdev: Asus Laptop extra buttons: Close
[  1505.724] (II) UnloadModule: "evdev"
[  1505.724] (II) evdev: Logitech USB Receiver: Close
[  1505.724] (II) UnloadModule: "evdev"
[  1505.724] (II) evdev: Logitech USB Receiver: Close
[  1505.725] (II) UnloadModule: "evdev"
[  1505.725] (II) evdev: Sleep Button: Close
[  1505.725] (II) UnloadModule: "evdev"
[  1505.725] (II) evdev: Video Bus: Close
[  1505.725] (II) UnloadModule: "evdev"
[  1505.725] (II) evdev: Power Button: Close
[  1505.725] (II) UnloadModule: "evdev"
[  1507.495] (II) NVIDIA(GPU-0): Deleting GPU-0
[  1507.499] (EE) Server terminated successfully (0). Closing log file.
Back to top
View user's profile Send private message
v_andal
Guru
Guru


Joined: 26 Aug 2008
Posts: 527
Location: Germany

PostPosted: Mon Dec 02, 2013 8:18 am    Post subject: Reply with quote

You can either add the following to xorg.conf or create directory /etc/X11/xorg.conf.d and placed it to file there, for example keyboard.conf

Quote:

Section "InputClass"
Identifier "other keyboards"
MatchIsKeyboard "On"
Option "Ignore" "on"
EndSection


Section "InputClass"
Identifier "Real Keyboard"
Driver "evdev"
MatchProduct "AT Translated Set 2 keyboard"
MatchIsKeyboard "On"
Option "XkbModel" "pc105"
Option "XkbLayout" "pl"
# Option "XkbOptions" "grp:rwin_toggle,ctrl:swapcaps,grp_led:scroll,compose:ralt"
Option "AutoServerLayout" "on"
Option "SendCoreEvents" "on"
Option "Ignore" "off"
EndSection


Note the Driver line. It indicates evdev and not kbd. The above configuration forces ignoring of everything that udev believes to be keyboard and enabling only the real keyboard. Try it.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Mon Dec 02, 2013 11:26 am    Post subject: Reply with quote

Glossing over the need for as verbose section, you should have '/dev/input/event*' path filter there.
Back to top
View user's profile Send private message
kfiadeg
n00b
n00b


Joined: 04 May 2006
Posts: 39
Location: Republic of Poland

PostPosted: Thu Dec 05, 2013 2:28 am    Post subject: Reply with quote

Maybe changing /etc/conf.d/keymaps will help?
I've got there:
Code:
keymap="pl"
windowkeys="YES"
extended_keymaps=""
dumpkeys_charset="iso-8859-2"
fix_euro="NO"
Back to top
View user's profile Send private message
v_andal
Guru
Guru


Joined: 26 Aug 2008
Posts: 527
Location: Germany

PostPosted: Thu Dec 05, 2013 8:24 am    Post subject: Reply with quote

/etc/conf.d/keymaps is for console. So it works only if X is not started. In X it plays no role.
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Thu Dec 05, 2013 11:24 pm    Post subject: Reply with quote

Remove all the grabastic pieces of ancient config from your xorg.conf and add something like this:

Code:

Section "InputClass"
   Identifier   "Keyboard Defaults"
   MatchIsKeyboard   "yes"
   Option      "XkbModel"   "pc104"
   Option      "XkbLayout"   "pl"
   Option      "XkbOptions"   "terminate:ctrl_alt_bksp,ctrl:nocaps,eurosign:5"
EndSection

_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Fri Dec 06, 2013 2:27 am    Post subject: Reply with quote

run the command

Code:
eselect locale list
& post your results to the thread! :twisted:
Back to top
View user's profile Send private message
hubertnnn
n00b
n00b


Joined: 26 Oct 2013
Posts: 28

PostPosted: Tue Dec 17, 2013 1:03 pm    Post subject: Reply with quote

v_andal wrote:
You can either add the following to xorg.conf or create directory /etc/X11/xorg.conf.d and placed it to file there, for example keyboard.conf

Quote:

Section "InputClass"
Identifier "other keyboards"
MatchIsKeyboard "On"
Option "Ignore" "on"
EndSection


Section "InputClass"
Identifier "Real Keyboard"
Driver "evdev"
MatchProduct "AT Translated Set 2 keyboard"
MatchIsKeyboard "On"
Option "XkbModel" "pc105"
Option "XkbLayout" "pl"
# Option "XkbOptions" "grp:rwin_toggle,ctrl:swapcaps,grp_led:scroll,compose:ralt"
Option "AutoServerLayout" "on"
Option "SendCoreEvents" "on"
Option "Ignore" "off"
EndSection


Note the Driver line. It indicates evdev and not kbd. The above configuration forces ignoring of everything that udev believes to be keyboard and enabling only the real keyboard. Try it.


It fixed my keyboard problem but now mouse dont work:
Quote:
[ 172.070] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/mouse1)
[ 172.070] (**) Logitech USB Receiver: Ignoring device from InputClass "other keyboards"

Removing first section seem to fix the issue and language is also ok.


666threesixes666 wrote:
run the command

Code:
eselect locale list
& post your results to the thread! :twisted:


Quote:
asus hubertnnn # eselect locale list
Available targets for the LANG variable:
[1] C
[2] POSIX
[3] en_US
[4] en_US.iso88591
[5] en_US.utf8
[6] pl_PL.utf8 *
[ ] (free form)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum