Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome3 works Once, Second Time it gets stuck
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jazernorth
n00b
n00b


Joined: 26 Oct 2004
Posts: 50
Location: Heber City, UT

PostPosted: Tue Dec 17, 2013 5:20 am    Post subject: Gnome3 works Once, Second Time it gets stuck Reply with quote

When I launch Gnome3 (using startx, see code below), it works very well the first launch.
Code:
export XDG_MENU_PREFIX=gnome-
exec gnome-session


I would then configure the desktop, add extensions, etc. When I close Gnome it would not launch. X11 comes up, but Gnome will not. I thought it was the extensions, so I clearned my .config gnome folders, then launched gnome. It worked! I then closed gnome, immediately, no configure or anything. I then launched it again and it got stuck. So, my thinking is that there is some configuration file that is being generated by Gnome that is causing it to fail.

Anyone have any ideas? I'll be happy to post any files you would like to see that could help resolve this problem.

Thanks in advance!
_________________
http://www.jaynorth.net
http://www.blgc.org
I build it, they will come.
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1371

PostPosted: Tue Dec 17, 2013 7:45 pm    Post subject: Reply with quote

No,
it is some hung user Gnome service not closing after logout. If you login again your new Gnome session fails to open a second instance of it. This I have seen using Gnome-3.10 from gnome-next overlay, I thaugth it is because of alpha quality (as kde fan).
_________________
fun2gen2
Back to top
View user's profile Send private message
jazernorth
n00b
n00b


Joined: 26 Oct 2004
Posts: 50
Location: Heber City, UT

PostPosted: Tue Dec 17, 2013 7:56 pm    Post subject: Reply with quote

ulenrich wrote:
No,
it is some hung user Gnome service not closing after logout. If you login again your new Gnome session fails to open a second instance of it. This I have seen using Gnome-3.10 from gnome-next overlay, I thaugth it is because of alpha quality (as kde fan).


Do you know how I would go about finding the service that is not closing?
_________________
http://www.jaynorth.net
http://www.blgc.org
I build it, they will come.
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1371

PostPosted: Tue Dec 17, 2013 10:34 pm    Post subject: Reply with quote

If I have done logout, I did
- login as root in a text console
- htop
- F6 arrow-up-down - enter at sort user
- F9 kill all of that logout users applications

I am curiously waiting to hear if this helps you ?
I thought it is an issue of Gnome-3.10, but you are using Gnome-3.8 ?

PS: Or, get familiar with a tool like killall ?
_________________
fun2gen2
Back to top
View user's profile Send private message
jazernorth
n00b
n00b


Joined: 26 Oct 2004
Posts: 50
Location: Heber City, UT

PostPosted: Wed Dec 18, 2013 4:15 am    Post subject: Reply with quote

Yes 3.8.

I guess I have to figure this out the hard way.... was hoping someone already did the leg work ... I like being lazy ....

OK - here goes on figuring out what application is still hanging on.... though, once I figure out which app, then I can submit a bug report to that group?
_________________
http://www.jaynorth.net
http://www.blgc.org
I build it, they will come.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum