Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem Emerging XFCE4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Nivlac
n00b
n00b


Joined: 16 Oct 2010
Posts: 8
Location: Washington, USA

PostPosted: Sun Dec 15, 2013 8:40 am    Post subject: Problem Emerging XFCE4 Reply with quote

I'm trying to emerge XFCE4, but emerge fails on a dependency: x11-libs/libxkbfile-1.0.8. Does anyone have any advice?
Code:
Portage 2.2.7 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.16.0, 3.10.17-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.10.17-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_W3530_@_2.80GHz-with-gentoo-2.2
KiB Mem:     4054368 total,   3282672 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Sun, 15 Dec 2013 07:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.5-r3, 3.3.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="rsync://rsync.gtlib.gatech.edu/gentoo http://lug.mtu.edu/gentoo/ http://gentoo.osuosl.org/ http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ ftp://ftp.wallawalla.edu/pub/mirrors/ftp.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv ipv6 jpeg lcms ldap libnotify lock mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support readline sdl session spell sse sse2 ssl startup-notification svg tcpd thunar tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6347
Location: /usr/lib64/lv2

PostPosted: Sun Dec 15, 2013 3:07 pm    Post subject: Reply with quote

That's the version I have, but it's in there with no trouble. What does Portage spit out when you try to emerge it?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7454

PostPosted: Sun Dec 15, 2013 5:34 pm    Post subject: Reply with quote

Gave us a link to the build.log we cannot answer to "that program doesn't build". And generally users forget the important part of the output.
Back to top
View user's profile Send private message
Nivlac
n00b
n00b


Joined: 16 Oct 2010
Posts: 8
Location: Washington, USA

PostPosted: Sun Dec 15, 2013 6:59 pm    Post subject: Reply with quote

Sorry about that. I've lurked through these forums for years, but I'm new to posting. I should have more carefully read the "If you need support..." paragraph. Below should be everything that is relevant to the issue. If not I can provide additional information.

This is the output of
Code:
emerge xfce4-meta

http://bpaste.net/show/158748/

This is the output of
Code:
emerge --info '=x11-libs/libxkbfile-1.0.8::gentoo

http://bpaste.net/show/158752/

This is the output of
Code:
emerge -pqv '=x11-libs/libxkbfile-1.0.8::gentoo

http://bpaste.net/show/158753/

This is the complete build log:
http://bpaste.net/show/158754/

This is the ebuild environment file:
http://bpaste.net/show/158755/
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Sun Dec 15, 2013 7:30 pm    Post subject: Reply with quote

No package 'x11' found
No package 'kbproto' found

my guess.... and this is a guess.... that worked for me 3 days ago.... 1st run

Code:

emerge -avxorg-server xorg-x11


hopefully all is well then and ready for your xfce4-meta emerge :twisted:

id almost say bug report this, xfce4-meta should know better and pull those in automatically.
Back to top
View user's profile Send private message
Nivlac
n00b
n00b


Joined: 16 Oct 2010
Posts: 8
Location: Washington, USA

PostPosted: Sun Dec 15, 2013 7:54 pm    Post subject: Reply with quote

Well, that gets stuck too on libXext-1.3.2. Here is the build log: http://bpaste.net/show/158777/.

It shows a similar issue:
Code:
No package 'x11' found


I tried running emerge x11 and I got the same result. It seems like they're circular dependencies.
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Sun Dec 15, 2013 8:07 pm    Post subject: Reply with quote

my bad...

its

emerge xorg-x11

emerge xorg-server
Back to top
View user's profile Send private message
Nivlac
n00b
n00b


Joined: 16 Oct 2010
Posts: 8
Location: Washington, USA

PostPosted: Sun Dec 15, 2013 8:19 pm    Post subject: Reply with quote

Both emerges fail for the same reason as the previous post.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7454

PostPosted: Sun Dec 15, 2013 8:35 pm    Post subject: Reply with quote

Code:
checking for XEXT... configure: error: Package requirements (xproto >= 7.0.13 x11 >= 1.1.99.1 xextproto >= 7.1.99) were not met:

try upgrade xproto and xextproto before going back to upgrading xorg
Code:
emerge -u1 xproto xextproto && emerge -u1 xorg-server


i suppose a emerge -uND1 xorg-server should make it better, as it will update everything to get xorg-server ready.
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Sun Dec 15, 2013 9:13 pm    Post subject: Reply with quote

i keep saying to emerge xorg-x11 because its fonts and other stuff that can and will break things if not merged even though most everything will run with just xorg-server. id trust krinn, im sleeping on the job here atm :(
Back to top
View user's profile Send private message
Nivlac
n00b
n00b


Joined: 16 Oct 2010
Posts: 8
Location: Washington, USA

PostPosted: Sun Dec 15, 2013 10:15 pm    Post subject: Reply with quote

I tried everything you said and it still isn't working. libxkbfile and libXext are still preventing anything from going forward.

libXext build log
Code:

checking for XEXT... configure: error: Package requirements (xproto >= 7.0.13 x11 >= 1.1.99.1 xextproto >= 7.1.99) were not met:

No package 'x11' found


libxkbfile build log
Code:

checking for XEXT... configure: error: Package requirements (xproto >= 7.0.13 x11 >= 1.1.99.1 xextproto >= 7.1.99) were not met:

No package 'x11' found


So if I understand this correct, x11 needs to be installed for these two items to build, but these two items need to be installed for x11 to build. That doesn't make sense.

Also for what its worth here is the output for emerge --info xproto xextproto
http://bpaste.net/show/158826/
Code:

x11-proto/xproto-7.0.24 was built with the following:
USE="-doc" ABI_X86="64 -32 -x32"


x11-proto/xextproto-7.2.1-r1 was built with the following:
USE="-doc" ABI_X86="64 -32 -x32"
Back to top
View user's profile Send private message
Nivlac
n00b
n00b


Joined: 16 Oct 2010
Posts: 8
Location: Washington, USA

PostPosted: Sun Dec 15, 2013 10:39 pm    Post subject: Reply with quote

I figured it out, finally. I didn't realize that x11 was really libX11. I emerged that (which itself required a few manual emerges) and things seem to be moving along now. Thank you for your assistance, it is greatly appreciated.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum