Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] lxdm FTBS
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
hadrons123
Tux's lil' helper
Tux's lil' helper


Joined: 08 Mar 2012
Posts: 90
Location: chennai

PostPosted: Thu Dec 12, 2013 3:15 pm    Post subject: [SOLVED] lxdm FTBS Reply with quote

I was trying to buld lxdm today and was not able to build.
Code:
jean ~ # emerge lxdm
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) lxde-base/lxdm-0.4.1-r7
 * lxdm-0.4.1.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                                             [ ok ]
>>> Unpacking source...
>>> Unpacking lxdm-0.4.1.tar.gz to /tmp/portage/lxde-base/lxdm-0.4.1-r7/work
>>> Source unpacked in /tmp/portage/lxde-base/lxdm-0.4.1-r7/work
>>> Preparing source in /tmp/portage/lxde-base/lxdm-0.4.1-r7/work/lxdm-0.4.1 ...
 * Applying lxdm-0.4.1-pam_console-disable.patch ...                                                                                                                                                                                  [ ok ]
 * Applying lxdm-0.4.1-git-fix-null-pointer-deref.patch ...                                                                                                                                                                           [ ok ]
 * Applying lxdm-0.4.1-configure-add-pam.patch ...                                                                                                                                                                                    [ ok ]
 * Applying lxdm-0.4.1-missing-pam-defines.patch ...                                                                                                                                                                                  [ ok ]
 * Applying lxdm-0.4.1-event-check.patch ...                                                                                                                                                                                          [ ok ]
 * Applying lxdm-0.4.1-selinux-support.patch ...                                                                                                                                                                                      [ ok ]
 * Applying lxdm-0.4.1-fix-pam-100-cpu.patch ...                                                                                                                                                                                      [ ok ]
 * Running eautoreconf in '/tmp/portage/lxde-base/lxdm-0.4.1-r7/work/lxdm-0.4.1' ...
 * Running intltoolize --automake --copy --force ...                                                                                                                                                                                  [ ok ]
 * Running aclocal ...                                                                                                                                                                                                                [ ok ]
 * Running autoconf ...                                                                                                                                                                                                               [ ok ]
 * Running autoheader ...                                                                                                                                                                                                             [ ok ]
 * Running automake --add-missing --copy ...                                                                                                                                                                                          [ !! ]

 * Failed Running automake !
 *
 * Include in your bugreport the contents of:
 *
 *   /tmp/portage/lxde-base/lxdm-0.4.1-r7/temp/automake.out

 * ERROR: lxde-base/lxdm-0.4.1-r7::gentoo failed (prepare phase):
 *   Failed Running automake !
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 3026:  Called eautoreconf
 *   environment, line  844:  Called eautomake
 *   environment, line  793:  Called autotools_run_tool 'automake' '--add-missing' '--copy'
 *   environment, line  605:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *
 * If you need support, post the output of `emerge --info '=lxde-base/lxdm-0.4.1-r7::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=lxde-base/lxdm-0.4.1-r7::gentoo'`.
/usr/lib64/portage/bin/isolated-functions.sh: line 188: wait: `Failed Running automake !': not a pid or valid job spec
 * The complete build log is located at '/tmp/portage/lxde-base/lxdm-0.4.1-r7/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/lxde-base/lxdm-0.4.1-r7/temp/environment'.
 * Working directory: '/tmp/portage/lxde-base/lxdm-0.4.1-r7/work/lxdm-0.4.1'
 * S: '/tmp/portage/lxde-base/lxdm-0.4.1-r7/work/lxdm-0.4.1'

>>> Failed to emerge lxde-base/lxdm-0.4.1-r7, Log file:

>>>  '/tmp/portage/lxde-base/lxdm-0.4.1-r7/temp/build.log'

 * Messages for package lxde-base/lxdm-0.4.1-r7:

 * Failed Running automake !
 *
 * Include in your bugreport the contents of:
 *
 *   /tmp/portage/lxde-base/lxdm-0.4.1-r7/temp/automake.out
 * ERROR: lxde-base/lxdm-0.4.1-r7::gentoo failed (prepare phase):
 *   Failed Running automake !
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 3026:  Called eautoreconf
 *   environment, line  844:  Called eautomake
 *   environment, line  793:  Called autotools_run_tool 'automake' '--add-missing' '--copy'
 *   environment, line  605:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *
 * If you need support, post the output of `emerge --info '=lxde-base/lxdm-0.4.1-r7::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=lxde-base/lxdm-0.4.1-r7::gentoo'`.
 * The complete build log is located at '/tmp/portage/lxde-base/lxdm-0.4.1-r7/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/lxde-base/lxdm-0.4.1-r7/temp/environment'.
 * Working directory: '/tmp/portage/lxde-base/lxdm-0.4.1-r7/work/lxdm-0.4.1'
 * S: '/tmp/portage/lxde-base/lxdm-0.4.1-r7/work/lxdm-0.4.1'


build.log
Code:
 * Package:    lxde-base/lxdm-0.4.1-r7
 * Repository: gentoo
 * Maintainer: lxde@gentoo.org
 * USE:        abi_x86_64 amd64 elibc_glibc kernel_linux multilib nls pam userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking lxdm-0.4.1.tar.gz to /tmp/portage/lxde-base/lxdm-0.4.1-r7/work
>>> Source unpacked in /tmp/portage/lxde-base/lxdm-0.4.1-r7/work
>>> Preparing source in /tmp/portage/lxde-base/lxdm-0.4.1-r7/work/lxdm-0.4.1 ...
 * Applying lxdm-0.4.1-pam_console-disable.patch ...
 [ ok ]
 * Applying lxdm-0.4.1-git-fix-null-pointer-deref.patch ...
 [ ok ]
 * Applying lxdm-0.4.1-configure-add-pam.patch ...
 [ ok ]
 * Applying lxdm-0.4.1-missing-pam-defines.patch ...
 [ ok ]
 * Applying lxdm-0.4.1-event-check.patch ...
 [ ok ]
 * Applying lxdm-0.4.1-selinux-support.patch ...
 [ ok ]
 * Applying lxdm-0.4.1-fix-pam-100-cpu.patch ...
 [ ok ]
 * Running eautoreconf in '/tmp/portage/lxde-base/lxdm-0.4.1-r7/work/lxdm-0.4.1' ...
 * Running intltoolize --automake --copy --force ...
 [ ok ]
 * Running aclocal ...
 [ ok ]
 * Running autoconf ...
 [ ok ]
 * Running autoheader ...
 [ ok ]
 * Running automake --add-missing --copy ...
 [ !! ]

 * Failed Running automake !
 *
 * Include in your bugreport the contents of:
 *
 *   /tmp/portage/lxde-base/lxdm-0.4.1-r7/temp/automake.out

 * ERROR: lxde-base/lxdm-0.4.1-r7::gentoo failed (prepare phase):
 *   Failed Running automake !
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 3026:  Called eautoreconf
 *   environment, line  844:  Called eautomake
 *   environment, line  793:  Called autotools_run_tool 'automake' '--add-missing' '--copy'
 *   environment, line  605:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *
 * If you need support, post the output of `emerge --info '=lxde-base/lxdm-0.4.1-r7::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=lxde-base/lxdm-0.4.1-r7::gentoo'`.
/usr/lib64/portage/bin/isolated-functions.sh: line 188: wait: `Failed Running automake !': not a pid or valid job spec
 * The complete build log is located at '/tmp/portage/lxde-base/lxdm-0.4.1-r7/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/lxde-base/lxdm-0.4.1-r7/temp/environment'.
 * Working directory: '/tmp/portage/lxde-base/lxdm-0.4.1-r7/work/lxdm-0.4.1'
 * S: '/tmp/portage/lxde-base/lxdm-0.4.1-r7/work/lxdm-0.4.1'


My system info
Code:
emerge --info
Portage 2.2.7 (default/linux/amd64/13.0/desktop, gcc-4.8.2, glibc-2.17, 3.12.5 x86_64)
=================================================================
System uname: Linux-3.12.5-x86_64-Intel-R-_Core-TM-_i7-3630QM_CPU_@_2.40GHz-with-gentoo-2.2
KiB Mem:     8066956 total,   6993316 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Thu, 12 Dec 2013 13:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.6, 3.3.3
dev-util/cmake:           2.8.12.1-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.14
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0
sys-kernel/linux-headers: 3.12 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo mate-overlay
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -mtune=generic -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://mirror.mcs.anl.gov/pub/gentoo/ rsync://mirror.mcs.anl.gov/gentoo/ ftp://mirror.mcs.anl.gov/pub/gentoo/ http://mirror.datapipe.net/gentoo ftp://mirror.datapipe.net/gentoo http://gentoo.mirrors.easynews.com/linux/gentoo/"
LANG="en_US.iso88591"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude=metadata/cache/*"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/mate"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluray branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fontconfig fortran gdbm gif gnome gpm gtk gtkstyle iconv infinality ipv6 jpeg lcms ldap libass libnotify lock mad matroska mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nsplugin ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support qt4 readline sdl session spell sse sse2 ssl svg tcpd thunar tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, USE_PYTHON

[/quote]


I tried installing lxde few weeks ago and lxsession failed with somewhat similar error. Anybody know how to cure this?
_________________
LENOVO Y580 FHD Intel® Core™ i7-3630QM CPU @ 2.40GHz × 8 |660M GTX NVIDIA | 16GB SanDisk SSD


Last edited by hadrons123 on Fri Dec 13, 2013 2:59 am; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Thu Dec 12, 2013 6:17 pm    Post subject: Reply with quote

Take a careful look at that build log and guess what haven't you posted yet.
Back to top
View user's profile Send private message
hadrons123
Tux's lil' helper
Tux's lil' helper


Joined: 08 Mar 2012
Posts: 90
Location: chennai

PostPosted: Thu Dec 12, 2013 10:56 pm    Post subject: Reply with quote

I guess its the environment
https://dl.dropboxusercontent.com/u/106654446/environment
_________________
LENOVO Y580 FHD Intel® Core™ i7-3630QM CPU @ 2.40GHz × 8 |660M GTX NVIDIA | 16GB SanDisk SSD
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Fri Dec 13, 2013 2:45 am    Post subject: Reply with quote

hadrons123 wrote:
I guess its the environment
https://dl.dropboxusercontent.com/u/106654446/environment


:sigh: no, automake.out.
Back to top
View user's profile Send private message
hadrons123
Tux's lil' helper
Tux's lil' helper


Joined: 08 Mar 2012
Posts: 90
Location: chennai

PostPosted: Fri Dec 13, 2013 2:49 am    Post subject: Reply with quote

Sorry for my ignorance.

Code:
**** automake *****
***** PWD: /tmp/portage/lxde-base/lxdm-0.4.1-r7/work/lxdm-0.4.1
***** automake --add-missing --copy

automake-1.14: warnings are treated as errors
src/Makefile.am:45: warning: source file 'gdm/gdm-languages.c' is in a subdirectory,
src/Makefile.am:45: but option 'subdir-objects' is disabled
automake-1.14: warning: possible forward-incompatibility.
automake-1.14: At least a source file is in a subdirectory, but the 'subdir-objects'
automake-1.14: automake option hasn't been enabled.  For now, the corresponding output*
automake-1.14: object file(s) will be placed in the top-level directory.  However,
automake-1.14: this behaviour will change in future Automake versions: they will
automake-1.14: unconditionally cause object files to be placed in the same subdirectory
automake-1.14: of the corresponding sources.
automake-1.14: You are advised to start using 'subdir-objects' option throughout your
automake-1.14: project, to avoid future incompatibilities.



I think I hit this one
https://bugs.gentoo.org/show_bug.cgi?id=469504
https://forums.gentoo.org/viewtopic-t-968856-start-0.html

Code:
 WANT_AUTOMAKE="1.12" emerge lxdm

Now I am able to build and install it. Thanks for the suggestion.
_________________
LENOVO Y580 FHD Intel® Core™ i7-3630QM CPU @ 2.40GHz × 8 |660M GTX NVIDIA | 16GB SanDisk SSD
Back to top
View user's profile Send private message
Spidey
Apprentice
Apprentice


Joined: 07 Sep 2006
Posts: 269

PostPosted: Mon Dec 23, 2013 12:51 am    Post subject: Reply with quote

I've hit the same problem emerging lxsession, part of LXDE. Should I open another bug report?
Back to top
View user's profile Send private message
hadrons123
Tux's lil' helper
Tux's lil' helper


Joined: 08 Mar 2012
Posts: 90
Location: chennai

PostPosted: Mon Dec 23, 2013 12:00 pm    Post subject: Reply with quote

If this comment is made by you. I think it would suffice.

https://bugs.gentoo.org/show_bug.cgi?id=469504#c9
_________________
LENOVO Y580 FHD Intel® Core™ i7-3630QM CPU @ 2.40GHz × 8 |660M GTX NVIDIA | 16GB SanDisk SSD
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum