Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[systemd] "Failed to get D-Bus connection" (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
ludo82
n00b
n00b


Joined: 19 Aug 2005
Posts: 73

PostPosted: Sun Dec 08, 2013 10:09 am    Post subject: [systemd] "Failed to get D-Bus connection" (résolu Reply with quote

Bonjour à tous,

Suite à la migration vers gnome 3.8 et systemd, je n'arrive plus à me loguer.

Au moment du lancement de gdm, j'ai un écran noir avec un curseur et au bout de quelques instants, j'ai un fond d'écran avec la date et l'heure seulement (aucun menu ni aucune action possible).

Le problème vient apparemment de systemd car lorsque je fais systemctl --failed, ça donne ceci :
Code:
# systemctl --failed
Failed to get D-Bus connection : No connection to service manager

J'ai pourtant suivi pas à pas le guide Gentoo pour systemd et ajouté "init=/usr/lib/systemd/systemd" dans grub mais mon système continue à lancer Openrc au démarrage.

Quelqu'un peut-il m'aider ?

Merci


Last edited by ludo82 on Tue Dec 10, 2013 8:22 am; edited 1 time in total
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2868
Location: Grenoble, France

PostPosted: Mon Dec 09, 2013 10:41 am    Post subject: Reply with quote

As-tu bien toutes les options qu'il faut dans le noyau ?

Tous les paquets concernés sont dans la même branche ? (pas de arch et ~arch par exemple ?)

Tu as bien systemd dans USE ?
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5272
Location: ~Brussels - Belgique

PostPosted: Mon Dec 09, 2013 10:42 am    Post subject: Reply with quote

Et est-ce que le service DBUS est bien démarré avant systemd ?
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
ludo82
n00b
n00b


Joined: 19 Aug 2005
Posts: 73

PostPosted: Mon Dec 09, 2013 12:55 pm    Post subject: Reply with quote

kopp wrote:
As-tu bien toutes les options qu'il faut dans le noyau ?

Vu que j'utilise le noyau gentoo-sources, je n'ai activé que cette option :

Code:
Gentoo Linux --->
        Support for init systems, system and service managers --->
                [*] systemd

kopp wrote:
Tous les paquets concernés sont dans la même branche ? (pas de arch et ~arch par exemple ?)

Tous mes paquets installés sont dans la branche stable amd64.

kopp wrote:
Tu as bien systemd dans USE ?

Oui.

XavierMiller wrote:
Et est-ce que le service DBUS est bien démarré avant systemd ?

J'ai du mal à comprendre la question.
Je croyais que systemd était un chargeur de services, pas un service en lui-même.
C'est pas systemd qui est censé lancer les services, notamment le service dbus ?
Chez moi, le service dbus est lancé par openrc via le script /etc/init.d/dbus.
Je n'ai pas de service systemd dans le répertoire /etc/init.d/
Comment faire pour lancer systemd avant dbus et surtout comment faire pour que ce soit systemd qui gère l'init et non plus openrc ?
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5272
Location: ~Brussels - Belgique

PostPosted: Mon Dec 09, 2013 12:59 pm    Post subject: Reply with quote

Oui juste, je parlais en termes d'openrc.

Une autre chose à vérifier : losque dbus change, il faut souvent recompiler dbus-glib et python-dbus.

Code:
emerge -1av dbus-glib python-dbus

_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
ludo82
n00b
n00b


Joined: 19 Aug 2005
Posts: 73

PostPosted: Mon Dec 09, 2013 6:57 pm    Post subject: Reply with quote

J'ai réinstallé dbus-glib et dbus-python mais c'est toujours le même problème.

Systemd ne veut pas se lancer au boot. C'est openrc qui se lance à chaque fois alors que j'ai bien rajouté "init=/usr/lib/systemd/systemd" dans le fichier /etc/default/grub :

Code:
# Append parameters to the linux kernel command line
GRUB_CMDLINE_LINUX="init=/usr/lib/systemd/systemd"

Je comprends plus rien.
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5272
Location: ~Brussels - Belgique

PostPosted: Mon Dec 09, 2013 6:59 pm    Post subject: Reply with quote

As-tu regénéré ce qu'il faut après avoir modifié ce fichier de configuration ?

Ce que tu montres n'est pas le menu de GRUB, mais un fichier qui va participer à la génération du menu ;)
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
ludo82
n00b
n00b


Joined: 19 Aug 2005
Posts: 73

PostPosted: Mon Dec 09, 2013 7:22 pm    Post subject: Reply with quote

Oui, j'ai fait :

Code:
grub2-mkconfig  -o /boot/grub/grub.cfg
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2868
Location: Grenoble, France

PostPosted: Mon Dec 09, 2013 7:39 pm    Post subject: Reply with quote

est ce que ton /usr est sur une partition séparée ?
Est-ce que tu as un initramfs ?

(Note que j'ai pas forcément de solution, je pose des questions qui pourraient éventuellement mener à une cause, et il me semble qu'il y a des histoires avec ça)
Back to top
View user's profile Send private message
ludo82
n00b
n00b


Joined: 19 Aug 2005
Posts: 73

PostPosted: Mon Dec 09, 2013 7:50 pm    Post subject: Reply with quote

kopp wrote:
est ce que ton /usr est sur une partition séparée ?

Non
kopp wrote:
Est-ce que tu as un initramfs ?

Oui
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5272
Location: ~Brussels - Belgique

PostPosted: Mon Dec 09, 2013 9:41 pm    Post subject: Reply with quote

Pourrais-tu vérifier lors du démarrage que l'option est bien prise en compte, en appuyant sur la touche "O" (o, pas zéro) sur la ligne qui lance ce noyau ?
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
ludo82
n00b
n00b


Joined: 19 Aug 2005
Posts: 73

PostPosted: Mon Dec 09, 2013 11:52 pm    Post subject: Reply with quote

La touche "o" ne donne strictement rien au démarrage. Tu es sûr que c'est la bonne touche ?

Quant à initramfs, je pense que le problème vient effectivement de là car openrc se lance juste après le lancement de la procédure de boot via initramfs :

Code:
Booting (initramfs)
INIT: version 2.88 booting

    OpenRC 0.12.4 is starting up Gentoo Linux (x86_64)

Ma question est donc : comment faire pour dire à initramfs de démarrer systemd et non openrc ?
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5272
Location: ~Brussels - Belgique

PostPosted: Tue Dec 10, 2013 7:08 am    Post subject: Reply with quote

As-tu tout vérifié sur le wiki: http://wiki.gentoo.org/wiki/Systemd ?
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
ludo82
n00b
n00b


Joined: 19 Aug 2005
Posts: 73

PostPosted: Tue Dec 10, 2013 8:21 am    Post subject: Reply with quote

Ça y est, j'ai trouvé la solution en farfouillant sur internet.

Il fallait mettre "real_init=/usr/lib/systemd/systemd" dans les options de grub2 et non pas "init=/usr/lib/systemd/systemd".

Merci quand même pour votre aide.
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5272
Location: ~Brussels - Belgique

PostPosted: Tue Dec 10, 2013 8:23 am    Post subject: Reply with quote

Bien vu ! Cela est du à l'init script.

As-tu réellement besoin du init script ? A part un bootsplash ou le root crypté, je ne vois pas trop, vu que ton /usr n'est pas dans une partition séparée.
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
ludo82
n00b
n00b


Joined: 19 Aug 2005
Posts: 73

PostPosted: Tue Dec 10, 2013 10:11 am    Post subject: Reply with quote

J'ai un bootsplash.
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5272
Location: ~Brussels - Belgique

PostPosted: Tue Dec 10, 2013 10:25 am    Post subject: Reply with quote

ok !
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum