Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No i915 kms on 3.12.3 - Works after suspend/resume
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
DepreTux
n00b
n00b


Joined: 15 Aug 2011
Posts: 8

PostPosted: Fri Dec 06, 2013 12:53 am    Post subject: No i915 kms on 3.12.3 - Works after suspend/resume Reply with quote

Hi!

I upgraded to vanilla kernel 3.12.3 from 3.10.21 on my aspire one notebook (945GM vga) and when I boot up I get a black screen with no cursor although the lcd backlight does stay on.

The curious detail is that if I suspend the system and then resume it, the console login works fine and I can login to my user and even startx and everything runs perfect thereafter.

I "make oldconfig'd" from a working config on 3.10.21 but I might have screwed somewhere.

I used to stay with LTS kernels, but found out new ones outperform them in terms of power efficiency.

my config: http://pastebin.com/yGfda7K8

my dmesg output (after having suspended and hibernated the thing, X running):

http://pastebin.com/hgk4EZEY

Let me know if anything else is needed to sort this out.

Thanks, and have a good one!
Back to top
View user's profile Send private message
DepreTux
n00b
n00b


Joined: 15 Aug 2011
Posts: 8

PostPosted: Fri Dec 06, 2013 5:26 am    Post subject: Reply with quote

a little update:

Tried booting with "nomodesetting" and I the screen works fine.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum