Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Blocked package @preserved
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Thu Dec 05, 2013 7:47 pm    Post subject: Blocked package @preserved Reply with quote

Gnome 3 ask for package 2.x blocked by 3.x package. Mask all?
How to solve?

Code:
# emerge @preserved-rebuild
Calculating dependencies... done!
[ebuild     UD#] dev-libs/libgweather-2.30.3 [3.8.3] USE="python%*"
[ebuild     U  ] gnome-extra/gnome-screensaver-3.6.1 [2.30.2-r1] USE="systemd%*"
[ebuild   R    ] dev-vcs/gitg-0.2.7
[ebuild     UD#] gnome-extra/evolution-data-server-2.32.3-r3 [3.8.5] USE="gnome-keyring%*"
[ebuild     UD#] gnome-base/gnome-panel-2.32.1-r3 [3.8.0-r1] USE="bonobo%*"
[ebuild   R    ] dev-python/evolution-python-2.32.0
[ebuild   R    ] gnome-extra/evolution-webcal-2.32.0
[ebuild   R    ] dev-python/gnome-applets-python-2.32.0
[ebuild   R    ] net-analyzer/gnome-netstatus-2.28.2
[ebuild   R    ] gnome-extra/libgail-gnome-1.20.4
[ebuild   R    ] gnome-extra/deskbar-applet-2.32.0

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

gnome-extra/evolution-data-server:0

  (gnome-extra/evolution-data-server-3.8.5::gentoo, installed) pulled in by
    >=gnome-extra/evolution-data-server-3.8.5:0/40=[gnome-online-accounts,weather] required by (mail-client/evolution-3.8.5::gentoo, installed)
    (and 11 more with the same problem)

  (gnome-extra/evolution-data-server-2.32.3-r3::gentoo, ebuild scheduled for merge) pulled in by
    <gnome-extra/evolution-data-server-3.6 required by (gnome-extra/evolution-webcal-2.32.0::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

gnome-base/gnome-panel:0

  (gnome-base/gnome-panel-2.32.1-r3::gentoo, ebuild scheduled for merge) pulled in by
    gnome-base/gnome-panel[bonobo] required by (gnome-extra/deskbar-applet-2.32.0::gentoo, ebuild scheduled for merge)
    gnome-base/gnome-panel[bonobo] required by (gnome-extra/libgail-gnome-1.20.4::gentoo, ebuild scheduled for merge)
    gnome-base/gnome-panel[bonobo] required by (net-analyzer/gnome-netstatus-2.28.2::gentoo, ebuild scheduled for merge)

  (gnome-base/gnome-panel-3.8.0-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/libgweather:2

  (dev-libs/libgweather-2.30.3::gentoo, ebuild scheduled for merge) pulled in by
    <dev-libs/libgweather-2.90.1:2 required by (gnome-base/gnome-panel-2.32.1-r3::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (dev-libs/libgweather-3.8.3::gentoo, installed) pulled in by
    >=dev-libs/libgweather-3.5.1:2= required by (gnome-base/gnome-panel-3.8.0-r1::gentoo, installed)
    (and 5 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by gnome-base/gnome-panel-2.32.1-r3
# required by net-analyzer/gnome-netstatus-2.28.2
# required by @preserved-rebuild (argument)
# /etc/portage/package.mask:
=dev-libs/libgweather-2.30.3
# required by dev-python/gnome-applets-python-2.32.0
# required by gnome-extra/deskbar-applet-2.32.0
# required by @preserved-rebuild (argument)
# /etc/portage/package.mask:
=gnome-base/gnome-panel-2.32.1-r3
# required by gnome-extra/deskbar-applet-2.32.0[eds]
# required by @preserved-rebuild (argument)
# /etc/portage/package.mask:
=gnome-extra/evolution-data-server-2.32.3-r3

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1415

PostPosted: Fri Dec 06, 2013 12:56 am    Post subject: Re: Blocked package @preserved Reply with quote

mrl4n wrote:
Gnome 3 ask for package 2.x blocked by 3.x package.

Probably not Gnome3 but your @world selection asks for 2.32 ebuilds?
_________________
ultra left enrich
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Fri Dec 06, 2013 1:02 am    Post subject: Reply with quote

No one of this ebuild is present in my world...
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1415

PostPosted: Fri Dec 06, 2013 1:13 am    Post subject: Reply with quote

some trial will show what has asked indirectly::

emerge --ask -c =dev-python/gnome-applets-python-2.32

Most blockage is caused by a blown big @world, and try depclean before world:
emerge --ask -c
emerge -auvDN @world
_________________
ultra left enrich


Last edited by ulenrich on Fri Dec 06, 2013 1:17 am; edited 1 time in total
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Fri Dec 06, 2013 1:15 am    Post subject: Reply with quote

ulenrich wrote:
some trial will show what has asked indirectly::

emerge --ask -c =dev-python/gnome-applets-python-2.32


Nothing
Code:
# emerge --ask -c =dev-python/gnome-applets-python-2.32
--- Couldn't find '=dev-python/gnome-applets-python-2.32' to depclean.
>>> No packages selected for removal by depclean
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1415

PostPosted: Fri Dec 06, 2013 1:20 am    Post subject: Reply with quote

Of course, try with names and versions you have installed :)
Or just names without versions ...

The more radical approach, do not try from X:
Code:
which qlist && emerge --ask -C $( qlist -IC gnome)
emerge -c
emerge gnome

_________________
ultra left enrich
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Fri Dec 06, 2013 4:28 pm    Post subject: Reply with quote

129 uninstall and 65 emerge...i'm afraid for the next boot :roll:
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1415

PostPosted: Fri Dec 06, 2013 5:00 pm    Post subject: Reply with quote

Have you seen my Warning in forum Desktops?
Firstly try systemd as a first single step!
_________________
ultra left enrich
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Fri Dec 06, 2013 5:03 pm    Post subject: Reply with quote

ulenrich wrote:
Have you seen my Warning in forum Desktops?


No, where?

ulenrich wrote:

Firstly try systemd as a first single step!


Suggest?
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1415

PostPosted: Fri Dec 06, 2013 5:21 pm    Post subject: Reply with quote

Uuups: I called it Hara-kiri
https://forums.gentoo.org/viewtopic-t-977656.html

@mrl4n
If your really want a full blown gnome, try on save grounds how to run with

a) systemd
as a first step. Try to reboot with an exta grub kernel cmdline parameter:
init=/usr/lib/systemd/systemd
with kept openrc installed. And then change your profile to .../gnome/systemd
Keep going to configure your systemd perfectly: timezone, locale

b) Try to purge as much as possible not essential ebuild
google-earth, games, gstreamer (comes in a new gstreamer-1 automatically)
Nearly all comes in again automatically by just doing: emerge gnome

c) Try to have a fully updated @system set is essential.
Do your homework there at first, read the news etc.

d) resolve further exclusives:
xine or ffmpg
gnutls or openssl
_________________
ultra left enrich
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Fri Dec 06, 2013 6:16 pm    Post subject: Reply with quote

ulenrich wrote:
Uuups: I called it Hara-kiri
https://forums.gentoo.org/viewtopic-t-977656.html

@mrl4n
If your really want a full blown gnome, try on save grounds how to run with

a) systemd
as a first step. Try to reboot with an exta grub kernel cmdline parameter:
init=/usr/lib/systemd/systemd
with kept openrc installed. And then change your profile to .../gnome/systemd
Keep going to configure your systemd perfectly: timezone, locale


Just do it...

ulenrich wrote:

b) Try to purge as much as possible not essential ebuild
google-earth, games, gstreamer (comes in a new gstreamer-1 automatically)
Nearly all comes in again automatically by just doing: emerge gnome


I will do it...

ulenrich wrote:

c) Try to have a fully updated @system set is essential.
Do your homework there at first, read the news etc.


This is the real problem...

ulenrich wrote:

d) resolve further exclusives:
xine or ffmpg
gnutls or openssl


This is very simple.

P.S. now during the boot a blank window and a new message
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum