Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]installing gnome2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
usf
n00b
n00b


Joined: 24 Oct 2013
Posts: 19

PostPosted: Wed Dec 04, 2013 7:12 pm    Post subject: [SOLVED]installing gnome2 Reply with quote

Good evening everyone!
I run gentoo with openbox as wm and Slim login manager.

Now i want to install gnome as second de and have a question..
How can i install gnome 2 instead of gnome3, that is stable now and installs automatically when im trying to emerge gnome?


Last edited by usf on Wed Dec 04, 2013 10:26 pm; edited 2 times in total
Back to top
View user's profile Send private message
dlaor
n00b
n00b


Joined: 27 Jan 2008
Posts: 55

PostPosted: Wed Dec 04, 2013 9:27 pm    Post subject: Reply with quote

If you want to install gnome-base/gnome-light-2.32.1-r2, as long as it is in the stable arch (it is now), then I think it suffices to add the following to /etc/portage/package.mask :

Code:

# Gnome light 2.32
>=app-arch/file-roller-3.2.2
>=app-text/evince-3.4.0
>=gnome-base/gconf-3.2.6
>=gnome-base/gnome-control-center-3.2.2-r1
>=gnome-base/gnome-keyring-3.2.2
>=gnome-base/gnome-light-3.2.1
>=gnome-base/gnome-menus-3.0.1-r1
>=gnome-base/gnome-panel-3.2.1
>=gnome-base/gnome-session-3.2.1-r1
>=gnome-base/gnome-settings-daemon-3.2.3
>=gnome-base/libgnome-keyring-3.2.2
>=gnome-base/nautilus-3.2.1
>=gnome-extra/yelp-3.2.1
>=gnome-extra/zenity-2.34
>=net-libs/gnutls-3.1.3
>=sys-apps/gnome-disk-utility-3.0.2-r300
>=x11-misc/alacarte-0.13.2-r50
>=x11-terms/gnome-terminal-3.2.1
>=x11-wm/metacity-2.34

# newest gtk+ breaks theming
>=x11-libs/gtk+-3.8


When emerging gnome-light you should then get the 2.32 version.

I do not know if the set above is minimal. Of course if you want to emerge gnome-base/gnome instead then you will need more masks, the set above can probably be used as a starting point.

Hope this helps!
Back to top
View user's profile Send private message
usf
n00b
n00b


Joined: 24 Oct 2013
Posts: 19

PostPosted: Wed Dec 04, 2013 9:47 pm    Post subject: Reply with quote

So as i understood u, to install gnome version 2 i need to mask (hide) newer version?
Ok, ill try this, ty very much!
Back to top
View user's profile Send private message
dlaor
n00b
n00b


Joined: 27 Jan 2008
Posts: 55

PostPosted: Wed Dec 04, 2013 10:01 pm    Post subject: Reply with quote

Yes, for example, putting the line

Code:
>=gnome-base/gnome-light-3.2.1


in /etc/portage/package.mask tells emerge not to install a version of gnome-light that is 3.2.1 or higher.

Again, the list above only works if you want to emerge the light version of gnome, gnome-base/gnome-light. If you want to install the full version, gnome-base/gnome, then you will need to mask many more packages. In particular, for example, you will have add a mask for gnome-base/gnome itself:

Code:
>=gnome-base/gnome-3.6.2


and so forth.

Also, at some point in the future gnome 2 will be removed from portage. Then we will have a problem, since then there will be no version of gnome-light that is below 3.2.1 and so emerge will complain that it cannot fulfill our wishes.

You are welcome!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum