Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ip address does not shows up when restarting the net.lo.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
srijiv.w2w
n00b
n00b


Joined: 04 Dec 2013
Posts: 4
Location: India

PostPosted: Wed Dec 04, 2013 6:22 am    Post subject: ip address does not shows up when restarting the net.lo. Reply with quote

Hi Everyone,

I am not able to figure out as to why I am not able to bring the ip address to the interface. So, here is what happens:-

I have a Dell PowerEdge R710 Server and I am uploading the gentoo-minimal image to it via IDRAC.. I boot from the image and to configure it for remote access, I try to configure an ip to it. I check the config file /sysc/class/net / to see the available interfaces on the server and then configure ip to its eno1 interface. I then configure soft-link for eno1 pointing it to net.lo interface under /etc/init.d. Once this is done, I restart the net.lo and net.eno1. The interface comes up but when I do 'ifconfig', I don’t see any ip on the eno1 interface. I just see lo interface with 169.x.x.x ip.

Please let me know if I am missing something here..I have been banging my head for some time now on this issue. I am not sure if Dell R710 even supports Gentoo. I have configured 6 R720 Servers with Gentoo without any issues. Not sure what exactly I am missing here.

Appreciate all your help in advance.

Thanks and Regards,
_________________
Srijiv Dimri

"Worship the Creator, not the Creation"
Back to top
View user's profile Send private message
anbc
n00b
n00b


Joined: 26 Jul 2013
Posts: 47

PostPosted: Wed Dec 04, 2013 6:42 am    Post subject: Reply with quote

Can you post your /etc/conf.d/net ?
or
Can you post your /etc/conf.d/network ?
or
Funtoo Linux on Dell PowerEdge 11G Servers (Gentoo too)
Back to top
View user's profile Send private message
srijiv.w2w
n00b
n00b


Joined: 04 Dec 2013
Posts: 4
Location: India

PostPosted: Wed Dec 04, 2013 6:48 am    Post subject: Reply with quote

Hi,

Thanks for looking into this. Please find the requested o/p's

vi /etc/conf.d/net
config_eno1=("10.164.253.215 netmask 255.255.255.0 broadcast 10.164.253.255")

There is no file names as '/etc/conf.d/network'

Appreciate all your time.

Thanks and Regards,
_________________
Srijiv Dimri

"Worship the Creator, not the Creation"
Back to top
View user's profile Send private message
anbc
n00b
n00b


Joined: 26 Jul 2013
Posts: 47

PostPosted: Wed Dec 04, 2013 7:03 am    Post subject: Reply with quote

Same thing, but try...

config_eno1="10.164.253.215/24"

and restart eno1

Sorry, can you also post:
/etc/hosts

your nics are 4xBCM 5709c - right?
Back to top
View user's profile Send private message
srijiv.w2w
n00b
n00b


Joined: 04 Dec 2013
Posts: 4
Location: India

PostPosted: Wed Dec 04, 2013 7:07 am    Post subject: Reply with quote

I tried the way you mentioned and restated the net.lo, net.eno1 and local services, but no Luck.


vi /etc/hosts
127.0.0.1 livecd.gentoo livecd localhost

Yes, the Server has NetXtreme II BCM5709 Gigabit Ethernet.

Thanks and Regards,
Srijiv Dimri
_________________
Srijiv Dimri

"Worship the Creator, not the Creation"
Back to top
View user's profile Send private message
anbc
n00b
n00b


Joined: 26 Jul 2013
Posts: 47

PostPosted: Wed Dec 04, 2013 7:19 am    Post subject: Reply with quote

over to the experts...

one last try from me - can you post the full output from ifconfig -a

or if you have iproute2 installed ip link
Back to top
View user's profile Send private message
srijiv.w2w
n00b
n00b


Joined: 04 Dec 2013
Posts: 4
Location: India

PostPosted: Wed Dec 04, 2013 7:24 am    Post subject: Reply with quote

Its hard for me to paste the o/p for ifconfig -a as the copy past is not happening from the IDRAC. But I see eno1, eno2, eno3, eno4 and lo interfaces.

Appreciate all your help.

Thanks and Regards,
Srijiv Dimri
_________________
Srijiv Dimri

"Worship the Creator, not the Creation"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum