Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Brightness Control Problem Solved
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
slicktux
n00b
n00b


Joined: 16 Jul 2013
Posts: 14
Location: CA

PostPosted: Sun Dec 01, 2013 11:44 pm    Post subject: Brightness Control Problem Solved Reply with quote

Thanks to the folks @ #gentoo i was able to finally resolve my Brightness Control Problem. Thee problem came about when i upgraded my Kernel from 3.8.13 to 3.10.7&3.10.17, i had lost all control of my laptop's screen brightness. after troubleshooting i noticed 'ls /sys/class/backlight' gave me an output of 'acpi_video0' along with 'intel_backlight'. it was then clear to me what the problem was, my kernel was choosing 'acpi_video0' instead of 'intel_backlight'. i resolved my problem by adding a parameter to my grub ' acpi_backlight=vendor' and walla problem solved. Now i am left with a question why am i getting acpi_video0 when i do not use ATI driver? the first kernel i ever installed was 3.8.13 and my driver worked out-the-box 'no parameters necessary'. is there a change in all the new kernels that automatically give you both acpi_video0 and intel_backlight? is adding a parameter going to be necessary for all future kernel's? or am i doing something wrong?
_________________
The Future Is Linux
The Future Is Now
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum