Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to setup PPTP VPN? [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Fri Nov 22, 2013 8:49 pm    Post subject: How to setup PPTP VPN? [solved] Reply with quote

See the question above.

N.B. None of examples and documentation of pptp works!

Connection to VPN server is not a problem.
Obviously the main problem is routing, but! I might be mistaken.

Behaviour of pptpclient is very dubious. It create a wrong route by itself
and there is No way to prevent it from doing so. Only route del... helps.

Also usepeerdns is set in the settings, but variable $USEPEERDNS remains undefined.
So the script which is replacing resolv.conf has to be modified - commented.

When all that is done and new rules are set, I can ping VPN server, DNS server and even youtube.com
Means name resolving works too.

But, I can't open a web page. Well sometimes I can, but youtube.com and staff can not be opened.

Once I have succeed, but then it has stopped working and the issue with usepeerdns appears.

At the same time VPN connection over NetworkManager works well.

The most curious thing is, that NO proper documentation on that topic existing.
There are thousands examples, but all them are wrong and.. different.

I was trying to simulate route table based on NM but without success.
_________________
Lefsha


Last edited by lefsha on Fri Nov 22, 2013 9:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Fri Nov 22, 2013 9:10 pm    Post subject: Reply with quote

Can not find any polite words to describe my feeling...

The problem is MTU value.
Changing it to 1400 like at NM helps.

But still pptp IS buggy. It doesn't start scripts automatically as it should
and does things it should not! What a crap software....
_________________
Lefsha
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum