Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Eterm and xterm broken after udev update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
doublehp
Guru
Guru


Joined: 11 Apr 2005
Posts: 439
Location: FRANCE

PostPosted: Sun Mar 16, 2014 9:26 pm    Post subject: Eterm and xterm broken after udev update Reply with quote

Eterm gives me the same error message for user and root; in both case I get a prompt; in parent shell, I get this message:
Quote:
Eterm: Error: grantpt(4) failed: No such file or directory


xterm works perfectly well as root, but as user, I get this message, a new window, and no prompt in it:
Quote:
xterm: Error 18, errno 13: Permission denied
Reason: spawn: open() failed on ptsname


My devpts is mounted coprrectly:
Code:
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620)


and my pt_chown have the right props:
Code:
-rws--x--x 1 root root 9.2K 2010-11-12 18:31 /usr/lib32/misc/glibc/pt_chown
-rws--x--x 1 root root  10K 2010-11-12 18:31 /usr/lib64/misc/glibc/pt_chown


There is a strange detail:
Code:
root@uranus:/etc/udev which xterm
/usr/bin/xterm
root@uranus:/etc/udev equery b /usr/bin/xterm
 * Searching for /usr/bin/xterm ...
root@uranus:/etc/udev

_________________
DEMAINE Benoît-Pierre (aka DoubleHP ) http://www.demaine.info/
>o_/ Coin coin coin \_o<
to contact me (MSN,ICQ, JABBER, Skype ... ) http://benoit.demaine.info/contact.png
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum