Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] `OPENLDAP_2.4_2' not found -- but lib is present
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
DZoom
n00b
n00b


Joined: 13 Jun 2010
Posts: 59

PostPosted: Fri Oct 25, 2013 7:48 pm    Post subject: [SOLVED] `OPENLDAP_2.4_2' not found -- but lib is present Reply with quote

Hi,

I have issues starting rainlendar in its current 64bit version on three different machines w/ 64bit gentoo installations.
the program is available from here:
http://www.rainlendar.net/cms/index.php?option=com_kunena&Itemid=42&func=view&catid=7&id=19989

the error message i get:
Code:
~ $ rainlendar
/usr/lib/rainlendar2/rainlendar2: /usr/lib64/liblber-2.4.so.2: version `OPENLDAP_2.4_2' not found (required by /usr/lib/rainlendar2/rainlendar2)
/usr/lib/rainlendar2/rainlendar2: /usr/lib64/libldap_r-2.4.so.2: version `OPENLDAP_2.4_2' not found (required by /usr/lib/rainlendar2/rainlendar2)


openldap is installed in version 2.4.35-r1:
Code:
~ $ eix -I openldap
[I] net-nds/openldap
     Available versions:  2.3.43-r1 2.3.43-r3 2.3.43-r4 2.4.19-r1 ~2.4.21 2.4.23 2.4.24 ~2.4.25 ~2.4.25-r1 ~2.4.28 2.4.28-r1 2.4.30 ~2.4.31 ~2.4.31-r1 ~2.4.32 ~2.4.33 ~2.4.33-r1 ~2.4.33-r2 2.4.35 2.4.35-r1 {(+)berkdb crypt -cxx debug experimental gdbm gnutls icu iodbc ipv6 kerberos minimal odbc overlays perl samba sasl selinux slp smbkrb5passwd ssl +syslog tcpd}
     Installed versions:  2.4.35-r1(10:32:00 PM 10/22/2013)(berkdb crypt gnutls minimal ssl syslog tcpd -cxx -debug -experimental -icu -iodbc -ipv6 -kerberos -odbc -overlays -perl -samba -sasl -selinux -slp -smbkrb5passwd)
     Homepage:            http://www.OpenLDAP.org/
     Description:         LDAP suite of application and development tools



the ldap use flag is also enabled globally
emerge info on this machine is as follows:
emerge --info wrote:
Portage 2.2.7 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.15-r3, 3.10.7-gentoo-r1 x86_64)
=================================================================
System uname: Linux-3.10.7-gentoo-r1-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4400+-with-gentoo-2.2
KiB Mem: 3344884 total, 235928 free
KiB Swap: 2097148 total, 2097148 free
Timestamp of tree: Fri, 25 Oct 2013 15:15:01 +0000
ld GNU gold (GNU Binutils 2.23.1) 1.11
app-shells/bash: 4.2_p45
dev-java/java-config: 2.1.12-r1
dev-lang/python: 2.7.5-r3, 3.2.5-r3
dev-util/cmake: 2.8.10.2-r2
dev-util/pkgconfig: 0.28
sys-apps/baselayout: 2.2
sys-apps/openrc: 0.11.8
sys-apps/sandbox: 2.6-r1
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.12.6, 1.13.4
sys-devel/binutils: 2.23.1
sys-devel/gcc: 4.7.3-r1
sys-devel/gcc-config: 1.7.3
sys-devel/libtool: 2.4.2
sys-devel/make: 3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc: 2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O3 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=k8 -O3 -pipe -finline-functions -flto -fwhole-program -floop-parallelize-all -fuse-linker-plugin"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://gd.tuwien.ac.at/opsys/linux/gentoo/ ftp://gentoo.mirror.web4u.cz/ ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ ftp://ftp6.uni-erlangen.de/pub/mirrors/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -O3 -flto -fuse-linker-plugin"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 bash-completion berkdb branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dedicated dri dts dvd dvdr emboss encode exif fam ffmpeg fftw flac ftp g3dvl gdbm gif git gnutls gpm gtk iconv icq ieee1394 inotify java jpeg jpeg2k latex lcms ldap libnotify mad matroska mmx mng modules mp3 mp4 mpd mpeg mtp mudflap multilib ncurses nls nptl nvidia ogg openal opengl openmp pam pango pcre pdf png policykit ppds python qt3support quicktime readline sdl session smp spell sse sse2 ssl startup-notification subversion svg tcpd thunar tiff truetype udev udisks unicode upower usb vcd vdpau videos vorbis win32codecs wxwidgets x264 xcb xml xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON




for my limited programming skills it seems to me that the symbol OPENLDAP_2.4_2 is missing? but how to fix it?
i also tried emerging net-nds/openldap=2.4.28-r1
which worked fine; but the error stays the same.

any ideas are appreciated!


Last edited by DZoom on Wed Nov 20, 2013 2:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Fri Oct 25, 2013 10:17 pm    Post subject: Reply with quote

It seems this program was built against openldap version, that was built in some way that's incompatible with versions available in portage.
Perhaps that one was patched to have versioned symbols ?
One way or the other, this program won't work without libldap built the same way.
Back to top
View user's profile Send private message
DZoom
n00b
n00b


Joined: 13 Jun 2010
Posts: 59

PostPosted: Wed Nov 20, 2013 2:29 pm    Post subject: Reply with quote

problem were to agressive compile flags for the whole system.
changed them back to modest ones
and rebuild my whole system
afterwards rainlendar started just fine.

also see here: https://forums.gentoo.org/viewtopic-p-7420140.html#7420140
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum