Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
making alsa work with SB Live
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
lethe
n00b
n00b


Joined: 25 Jun 2002
Posts: 49

PostPosted: Fri Jul 26, 2002 6:22 pm    Post subject: making alsa work with SB Live Reply with quote

i m hoping to get some help making alsa work with my soundblaster live sound card.

i have been following the instructions on the gentoo desktop page, and when i get to the part where i am suppposed to get a bunch of info by running amixer, instead i see this:

Code:

# amixer
amixer: Mixer attach default error: No such file or directory


i have alsa-utils 0.9.0_rc2 installed, kernel 2.4.19-rc1. my /etc/devfsd.conf and my /etc/modules.d/alsa look identical to the ones on the page, since i have the same soundcard. one thing, i actually had already installed alsa-utils before i did the stuff on that page, but when i found the page, and followed those instructions, i unmerged and re-emerged alsa-utils.

so, any advice is appreciated. what causes this error, what is amixer missing? thanks
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16090
Location: Colorado

PostPosted: Fri Jul 26, 2002 6:48 pm    Post subject: Reply with quote

Do you have sound support enabled in the kernel? With alsa, you shouldn't.
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
lethe
n00b
n00b


Joined: 25 Jun 2002
Posts: 49

PostPosted: Fri Jul 26, 2002 7:11 pm    Post subject: Reply with quote

well that desktop page says this:

Quote:

One note; if you've installed a new sys-kernel/linux-sources package, make sure that your Linux kernel has sound support enabled.


and this page from the alsa webpage says:
Quote:

You must compile the kernel with sound support , you do not need to select any of the other sound modules apart from sound support


so, for alsa, i am supposed to have generic sound support in the kernel, but not any specific sound card modules? i didn t know that it was required to not install any sound modules. so i installed both basic sound support, and my sound card module. do you think this is the problem? i have discovered that i do have sound support using cat > /dev/dsp, but the alsa-utils amixer and such still don t work, so i think i am using the kernel driver.

alsa is better than the current kernel drivers, right? so i should prefer it. i will make a new kernel without the sound card module, and then try again with alsa-utils, and report back. thanks for the tip.
Back to top
View user's profile Send private message
metalhedd
l33t
l33t


Joined: 30 May 2002
Posts: 692
Location: Ontario Canada

PostPosted: Fri Jul 26, 2002 10:13 pm    Post subject: Reply with quote

You most definitely CAN'T Have kernel support for your card built into the kernel. only generic sound card support.

In my experience the kernel driver for an SB Live sounded Horrible. other people have had other experiences though. I am currently using a kernel patched to have alsa support built right in and it sounds great. the regular alsa 0.9 drivers sounded great too.. kernel sound was just terrible though.
Back to top
View user's profile Send private message
Mr. Pointy
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2002
Posts: 77

PostPosted: Sun Jul 28, 2002 3:05 am    Post subject: Reply with quote

my /etc/modules.d/alsa

Code:
# Alsa 0.9.X kernel modules' configuration file.
#/space/gentoo/cvsroot/gentoo-x86/media-sound/alsa-driver/files/alsa-modules.conf,v 1.3 2002/06/24 18:05:58 agenkin Exp

# ALSA portion
alias char-major-116 snd
options snd snd_cards_limit=1
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
alias snd-card-0 snd-emu10k1
options snd-emu10k1 snd_extin=0x0003 snd_extout=0x1f03
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss


check /usr/doc/alsa-driver-0.9.0_rc2/INSTALL.gz for the snd_extin and snd_extout for your model
Back to top
View user's profile Send private message
lethe
n00b
n00b


Joined: 25 Jun 2002
Posts: 49

PostPosted: Mon Jul 29, 2002 6:21 pm    Post subject: Reply with quote

thanks for the advices. unfortunately, it didn t seem to help. i recompiled the kernel, this time without the soundblaster stuff checked, and i still got the error from alsa, amixer posted above. /dev/dsp wasn t there at all, so sound was entirely broken.

my /etc/devfs.conf
Code:

# ALSA/OSS stuff
# Comment/change these if you want to change the permissions on
# the audio devices
LOOKUP          snd          MODLOAD ACTION snd
LOOKUP          dsp          MODLOAD
LOOKUP          mixer        MODLOAD
LOOKUP          midi         MODLOAD
REGISTER        sound/.*     PERMISSIONS root.audio 660
REGISTER        snd/.*       PERMISSIONS root.audio 660


my /etc/modules.d/alsa file:

Code:

# Alsa 0.9.X kernel modules' configuration file.
# $Header: /home/cvsroot/gentoo-x86/media-sound/alsa-driver/files/alsa-modules.conf,v 1.3 2002/06/24 18:05:58 agenkin Exp $

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

alias snd-card-0 snd-emu10k1
alias snd-card-1 snd-emu10k1
alias snd-card-2 snd-emu10k1
alias snd-card-3 snd-emu10k1
alias snd-card-4 snd-emu10k1
alias snd-card-5 snd-emu10k1
alias snd-card-6 snd-emu10k1
alias snd-card-7 snd-emu10k1



# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss
Back to top
View user's profile Send private message
nitro322
Guru
Guru


Joined: 24 Jul 2002
Posts: 551
Location: USA

PostPosted: Mon Jul 29, 2002 10:43 pm    Post subject: Reply with quote

Try recompiling one more time. Make sure you have Sound -> Sound card support enabled as a module, as well as Sound -> OSS sound modules (don't choose any drivers from the list, but do enable OSS sound modules as a module - it gives you soundcore.o, which is needed for certain apps). Install the new kernel and reboot. Do a 'modprobe sound' and then try loading your ALSA drivers. If that doesn't work, 'modprobe soundcore' and try again. I've had ALSA working before with an SB Live!, so it's definitely possible. If it still won't work, do you absolutely need the ASLA drivers? I switched from ALSA to the emu10k1 drivers available from http://sourceforge.net/projects/emu10k1. Supports everything I need, including digital out and AC3 bybass. Just a suggestion.
Back to top
View user's profile Send private message
azambuja
Apprentice
Apprentice


Joined: 12 Jul 2002
Posts: 257
Location: Porto Alegre, RS, Brazil

PostPosted: Wed Jul 31, 2002 4:53 pm    Post subject: theres the answer!!! Reply with quote

hello,

ive got the same problem a while ago, be sure to check this topic:
https://forums.gentoo.org/viewtopic.php?t=7796&highlight=

that really should get you out of trouble...

cheers
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum