Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Plymouth showing distorted, KMS Radeon
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
agrypa1
Apprentice
Apprentice


Joined: 31 Mar 2005
Posts: 243

PostPosted: Sun Nov 24, 2013 7:29 pm    Post subject: Plymouth showing distorted, KMS Radeon Reply with quote

Hi, My plymouth setup doesn't not work during boot time.

Hi have compiled a kernel with KMS support for the following hardware:

Code:

00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI BeaverCreek [Radeon HD 6550D]
   Subsystem: ASUSTeK Computer Inc. Device 84c8
   Kernel driver in use: radeon
   Kernel modules: radeon


While doing so I used the following command:
Code:

genkernel --kernel-config=.config  --plymouth-theme=solar all


The defaults for genkernel were: --install, --plymouth, --symlink. --no-splash

The end result for relevant part of the compilation was this:

Code:

initramfs: >> Initializing...
*         >> Appending base_layout cpio data...
*         >> Appending auxilary cpio data...
*         >> Copying keymaps
*         >> Appending busybox cpio data...
*         >> Appending modules cpio data...
*         >> Appending blkid cpio data...
*         >> Appending plymouth cpio data...
*   >> Installing plymouth [ using the solar theme and plugin: "space-flares" ].


The grub.cfg file has this:

Code:

echo   'Loading Linux x86_64-3.10.6-rt-rt3 ...'
      linux   /kernel-genkernel-x86_64-3.10.6-rt-rt3 root=UUID=397bfb7e-3a87-4e09-8981-b9de5353d5a4 ro  quiet splash rootfstype=ext4
      echo   'Loading initial ramdisk ...'
      initrd   /initramfs-genkernel-x86_64-3.10.6-rt-rt3


The problem now is that at boot time the solar theme is reduced to one line, as if some kind of text mode was enforced on the screen resolution.
I have no clue where to start digging.

Is Grub2 standing in the way for plymouth?
Perhaps some of the gfxmode stuff prevents solar theme to be shown on the whole screen?

Here is the /etc/default/grub from which the grub.cfg gets generated:

Code:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash rootfstype=ext4"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal.
# Note that you can use only modes which your graphic card supports via VBE.
# You can see them in real GRUB with the command `vbeinfo'.
#GRUB_GFXMODE=640x480
#GRUB_GFXMODE=auto

# my additions below
#GRUB_GFXPAYLOAD_LINUX=keep
# end my addition

# Path to theme spec txt file.
# The starfield is by default provided with use truetype.
# NOTE: when enabling custom theme, ensure you have required font/etc.
#GRUB_THEME="/boot/grub2/themes/starfield/theme.txt"

# Background image used on graphical terminal.
# Can be in various bitmap formats.
#GRUB_BACKGROUND="/boot/grub2/mybackground.png"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to kernel
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY=true


Any help is greatly appreciated

Agryppa
_________________
The first successor of Saint Peter was Linus (a.d. 68-79) - whose namesake became the creator of Linux in our time. Torvalds' middle name is Benedict - the name assumed by the previous Pope who resigned from office.
Back to top
View user's profile Send private message
agrypa1
Apprentice
Apprentice


Joined: 31 Mar 2005
Posts: 243

PostPosted: Tue Nov 26, 2013 7:28 pm    Post subject: Reply with quote

Let me do the follow-up to my own message.
the installation itself seems to be in a working condition.

The following commands produce forseeable results:

Code:

/usr/sbin/plymouthd
plymouth --show-splash


The screen fills up witha nice solar splash screen.
I can killall the proces from a different terminal.
Themes allow to be changed with

Code:

plymouth-set-default-theme --list
details
fade-in
glow
script
solar
spinfinity
spinner
text


Code:

 plymouth-set-default-theme text 


And now the screen shows THE SAME screen as during boot. Which seems ugly. One three color line travels right on the screen.

The question is why plymouth shows the text splash screen during boot if the initramsfs was made with genkernel like this:
Code:

genkernel --kernel-config=.config  --plymouth-theme=solar all


Plymouth will fallback to text mode if other modes are not available due to lack of framebufffer or something in that line.
Any hints will be greatly appreciated.

Could my problem be that I do not use make clean and make mrproper with genkernel?
And one more thing. The help file for genkernel-next says that --plymouth forces --udev. Does that mean that --udev is implied and does not have to be included on the command line?


Here is a grep of my /var/log searching for p;ymouth
[url] http://bpaste.net/show/153285 [/url]
Agryppa
_________________
The first successor of Saint Peter was Linus (a.d. 68-79) - whose namesake became the creator of Linux in our time. Torvalds' middle name is Benedict - the name assumed by the previous Pope who resigned from office.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum