Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Cinnamon wallpaper || INSTALL CINNAMON2 on GENTOO
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
fulminemizzega
n00b
n00b


Joined: 09 Jun 2013
Posts: 10

PostPosted: Fri Nov 15, 2013 12:16 am    Post subject: [SOLVED] Cinnamon wallpaper || INSTALL CINNAMON2 on GENTOO Reply with quote

SOLVED! SEE 2nd POST FOR CINNAMON2 IN GENTOO

Hi all!
I'm trying Cinnamon under Gentoo, but right now I'm facing an issue which I'm not able to solve in any way.
On a vm, with gnome 3.8 and cinnamon 1.8.8.1 installed, using cinnamon as DE, I'm not able to change wallpaper using cinnamon-settings. Instead, using the gnome setting panel I'm able to change it. I think this is quite weird, since Cinnamon settings should stick to Cinnamon DE and the same goes for the Gnome DE.
On another PC, I've had KDE installed, now I've changed my profile to desktop/gnome/systemd and emerged Cinnamon 2.0 from Sabayon overlay (I masked the whole overlay except for the few cinnamon required packages (see pastebin) ). My hope was that the strange wallpaper settings behaviour was gone, but it isn't, but this time, I have'nt the gnome settings panel available.
Now, I've read somewhere that having Nautilus and Nemo installed could lead to conflicts in the desktop management, but here there is only Nemo as desktop manager.
From my findings, I've noticed that changing background by right clicking on an image and setting it as desktop background works, but the keys changed in dconf are
/org/gnome/desktop/background/picture-uri
/org/cinnamon/desktop/background/picture-uri

But the funny thing is, if I change background from cinnamon-settings, only
/org/cinnamon/desktop/background/picture-uri

is changed. And this setting is STILL completely IGNORED. From what I've found, this dconf key is used by Gnome DE when setting the desktop background, insted

/org/cinnamon/desktop/background/picture-uri

is the one used by Cinnamon. So, from what I've seen, changing background from Nemo changes both the two keys, changing it from cinnamon-settings affects only the Cinnamon's one (which I think is good). Now, if I set /org/gnome/desktop/background/picture-uri to nothing, the background goes back to the stock Gnome 3 one (with blue vertical stripes, I think the colour changes with the time, does it?). Guess what, now changing wallpaper in cinnamon-settings still does not work (it is changing the same dconf key, of course).
Killing the Nemo process leads to something more interesting: no icons on the desktop, but the wallpaper changes correctly. If in dconf I disable Nemo as the desktop manager (uncheck org.nemo.desktop.show-desktop-icons ) wallpaper settings are correctly applied, but I'd like to have Nemo manage my desktop.

It looks like nemo is using the wrong key to set the desktop background... I'm out of ideas :)
What can be done to fix this issue? Does it happen also in Linux Mint?

And... I'm on ~amd64, with CFLAGS="-O2 -march=core-avx2 -maes -fomit-frame-pointer", if it changes anything.

http://pastebin.com/JttaxXB0


Last edited by fulminemizzega on Sat Nov 16, 2013 12:29 am; edited 2 times in total
Back to top
View user's profile Send private message
fulminemizzega
n00b
n00b


Joined: 09 Jun 2013
Posts: 10

PostPosted: Sat Nov 16, 2013 12:27 am    Post subject: Reply with quote

I'm answering myself, but I must thank the guys at #linuxmint-dev for helping me, even if the solution is quite simple.

By masking the whole Sabayon overlay, except for cinnamon (you can see what my package.unmask looked like using the link above), I emerge cinnamon2 with nemo 1.8.5 (the version from the portage tree).

The thing is, nemo-1.8.5 in gentoo's portage tree must be compiled or patched so that it uses the /org/gnome/desktop/background/picture-uri key to set the background image, instead of the default cinnamon's one. Simply unmasking also nemo from the Sabayon overlay solved the issue, as it installed nemo 2.0.5.

A linuxmint dev said that since Cinnamon2, Nemo is not anymore drawing the desktop, it is cinnamon itself.

So at this point, to make this thread a little more interesting, or, at least, useful, I'll write down what it is needed to have a basic cinnamon2 DE in Gentoo:

1. Right now, you must use layman and add Sabayon overlay ( layman -a sabayon ), since portage has still cinnamon 1.8-something
2. I think it's better if you mask the whole Sabayon overlay, except cinnamon and nemo, which can be done using package.mask and package.unmask: see http://pastebin.com/YsvaTTtw
3. emerge cinnamon
4. If you don't have any Desktop Manager, you should install one, if you don't want to start cinnamon from console. I'm using Lightdm.

I think then something will still be missing, probably fonts.

EDIT: It looks like mit-krb5 is required by cinnamon but not automatically emerged. You need to emerge it manually, otherwise, cinnamon won't compile.
Back to top
View user's profile Send private message
shadywack
n00b
n00b


Joined: 30 Aug 2012
Posts: 5

PostPosted: Tue Apr 01, 2014 8:53 am    Post subject: Reply with quote

This helped me try out Cinnamon 2, thanks for sharing this. I appreciated it quite a bit.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum