Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Problems setting correct regul. domain on wifi AP
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
zidour
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2004
Posts: 103

PostPosted: Thu Nov 14, 2013 11:17 am    Post subject: [solved] Problems setting correct regul. domain on wifi AP Reply with quote

After upgrading many packages on my AP I am having troubles setting correct regulatory domain for my wifi card.
Upon startup, I am getting the following in /var/log/messages:

Code:

Nov 12 21:22:45 server kernel: cfg80211: Calling CRDA to update world regulatory domain
Nov 12 21:22:45 server kernel: pcieport 0000:00:15.0: driver skip pci_set_master, fix it!
Nov 12 21:22:45 server kernel: ath: EEPROM regdomain: 0x809c
Nov 12 21:22:45 server kernel: ath: EEPROM indicates we should expect a country code
Nov 12 21:22:45 server kernel: ath: doing EEPROM country->regdmn map search
Nov 12 21:22:45 server kernel: ath: country maps to regdmn code: 0x52
Nov 12 21:22:45 server kernel: ath: Country alpha2 being used: CN
Nov 12 21:22:45 server kernel: ath: Regpair used: 0x52


and then later on

Code:
Nov 12 21:22:45 server kernel: cfg80211: Pending regulatory request, waiting for it to be processed...


Before the update (i.e. when setting the reg domain worked) the latter part of the log would be
Code:

Oct 14 12:04:46 server kernel: cfg80211: Calling CRDA for country: CZ
... channel list ...
Oct 14 12:04:46 server kernel: cfg80211: Regulatory domain changed to country: CZ
.

I was trying to narrow down the problem and found out that there might be some problem with the regulatory.bin file:
Code:

# regdbdump /usr/lib64/crda/regulatory.bin
Database signature verification failed.


I was verifying that the regulatory.bin file is binary identical to the one distributed by the linux wireless project (it is), next I was checking that the public key used to verify the DB is identical to the one that belongs to John Linville (it is).

This leaves me clueless.

Potentially there might be some issue after upgrading either openssl or m2crypto packages, which are used to extract the public key into a C structure during the emerge process for CRDA, but I doubt this.

Could anyone please suggest any further steps to narrow down the problem?
Thanks.

Edit: Package versions after/before update:
crda: 1.1.3/1.1.2-r4
wireless-regdb: 20131011/20110428-r1
openssl: 1.0.1e-r2/1.0.1c
m2crypto: 0.21.1-r1/0.21.1


Last edited by zidour on Mon Dec 09, 2013 8:59 am; edited 1 time in total
Back to top
View user's profile Send private message
zidour
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2004
Posts: 103

PostPosted: Mon Dec 09, 2013 8:58 am    Post subject: Solved Reply with quote

It must have been an issue with the net-wireless/wireless-regdb-20131011 package. All is fine after upgrading to net-wireless/wireless-regdb-20131127.
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1360
Location: Montréal

PostPosted: Mon Dec 09, 2013 12:33 pm    Post subject: Reply with quote

As a side note, you can set the country you want to use with the ieee80211_regdom option of the cfg80211 module. I dont see any other place to set it in Gentoo than write a line in /etc/modprobe.d/modprobe.conf
Code:
options cfg80211 ieee80211_regdom=XX

Obviously XX must be change for your country. With Debian, I can set it too in the configuration file /etc/default/crda.
Code:
modinfo cfg80211
filename:       /lib/modules/3.10.17-gentoo/kernel/net/wireless/cfg80211.ko
description:    wireless configuration support
license:        GPL
author:         Johannes Berg
depends:       
intree:         Y
vermagic:       3.10.17-gentoo SMP preempt mod_unload modversions
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

_________________
Paul
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1371

PostPosted: Mon Dec 09, 2013 2:17 pm    Post subject: Reply with quote

Everyone only in need to connect to default domain channels per wifi can create this file
Code:
# cat /etc/udev/rules.d/85-regulatory.rules
# Runs CRDA for kernel wireless regulatory events.
# For more information see:
# http://wireless.kernel.org/en/developers/Regulatory/CRDA
# KERNEL=="regulatory*", ACTION=="change", SUBSYSTEM=="platform", RUN+="/sbin/crda"
KERNEL=="regulatory*", ACTION=="change", SUBSYSTEM=="platform", RUN+="/bin/true"

_________________
fun2gen2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum