Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] pathological gone
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 02 Nov 2004
Posts: 104

PostPosted: Sun Dec 08, 2013 12:05 am    Post subject: [Solved] pathological gone Reply with quote

pathological when starts shows:


stefano@stelinux ~ $ pathological &
[1] 22046
stefano@stelinux ~ $ Traceback (most recent call last):
  File "./", line 21, in <module>
    import os, pygame, random, time, math, re, sys, md5
  File "/usr/lib64/python2.7/site-packages/pygame/", line 265, in <module>
    try: import pygame.sndarray
  File "/usr/lib64/python2.7/site-packages/pygame/", line 68, in <module>
    import pygame._numpysndarray as numpysnd
  File "/usr/lib64/python2.7/site-packages/pygame/", line 38, in <module>
    import numpy
  File "/usr/lib64/python2.7/site-packages/numpy/", line 137, in <module>
    import add_newdocs
  File "/usr/lib64/python2.7/site-packages/numpy/", line 9, in <module>
    from numpy.lib import add_newdoc
  File "/usr/lib64/python2.7/site-packages/numpy/lib/", line 13, in <module>
    from polynomial import *
  File "/usr/lib64/python2.7/site-packages/numpy/lib/", line 11, in <module>
    import numpy.core.numeric as NX
AttributeError: 'module' object has no attribute 'core'

[1]+  Exit 1                  pathological

emerge --info


Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.16.0, 3.10.17-gentoo-r0 x86_64)
System uname: Linux-3.10.17-gentoo-r0-x86_64-Intel-R-_Core-TM-_i7_CPU_950_@_3.07GHz-with-gentoo-2.2
KiB Mem:    12275472 total,    269100 free
KiB Swap:   11727444 total,  11727444 free                                                     
Timestamp of tree: Thu, 05 Dec 2013 19:45:01 +0000                                             
ld ld di GNU (GNU Binutils) 2.23.1                                                             
app-shells/bash:          4.2_p45                                                             
dev-java/java-config:     2.1.12-r1                                                           
dev-lang/python:          2.7.5-r3, 3.2.5-r3, 3.3.2-r2                                         
dev-util/pkgconfig:       0.28                                                                 
sys-apps/baselayout:      2.2                                                                 
sys-apps/openrc:          0.12.4                                                               
sys-apps/sandbox:         2.6-r1                                                               
sys-devel/autoconf:       2.13, 2.69                                                           
sys-devel/automake:       1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.4                   
sys-devel/binutils:       2.23.1                                                               
sys-devel/gcc:            4.6.3, 4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo science stefano
CFLAGS="-march=corei7 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -O2 -pipe"
EMERGE_DEFAULT_OPTS="--jobs=4 --load-average=4 --keep-going=y --with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4 -l4"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/science /var/lib/stefano"
USE="X Xaw3d a52 aac aalib acl acpi alsa amd64 amr avahi berkdb bluetooth bluray branding bzip2 cairo caps cdda cdr cli consolekit cracklib crypt cups curl cxx dbus declarative dirac directfb djvu dri dts dvd dvdr egl emboss encode exif expat faac faad fam fbcon ffmpeg fftw firefox flac fontconfig fontforge fortran frei0r gdbm gif gles gnutls gpg gphoto2 gpm graphviz gstreamer gtk iconv icu ieee1394 ipv6 jack java jbig jpeg jpeg2k kde kipi latex lcms ldap libcaca libnotify lua lzma mad mmx mng modules mp3 mp4 mpeg mplayer mudflap multilib music mysql ncurses nls nptl ocaml odbc ogg openexr opengl openmp pam pango pch pcre pdf perl phonon plasma png policykit postscript ppds private-headers ps python python3 qt3support qt4 readline reports scanner schroedinger sdl semantic-desktop session slang smp snmp speex spell sqlite sse sse2 ssh ssl ssse3 startup-notification svg swig tcl tcpd theora thumbnail tiff tk truetype udev udisks unicode upower usb v4l v4l2 vdpau vorbis wmf wxwidgets x264 xattr xcb xcomposite xinerama xml xscreensaver xv xvid xvmc zeroconf zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console nlpsolver pdfimport scripting-beanshell scripting-javascript wiki-publisher" LINGUAS="it" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python3_3 python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia vesa v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

I try to recompile pygame numpy and pathological but no result.

Edit: numpy-1.8.0 resolve pathological and monsterz that have the same problem
stelinux on i7 950 12GB 1600 8/8/8 GP106
gentoo 17.0/no-multilib
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum