Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
backlight and nm-applet problems with kernel upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
imesg
Guru
Guru


Joined: 12 Jul 2002
Posts: 371

PostPosted: Mon Nov 11, 2013 4:00 am    Post subject: backlight and nm-applet problems with kernel upgrade Reply with quote

This is a strange problem. And maybe not a gentoo problem but an upstream problem. I am posting here with the hope that someone here may have an answer or insight enough to tourbleshoot the problems.

I have an lenovo yoga 11s laptop. I am using gnome3 with systemd running mostly good. I am presently running a vanilla-sources 3.10.5 kernel. I also boot an efi kernel. Today I tried to run a 3.12.0 kernel and the result is:

1 At boot time after the initial "Lenovo" screen I see some boot messages momentarily (somewhat less than a second) then the screen seemingly goes blank. But what is really happening is that the backlight goes off but the lcd is continuing to function normally. I found this out by using the hdmi output to my TV and a flashlight to examine the screen. The boot process continues normally. I can start X. After that I can switch to another terminal and login as root and echo some value into /sys/class/backlight/intel_backlight/backlight (not sure exactly about the path though) and increase the brightness. (Also I set CONFIG_CMDLINE="root=/dev/sda3 init=/usr/lib/systemd/systemd acpi_video=vendor"
under 'Processor Type and Features'. For the 3.10.5 kernel I have 'acpi_video=backlight'. The backlight control applet although present has no effect.

2. nm-applet also present has no effect. I can however use 'Network Settings" to control my wireless connection. To actually kill wireless though I have to select 'Airplane Mode' to 'Off'.

There could be and probably are other effects that I am unaware of. On one level the two things could be could be connected. Maybe a permission problem. But they could be completely unrelated. This happened recently when I tried another kernel between 3.10.5 and 3.12.0 but I went back to 3.10.5 and forgot about it.

On the face of it though it seems that this is a kernel problem or change in the kernel that I can't figure out.

Any help would be appreciated.

Thanks,
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum