Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Strange emerge after error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Ahnilated
n00b
n00b


Joined: 12 Sep 2010
Posts: 39

PostPosted: Tue Nov 05, 2013 2:14 pm    Post subject: Strange emerge after error Reply with quote

Today I did an emerge and got an error about the server being out of date. I removed the time stamp as it suggested (see below) and then got files that were wrong for my system. I have the 3.10.17-gentoo kernel installed and it is trying to install 3.10.7-r1 which I had before this as well as a lot of other files. Now I don't want to do this update and hose my system. Anyone have any thoughts?

__________________________________
n0zca ~ # emerge --sync
>>> Synchronization of repository 'gentoo' located in '/usr/portage'...
>>> Starting rsync with rsync://134.161.116.17/gentoo-portage...
>>> Checking server timestamp ...
* Hardware specifications
Architecture: Dual PPC (Xserve)
OS: Debian PPC

* Bandwidth specifications
1Gbps feed to the community (egress), and Internet2 support.

* Location
The University of Northern Iowa, Cedar Falls, IA

* Connections
30 per each rsync module.
_ _ _ _ ___
| | | | \ | |_ _|
| | | | \| || | -o)
| |_| | |\ || | /\\
\___/|_| \_|___| _\_V

Access terminated if penguin violated
Don't mess with the penguin

gentoo.cs.uni.edu [134.161.240.18]
----------------------------------
rsync server at gentoo.cs.uni.edu
----------------------------------
Resources hosted by the Department
of Computer Science at the
University of Northern Iowa


receiving incremental file list
timestamp.chk

Number of files: 1
Number of files transferred: 1
Total file size: 32 bytes
Total transferred file size: 32 bytes
Literal data: 32 bytes
Matched data: 0 bytes
File list size: 27
File list generation time: 0.001 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 98
Total bytes received: 874

sent 98 bytes received 874 bytes 648.00 bytes/sec
total size is 32 speedup is 0.03

>>>
>>> SERVER OUT OF DATE: rsync://134.161.116.17/gentoo-portage
>>>
>>> In order to force sync, remove '/usr/portage/metadata/timestamp.chk'.
>>>

>>> Retrying...
!!! Exhausted addresses for rsync6.us.gentoo.org
n0zca ~ # rm /usr/portage/metadata/timestamp.chk
n0zca ~ # emerge --sync
>>> Synchronization of repository 'gentoo' located in '/usr/portage'...
>>> Starting rsync with rsync://134.161.116.17/gentoo-portage...



Literal data: 22.35M bytes
Matched data: 0 bytes
File list size: 4.18M
File list generation time: 0.001 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 186.31K
Total bytes received: 13.86M

sent 186.31K bytes received 13.86M bytes 720.26K bytes/sec
total size is 310.46M speedup is 22.11
q: Updating ebuild cache ...
q: Finished 36932 entries in 0.122343 seconds
n0zca ~ # emerge -uDvp world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild UD ] app-arch/xz-utils-5.0.4-r1 [5.0.5-r1] USE="nls static-libs threads" ABI_X86="(-32%) (-64%*) (-x32%)" 0 kB
[ebuild UD ] sys-libs/zlib-1.2.7 [1.2.8-r1] USE="minizip static-libs" ABI_X86="(-32%) (-64%*) (-x32%)" 0 kB
[ebuild r UD ] dev-libs/icu-51.1:0/51.1 [51.2-r1:0/51.2] USE="static-libs -debug -doc -examples" 0 kB
[ebuild NS ] sys-kernel/gentoo-sources-3.10.7-r1:3.10.7-r1 [3.10.17:3.10.17] USE="symlink -build -deblob" 0 kB
[ebuild UD ] dev-qt/qtcore-4.8.4-r5:4 [4.8.5:4] USE="exceptions glib iconv qt3support ssl (-aqua) -c++0x% -debug -icu -pch" 0 kB
[ebuild UD ] dev-qt/qtscript-4.8.4:4 [4.8.5:4] USE="exceptions iconv jit (-aqua) -c++0x% -debug -pch" 0 kB
[ebuild UD ] dev-qt/qttest-4.8.4:4 [4.8.5:4] USE="exceptions (-aqua) -c++0x% -debug -pch" 0 kB
[ebuild UD ] dev-qt/qtxmlpatterns-4.8.4:4 [4.8.5:4] USE="(-aqua) -c++0x% -debug -pch" 0 kB
[ebuild rR ] media-libs/raptor-2.0.9:2 USE="curl static-libs unicode -debug -json" 0 kB
[ebuild rR ] app-text/libmspub-0.0.6 USE="static-libs -doc" 0 kB
[ebuild rR ] media-libs/libcdr-0.0.14 USE="static-libs -doc" 0 kB
[ebuild UD ] media-libs/libvisio-0.0.28 [0.0.30] USE="static-libs -doc" 0 kB
[ebuild UD ] dev-qt/qtdbus-4.8.4:4 [4.8.5:4] USE="exceptions (-aqua) -c++0x% -debug -pch" 0 kB
[ebuild UD ] dev-qt/qtgui-4.8.4-r1:4 [4.8.5-r1:4] USE="accessibility cups dbus%* exceptions gif%* glib mng qt3support tiff xv (-aqua) -c++0x% -debug -egl -gtkstyle -nas -nis -pch -trace -xinerama" 0 kB
[ebuild UD ] dev-qt/qtsvg-4.8.4:4 [4.8.5:4] USE="accessibility exceptions (-aqua) -c++0x% -debug -pch" 0 kB
[ebuild UD ] dev-qt/qtwebkit-4.8.4:4 [4.8.5:4] USE="exceptions gstreamer jit (-aqua) -debug -icu -pch" 0 kB
[ebuild rR ] sys-apps/gptfdisk-0.8.6 USE="icu ncurses -static" 0 kB
[ebuild UD ] net-print/cups-1.6.2-r5 [1.6.4] USE="X acl dbus filters kerberos pam python ssl static-libs threads usb xinetd -debug -gnutls -java -lprng-compat (-selinux) -zeroconf" LINGUAS="ca es fr ja ru" PYTHON_SINGLE_TARGET="(-python2_6%) (-python2_7%*)" PYTHON_TARGETS="(-python2_6%) (-python2_7%*)" 0 kB
[ebuild r UD ] app-text/poppler-0.22.5:0/37 [0.24.3:0/43] USE="cairo cxx introspection jpeg lcms png qt4 tiff utils -cjk -curl -debug -doc -jpeg2k" 0 kB
[ebuild UD ] dev-qt/qtopengl-4.8.4:4 [4.8.5:4] USE="exceptions qt3support (-aqua) -c++0x% -debug -egl -pch" 0 kB
[ebuild UD ] net-print/cups-filters-1.0.34-r1 [1.0.36-r1] USE="jpeg perl png static-libs tiff -zeroconf" 0 kB
[ebuild rR ] media-libs/harfbuzz-0.9.12 USE="static-libs" 0 kB
[ebuild UD ] dev-qt/qtsql-4.8.4:4 [4.8.5:4] USE="exceptions mysql qt3support sqlite (-aqua) -c++0x% -debug -firebird -freetds -oci8 -odbc -pch -postgres" 0 kB
[ebuild UD ] dev-qt/qt3support-4.8.4:4 [4.8.5:4] USE="accessibility exceptions (-aqua) -c++0x% -debug -pch" 0 kB
[ebuild UD ] x11-drivers/nvidia-drivers-319.60 [325.15] USE="X acpi (multilib) tools -pax_kernel" 0 kB
[ebuild UD ] dev-qt/qtdeclarative-4.8.4:4 [4.8.5:4] USE="accessibility exceptions qt3support webkit (-aqua) -c++0x% -debug -pch" 0 kB
[ebuild UD ] dev-qt/qtmultimedia-4.8.4:4 [4.8.5:4] USE="alsa exceptions (-aqua) -c++0x% -debug -pch" 0 kB
[ebuild rR ] app-office/libreoffice-4.1.2.3 USE="bluetooth branding cups dbus eds gnome gstreamer gtk kde mysql opengl vba webdav (-aqua) -debug -gtk3 -java -jemalloc -odk -postgres -telepathy {-test}" LIBREOFFICE_EXTENSIONS="presenter-minimizer -nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7 (-python3_3)" PYTHON_TARGETS="python2_7 (-python3_3)" 0 kB

Total: 28 packages (21 downgrades, 1 in new slot, 6 reinstalls), Size of downloads: 0 kB

!!! The following installed packages are masked:
- media-video/avidemux-2.5.6-r2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Tom Wijsman <TomWij@gentoo.org> (12 Mar 2013)
# 2.5.* has known security and other issues due to an affected
# bundled ffmpeg, see bugs #446468 and #444262.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

n0zca ~ # uname -a
Linux n0zca.org 3.10.17-gentoo #1 SMP Sat Nov 2 22:27:42 CDT 2013 x86_64 Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz GenuineIntel GNU/Linux
n0zca ~ # date
Tue Nov 5 07:56:52 CST 2013
Back to top
View user's profile Send private message
funky1096
n00b
n00b


Joined: 10 Oct 2013
Posts: 47

PostPosted: Tue Nov 05, 2013 2:24 pm    Post subject: Reply with quote

You have a masked(hidden) package. That means emerge will not merge it again unless you unmask the specific version of that package(it will merge future versions just not the one masked) if you want to mask or unmask a package edit /etc/portage/package.mask and .unmask respectively.
Back to top
View user's profile Send private message
Ahnilated
n00b
n00b


Joined: 12 Sep 2010
Posts: 39

PostPosted: Tue Nov 05, 2013 2:26 pm    Post subject: Reply with quote

funky1096 wrote:
You have a masked(hidden) package. That means emerge will not merge it again unless you unmask the specific version of that package(it will merge future versions just not the one masked) if you want to mask or unmask a package edit /etc/portage/package.mask and .unmask respectively.


This isn't the issue I was talking about. I don't care about the masked package. I care about emerge trying to install a kernel and other files that are old and not part of the current setup.
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9013
Location: beyond the rim

PostPosted: Tue Nov 05, 2013 2:45 pm    Post subject: Reply with quote

You synced against an outdated server. The hint about removing the timestamp file was only for forcing the sync, IOW if you know what you're doing. not every instruction portage gives you should be executed without thinking.
Of course with an outdated tree you're presented with outdated software. To fix that you need to sync against a server with the current tree. Best option is to change your make.conf to use the standard rsync.gentoo.org rotation (no idea how you ended up with rsync6.us.gentoo.org).


Last edited by Genone on Tue Nov 05, 2013 2:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ahnilated
n00b
n00b


Joined: 12 Sep 2010
Posts: 39

PostPosted: Tue Nov 05, 2013 2:48 pm    Post subject: Reply with quote

Genone wrote:
You synced against an outdated server. The hint about removing the timestamp file was only for forcing the sync, IOW if you know what you're doing. not every instruction portage gives you should be executed without thinking.
Of course with an outdated tree you're presented with outdated software. To fix that you need to sync against a server with the current tree.


Well this is the same server I have been sync'n against for years. The last time I sync'd against it was 2 days ago and I got the 3.10.17 kernel.
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9013
Location: beyond the rim

PostPosted: Tue Nov 05, 2013 2:51 pm    Post subject: Reply with quote

Ahnilated wrote:
Well this is the same server I have been sync'n against for years. The last time I sync'd against it was 2 days ago and I got the 3.10.17 kernel.

Well, just because your car has worked for years doesn't mean it can't malfunction today. There are lots of possible reasons how a server can end up with an outdated tree, but the error message "server out of date" means just that, not "just for fun please remove that file".
Back to top
View user's profile Send private message
Ahnilated
n00b
n00b


Joined: 12 Sep 2010
Posts: 39

PostPosted: Tue Nov 05, 2013 2:52 pm    Post subject: Reply with quote

Genone wrote:
Ahnilated wrote:
Well this is the same server I have been sync'n against for years. The last time I sync'd against it was 2 days ago and I got the 3.10.17 kernel.

Well, just because your car has worked for years doesn't mean it can't malfunction today. There are lots of possible reasons how a server can end up with an outdated tree, but the error message "server out of date" means just that, not "just for fun please remove that file".


Well http://mirrorstats.gentoo.org/rsync/ shows that it sync'd 1 hr ago and was renewed. So unless that site is wrong there is something else going on too.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1421

PostPosted: Tue Nov 05, 2013 3:53 pm    Post subject: Reply with quote

This is happening because both versions of 3.10.7 are marked stable. If you synced now you'd be asked to upgrade to 3.10.17. See the Package Website.
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper


Last edited by eyoung100 on Tue Nov 05, 2013 3:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ahnilated
n00b
n00b


Joined: 12 Sep 2010
Posts: 39

PostPosted: Tue Nov 05, 2013 3:55 pm    Post subject: Reply with quote

Ok, never mind, I guess this was the wrong place to ask...
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1421

PostPosted: Tue Nov 05, 2013 3:57 pm    Post subject: Reply with quote

Ahnilated wrote:
Ok, never mind, I guess this was the wrong place to ask...


If you sync now is 3.10.17 back in your rsync server's tree :?:
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum