Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] problems updating emul-linux-x86-baselibs and wine
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Utsuho Reiuji
Tux's lil' helper
Tux's lil' helper

Joined: 03 Apr 2013
Posts: 136

PostPosted: Sat Nov 02, 2013 1:37 pm    Post subject: [solved] problems updating emul-linux-x86-baselibs and wine Reply with quote

I wanted to do an update today (new wine and "app-emulation/emul-linux-x86-baselibs-20131008-r3"), but got this error message:
Total: 16 packages (15 upgrades, 1 new), Size of downloads: 143,387 kB
Conflict: 1 block

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:


  (app-emulation/emul-linux-x86-baselibs-20130224::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-baselibs-20130224 required by (app-emulation/emul-linux-x86-db-20130224::gentoo, installed)
    (and 5 more with the same problem)

  (app-emulation/emul-linux-x86-baselibs-20131008-r3::gentoo, ebuild scheduled for merge) pulled in by
    >=app-emulation/emul-linux-x86-baselibs-20131008[development] required by (app-emulation/wine-1.7.4::gentoo, ebuild scheduled for merge)


  (app-text/poppler-0.22.5::gentoo, installed) pulled in by
    >=app-text/poppler-0.16:0/37=[xpdf-headers(+),cxx] required by (app-office/libreoffice-, installed)

  (app-text/poppler-0.24.3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

I'm afraid to break something if I mask one of those or to use --backtrack...
Any idea what I should do here?

Last edited by Utsuho Reiuji on Mon Nov 04, 2013 10:25 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 23 Jan 2004
Posts: 1428

PostPosted: Sat Nov 02, 2013 5:47 pm    Post subject: Reply with quote

Add this to package.accept_keywords
app-emulation/emul-linux-x86-baselibs      ~amd64
app-emulation/emul-linux-x86-soundlibs      ~amd64
app-emulation/emul-linux-x86-xlibs      ~amd64
app-emulation/emul-linux-x86-medialibs      ~amd64
app-emulation/emul-linux-x86-db       ~amd64
app-emulation/emul-linux-x86-sdl      ~amd64
app-emulation/emul-linux-x86-gtklibs      ~amd64
app-emulation/emul-linux-x86-opengl      ~amd64
app-emulation/emul-linux-x86-qtlibs      ~amd64
sys-libs/ncurses            ~amd64
sys-libs/gpm               ~amd64
sys-libs/libraw1394            ~amd64
media-libs/libpng:1.2            ~amd64
sys-libs/zlib               ~amd64
virtual/libffi               ~amd64
dev-libs/libffi               ~amd64
app-arch/xz-utils            ~amd64
media-libs/jbigkit            ~amd64
dev-libs/udis86               ~amd64
virtual/udev               ~amd64
sys-fs/udev               ~amd64
sys-apps/kmod               ~amd64
sys-apps/hwids               ~amd64
dev-libs/glib               ~amd64
virtual/libiconv            ~amd64
sys-apps/attr               ~amd64
virtual/jpeg               ~amd64
media-libs/jpeg               ~amd64
virtual/libusb               ~amd64
dev-libs/libusb-compat            ~amd64
app-arch/bzip2               ~amd64
sys-devel/llvm               ~amd64
app-text/libpaper            ~amd64
dev-libs/libusbx            ~amd64
media-libs/lcms               ~amd64
media-libs/libjpeg-turbo         ~amd64
media-libs/libpng            ~amd64
sys-libs/libavc1394            ~amd64
media-libs/tiff               ~amd64
dev-libs/expat               ~amd64
dev-libs/elfutils            ~amd64
sys-libs/e2fsprogs-libs            ~amd64
dev-libs/gobject-introspection         ~amd64
dev-libs/gobject-introspection-common      ~amd64
sys-fs/e2fsprogs            ~amd64
sys-apps/openrc               ~amd64
net-misc/netifrc            ~amd64
dev-libs/vala-common            ~amd64
x11-libs/libXdamage            ~amd64
x11-libs/libXcomposite            ~amd64
x11-libs/libXft               ~amd64
x11-libs/libvdpau            ~amd64
media-libs/freetype            ~amd64
media-libs/libsamplerate         ~amd64
media-libs/xvid               ~amd64
media-plugins/caps-plugins         ~amd64
media-libs/speex            ~amd64
media-libs/libmad            ~amd64
media-libs/libdvdnav            ~amd64
media-libs/a52dec            ~amd64
media-libs/x264               ~amd64
dev-libs/liboil               ~amd64
media-libs/faad2            ~amd64
media-libs/libmpeg2            ~amd64
media-sound/gsm             ~amd64
media-sound/musepack-tools          ~amd64
sys-libs/libieee1284             ~amd64
media-libs/faac               ~amd64
media-libs/libsidplay             ~amd64
media-libs/libdca             ~amd64
media-libs/libdc1394            ~amd64
media-libs/libtheora             ~amd64
media-libs/webrtc-audio-processing       ~amd64
media-libs/ladspa-sdk             ~amd64
media-libs/libmms             ~amd64
media-libs/libsidplay             ~amd64
media-video/ffmpeg:0.10            ~amd64
media-video/ffmpeg:0            ~amd64
media-sound/lame             ~amd64
dev-libs/libcdio             ~amd64
media-libs/libvorbis             ~amd64
media-plugins/swh-plugins          ~amd64
media-sound/cdparanoia             ~amd64
media-libs/openjpeg             ~amd64
dev-libs/fribidi             ~amd64
media-libs/libv4l             ~amd64
media-libs/libmodplug             ~amd64
media-libs/libvisual             ~amd64
media-libs/vo-aacenc             ~amd64
media-libs/libid3tag             ~amd64
media-libs/audiofile             ~amd64
media-libs/alsa-lib             ~amd64
media-libs/libsndfile             ~amd64
media-libs/libshout             ~amd64
media-libs/libdv             ~amd64
media-libs/libogg             ~amd64
media-plugins/alsaequal          ~amd64
media-libs/libmimic             ~amd64
media-libs/libdvdcss             ~amd64
media-libs/libmikmod             ~amd64
media-libs/libvpx             ~amd64
media-libs/libiec61883             ~amd64
media-sound/jack-audio-connection-kit       ~amd64
media-sound/twolame             ~amd64
media-libs/libdvdread             ~amd64
media-sound/wavpack             ~amd64
media-libs/libreplaygain          ~amd64
media-libs/libcuefile            ~amd64
app-admin/eselect-cdparanoia          ~amd64
dev-libs/libcdio-paranoia          ~amd64
media-libs/flac               ~amd64
media-sound/mpg123             ~amd64
media-libs/portaudio             ~amd64
x11-proto/dri2proto             ~amd64
virtual/glu                ~amd64
media-libs/mesa             ~amd64
x11-proto/glproto             ~amd64
virtual/opengl                ~amd64
x11-proto/xf86driproto             ~amd64
media-libs/glew             ~amd64
x11-libs/libdrm             ~amd64
media-libs/freeglut             ~amd64
media-libs/glu               ~amd64

Add this to /etc/portage/profile/use.mask

The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper

Last edited by eyoung100 on Mon Nov 11, 2013 7:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
Utsuho Reiuji
Tux's lil' helper
Tux's lil' helper

Joined: 03 Apr 2013
Posts: 136

PostPosted: Sun Nov 03, 2013 10:21 pm    Post subject: Reply with quote

Thank you, eyoung100.
I tested this already and can confirm that the circular dependency problem is solved, but before I update, I would like to know what "-abi_x86_32" does.

This is what emerge would like to update:
[ebuild     U ~] app-emulation/emul-linux-x86-baselibs-20131008-r3 [20130224] USE="development" ABI_X86="-32%" 54,680 kB
[ebuild     U ~] app-emulation/emul-linux-x86-db-20131008 [20130224] USE="development" 1,469 kB
[ebuild     U  ] app-arch/xz-utils-5.0.5-r1 [5.0.4-r1] USE="nls threads -static-libs" ABI_X86="(64%*) -32% (-x32)" 1,276 kB
[ebuild     U ~] app-arch/bzip2-1.0.6-r4 [1.0.6-r3] USE="-static -static-libs" ABI_X86="(64%*) -32% (-x32)" 764 kB
[ebuild     U ~] dev-libs/expat-2.1.0-r3 [2.1.0-r2] USE="unicode -examples -static-libs" ABI_X86="(64%*) -32% (-x32)" 550 kB
[ebuild     U ~] virtual/libiconv-0-r1 [0] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] media-libs/libogg-1.3.1 [1.3.0] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 398 kB
[ebuild     U ~] media-libs/x264-0.0.20130912:0/138 [0.0.20111220:0/0] USE="interlaced sse%* threads -10bit -pic -static-libs (-custom-cflags%) (-debug%)" ABI_X86="(64%*) -32% (-x32)" 615 kB
[ebuild     U ~] media-libs/xvid-1.3.2-r1 [1.3.2] USE="threads -examples -pic" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] media-libs/libdvdcss-1.2.13-r1:1.2 [1.2.13:1.2] USE="-doc -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] dev-libs/libffi-3.0.13-r1 [3.0.11] USE="-debug -pax_kernel% -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)" 826 kB
[ebuild     U ~] media-libs/vo-aacenc-0.1.3 [0.1.2] USE="-examples (-neon) -static-libs" ABI_X86="(64%*) -32% (-x32)" 599 kB
[ebuild     U ~] media-libs/libvpx-1.2.0_pre20130625 [1.1.0] USE="mmx sse sse2 threads (-altivec) -doc -postproc -sse3 -sse4_1 -ssse3 -static-libs {-test%} (-debug%)" ABI_X86="(64%*) -32% (-x32)" 1,686 kB
[ebuild     U ~] virtual/libffi-3.0.13-r1 [3.0.11] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U  ] dev-libs/gmp-5.1.2 [5.0.2_p1] USE="cxx -doc -pgo% -static-libs" 1,777 kB
[ebuild     U ~] dev-libs/vala-common-0.22.0 [0.18.1] 2,590 kB
[ebuild     U  ] dev-libs/mpfr-3.1.2-r1 [3.1.1] USE="-static-libs" 1,050 kB
[ebuild  N     ] dev-lang/python-exec-0.3.1  PYTHON_TARGETS="(jython2_5) (jython2_7) (python2_6) (python2_7) (python3_2) (-pypy2_0) (-python3_3)" 0 kB
[ebuild     U  ] dev-python/python-exec-10000.1 [0.3.1] PYTHON_TARGETS="(jython2_5) (jython2_7) (python2_6) (python2_7) (python3_2) (-pypy2_0) (-python3_3) (-pypy1_9%) (-python2_5%*) (-python3_1%*)" 0 kB
[blocks b      ] <dev-python/python-exec-10000 ("<dev-python/python-exec-10000" is blocking dev-lang/python-exec-0.3.1)
[ebuild     U ~] dev-libs/gobject-introspection-common-1.36.0 [1.32.1] 1,173 kB
[ebuild     U  ] sys-libs/zlib-1.2.8-r1 [1.2.7] USE="minizip -static-libs" ABI_X86="(64%*) -32% (-x32)" 558 kB
[ebuild  r  U  ] dev-libs/icu-51.2-r1:0/51.2 [51.1:0/51.1] USE="-debug -doc -examples -static-libs" 21,331 kB
[ebuild     U ~] media-libs/alsa-lib- [] USE="-alisp -debug -doc -python" ABI_X86="(64%*) -32% (-x32)" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 886 kB
[ebuild     U ~] media-libs/libdvdread-4.2.0-r1 [4.2.0] USE="css" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] media-libs/libjpeg-turbo-1.3.0-r2 [1.3.0] USE="-java -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] app-text/libpaper-1.1.24-r2 [1.1.24-r1] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] media-libs/libmad-0.15.1b-r8 [0.15.1b-r7] USE="-debug -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] media-libs/a52dec-0.7.4-r7 [0.7.4-r6] USE="-djbfft -oss -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] media-libs/libdca-0.0.5-r3 [0.0.5-r2] USE="-debug -oss -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] media-libs/faad2-2.7-r3 [2.7-r2] USE="-digitalradio -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild  r  U ~] media-libs/libpng-1.6.6:0/16 [1.5.15:0/0] USE="apng (-neon) -static-libs" ABI_X86="(64%*) -32% (-x32)" 860 kB
[ebuild     U ~] virtual/jpeg-0-r2 [0] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild  rR    ] dev-libs/boost-1.52.0-r6:0/1.52  USE="icu nls threads -debug -doc -mpi -python -static-libs -tools" PYTHON_TARGETS="python2_7 python3_2 -python2_6 (-python3_3)" 0 kB
[ebuild  NS   ~] virtual/jpeg-62:62 [0:0] ABI_X86="(64) -32 (-x32)" 0 kB
[ebuild     U ~] media-libs/libid3tag-0.15.1b-r4 [0.15.1b-r2] USE="-debug -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] media-libs/freetype- [2.4.11:2] USE="X adobe-cff%* bindist bzip2 png%* -auto-hinter -debug -doc -fontforge -infinality -static-libs -utils" ABI_X86="(64%*) -32% (-x32)" 1,570 kB
[ebuild     U ~] media-libs/tiff-4.0.3-r5 [4.0.3-r4] USE="cxx jpeg zlib -jbig -lzma -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild  rR    ] media-libs/jbig2dec-0.11-r1  USE="png -static-libs {-test}" 0 kB
[ebuild     U ~] media-libs/lcms-2.5-r1:2 [2.3:2] USE="jpeg tiff zlib -doc -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)" 6,837 kB
[ebuild     U ~] media-libs/lcms-1.19-r1 [1.19] USE="jpeg tiff zlib -python -static-libs" PYTHON_TARGETS="python2_7%* python3_2%* -python2_6% -python3_3%" 0 kB
[ebuild     U ~] dev-libs/elfutils-0.156 [0.149] USE="bzip2 nls static-libs%* threads%* utils%* zlib -lzma {-test%}" ABI_X86="(64%*) -32% (-x32)" 2,694 kB
[ebuild     U ~] sys-apps/attr-2.4.47-r1 [2.4.46-r2] USE="nls -static-libs" ABI_X86="(64%*) -32% (-x32)" 336 kB
[ebuild  rR    ] dev-db/sqlite-3.7.17:3  USE="extensions icu readline -debug -doc -secure-delete -static-libs -tcl {-test}" 0 kB
[ebuild  rR    ] dev-lang/v8-  USE="icu readline (-neon)" 0 kB
[ebuild  rR    ] dev-libs/libxml2-2.9.1-r1:2  USE="icu ipv6 python readline -debug -examples -lzma -static-libs {-test}" PYTHON_TARGETS="python2_7 python3_2 -python2_6 (-python3_3) (-python2_5%) (-python3_1%)" 0 kB
[ebuild  N    ~] app-admin/eselect-cdparanoia-0.1  0 kB
[ebuild     U ~] media-sound/cdparanoia-3.10.2-r6 [3.10.2-r4] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[blocks b      ] <media-sound/cdparanoia-3.10.2-r5 ("<media-sound/cdparanoia-3.10.2-r5" is blocking app-admin/eselect-cdparanoia-0.1)
[ebuild     U ~] dev-libs/glib-2.36.4-r1:2 [2.32.4-r1:2] USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7%* -python2_6%" 8,303 kB
[ebuild  rR    ] dev-qt/qtcore-4.8.4-r5:4  USE="exceptions glib iconv icu qt3support ssl (-aqua) -c++0x -debug -pch" 0 kB
[ebuild     U ~] media-libs/libvorbis-1.3.3-r1 [1.3.3] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] media-libs/flac-1.2.1-r5 [1.2.1-r3] USE="3dnow cxx ogg sse (-altivec) -debug -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild  rR    ] media-libs/raptor-2.0.9:2  USE="curl unicode -debug -json -static-libs" 0 kB
[ebuild     U ~] x11-libs/libdrm-2.4.47 [2.4.46] USE="-libkms -static-libs" ABI_X86="(64%*) -32% (-x32)" VIDEO_CARDS="(-exynos) (-freedreno) -intel -nouveau (-omap) -radeon -vmware" 541 kB
[ebuild     U ~] media-libs/libdvdnav-4.2.0-r1 [4.2.0] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild  rR    ] media-plugins/gst-plugins-x264-0.10.19:0.10  0 kB
[ebuild     U ~] media-libs/libsamplerate-0.1.8-r1 [0.1.7] USE="-sndfile -static-libs%" ABI_X86="(64%*) -32% (-x32)" 4,203 kB
[ebuild     U ~] sys-libs/e2fsprogs-libs-1.42.8 [1.42.7] USE="nls -static-libs" ABI_X86="(64%*) -32% (-x32)" 561 kB
[ebuild     U ~] x11-proto/dri2proto-2.8-r1 [2.8] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] x11-proto/xf86driproto-2.1.1-r1 [2.1.1] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] x11-proto/glproto-1.4.16-r1 [1.4.16] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] dev-libs/fribidi-0.19.5-r2 [0.19.5-r1] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild  rR    ] app-text/libmspub-0.0.6  USE="-doc -static-libs" 0 kB
[ebuild  rR    ] media-libs/libcdr-0.0.14  USE="-doc -static-libs" 0 kB
[ebuild     U ~] sys-devel/llvm-3.3-r1:0/3.3 [3.1-r2:0/0] USE="libffi static-analyzer%* -clang% -debug -doc% -gold -multitarget -ocaml -python% {-test} -udis86 (-vim-syntax%)" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7%* -pypy2_0% -python2_6%" VIDEO_CARDS="-radeon%" 13,311 kB
[ebuild     U ~] media-libs/speex-1.2_rc1-r2 [1.2_rc1] USE="ogg sse -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U  ] media-libs/libvisio-0.0.30 [0.0.28] USE="-doc -static-libs" 376 kB
[ebuild     U  ] net-firewall/iptables-1.4.20 [] USE="ipv6 -netlink -static-libs" 535 kB
[ebuild     U ~] media-libs/mesa-9.2.1 [9.1.6] USE="bindist classic egl gallium llvm nptl -debug -gbm -gles1 -gles2 -opencl% -openvg -osmesa -pax_kernel -pic -r600-llvm-compiler (-selinux) -vdpau -wayland -xa -xorg -xvmc (-shared-glapi%*)" ABI_X86="(64%*) -32% (-x32)" PYTHON_SINGLE_TARGET="(-python2_6%) (-python2_7%*)" PYTHON_TARGETS="(-python2_6%) (-python2_7%*)" VIDEO_CARDS="(-freedreno) -i915 -i965 -ilo% -intel -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi -vmware" 6,490 kB
[ebuild     U ~] media-libs/audiofile-0.3.6-r1:0/1 [0.3.5:0/1] USE="flac%* -static-libs {-test}" ABI_X86="(64%*) -32% (-x32)" 519 kB
[ebuild     U ~] media-libs/libsndfile-1.0.25-r1 [1.0.25] USE="alsa -minimal -sqlite -static-libs {-test%}" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] x11-libs/libvdpau-0.7 [0.5] USE="dri -doc" ABI_X86="(64%*) -32% (-x32)" 476 kB
[ebuild     U ~] media-libs/libtheora-1.1.1-r1 [1.1.1] USE="encode -doc -examples -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild  rR    ] x11-libs/cairo-1.12.14-r4  USE="X glib opengl svg xcb (-aqua) -debug -directfb -doc (-drm) (-gallium) (-gles2) -legacy-drivers -openvg (-qt4) -static-libs -valgrind -xlib-xcb" 0 kB
[ebuild     U ~] virtual/opengl-7.0-r1 [7.0] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] dev-libs/gobject-introspection-1.36.0-r1 [1.32.1] USE="cairo%* -doctool {-test} (-doc%)" PYTHON_SINGLE_TARGET="python2_7%*" PYTHON_TARGETS="python2_7%*" 0 kB
[blocks b      ] <dev-libs/gobject-introspection-1.36 ("<dev-libs/gobject-introspection-1.36" is blocking dev-libs/glib-2.36.4-r1)
[blocks b      ] <dev-libs/gobject-introspection-1.36.0 ("<dev-libs/gobject-introspection-1.36.0" is blocking dev-libs/gobject-introspection-common-1.36.0)
[ebuild     U ~] media-libs/glu-9.0.0-r1 [9.0.0] USE="-static-libs (-multilib%)" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild  rR    ] media-libs/harfbuzz-0.9.12  USE="-static-libs" 0 kB
[ebuild     U ~] virtual/glu-9.0-r1 [9.0] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] media-libs/freeglut-2.8.1-r1 [2.8.1] USE="-debug -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] media-libs/libmpeg2-0.5.1-r2 [0.5.1] USE="X sdl -static-libs%" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild  rR    ] media-libs/libwebp-0.3.1  USE="gif jpeg opengl png tiff -experimental -static-libs -swap-16bit-csp" ABI_X86="(64) -32 (-x32)" 0 kB
[ebuild     U ~] media-sound/mpg123-1.16.0 [1.15.4] USE="alsa ipv6 sdl sse (-3dnow) (-3dnowext) (-altivec) (-coreaudio) -int-quality -jack (-mmx) -nas -oss -portaudio -pulseaudio" ABI_X86="(64%*) -32% (-x32)" 824 kB
[ebuild     U ~] app-emulation/emul-linux-x86-opengl-20131008 [20130224] USE="development" ABI_X86="-32%" 68,720 kB
[ebuild     U ~] app-emulation/emul-linux-x86-xlibs-20131008 [20130224] USE="(development) opengl" ABI_X86="-32%" 2,627 kB
[ebuild     U ~] app-emulation/emul-linux-x86-gtklibs-20131008-r1 [20130224] USE="development" ABI_X86="-32%" 6,997 kB
[ebuild     U ~] app-emulation/emul-linux-x86-medialibs-20131008-r1 [20130224] USE="development" ABI_X86="-32%" 10,746 kB
[ebuild     U ~] app-emulation/emul-linux-x86-soundlibs-20131008-r1 [20130224] USE="alsa development" ABI_X86="-32%" 6,544 kB
[ebuild     U ~] app-emulation/emul-linux-x86-sdl-20131008 [20130224] USE="development" 685 kB
[ebuild     U ~] sys-apps/kmod-15 [13-r1] USE="openrc%* tools zlib -debug -doc -lzma -static-libs" 1,420 kB
[ebuild  rR    ] dev-java/icedtea-bin-  USE="X alsa cjk cups -doc -examples -nsplugin -source" 0 kB
[ebuild     U ~] sys-libs/ncurses-5.9-r3:5 [5.9-r2:5] USE="cxx gpm unicode -ada -debug -doc -minimal -profile -static-libs -tinfo -trace" ABI_X86="(64%*) -32% (-x32)" 2,761 kB
[ebuild     U ~] sys-libs/gpm-1.20.7-r2 [1.20.7-r1] USE="(-selinux) -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U  ] dev-util/cmake- [] USE="ncurses qt4 -emacs (-qt5) {-test} -vim-syntax" 5,750 kB
[ebuild     U ~] media-sound/lame-3.99.5-r1 [3.99.5] USE="-debug (-mmx) -mp3rtp -sndfile -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild  r  U  ] app-text/poppler-0.24.3:0/43 [0.22.5:0/37] USE="cairo cjk cxx introspection jpeg lcms png qt4 tiff utils -curl -debug -doc -jpeg2k" 1,471 kB
[ebuild     U  ] app-misc/strigi-0.7.8 [0.7.7-r2] USE="dbus exif fam qt4 -clucene -debug -ffmpeg -inotify (-log) {-test} (-hyperestraier%)" 792 kB
[ebuild     U ~] media-video/ffmpeg-1.2.4 [1.0.7] USE="3dnow X aac alsa bindist bzip2 encode hardcoded-tables iconv%* mmx mp3 network* sdl truetype vorbis x264 xvid zlib -3dnowext -aacplus (-altivec) -amr -avx -bluray -cdio (-celt) -cpudetection -debug -doc -examples -faac -fdk -flite -fontconfig -frei0r -gnutls -gsm -iec61883 -ieee1394 -jack -jpeg2k -libass -libcaca -libsoxr% -libv4l -mmxext -modplug (-neon) -openal -openssl -opus* -oss -pic -pulseaudio -rtmp -schroedinger -speex -ssse3 -static-libs {-test} -theora -threads -twolame -v4l -vaapi -vdpau (-vis) -vpx" FFTOOLS="aviocat cws2fws ffescape%* ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher" 5,828 kB
[ebuild  rR    ] app-i18n/ibus-qt-1.3.1  USE="-doc" 0 kB
[ebuild     U ~] sys-apps/openrc-0.12.4 [0.11.8] USE="ncurses netifrc%* pam unicode -debug -newnet (-prefix) (-selinux) -static-libs -tools%" 129 kB
[blocks b      ] <sys-apps/openrc-0.12 ("<sys-apps/openrc-0.12" is blocking sys-apps/kmod-15, net-misc/netifrc-0.1)
[blocks b      ] net-misc/netifrc ("net-misc/netifrc" is blocking sys-apps/openrc-0.11.8)
[ebuild  N    ~] net-misc/netifrc-0.1  52 kB
[ebuild     U  ] net-print/cups-filters-1.0.36-r1 [1.0.34-r1] USE="jpeg png tiff -perl -static-libs -zeroconf" 1,009 kB
[ebuild  rR    ] sys-apps/gptfdisk-0.8.6  USE="icu ncurses -static" 0 kB
[ebuild     U ~] sys-fs/udev-208 [204] USE="acl firmware-loader gudev introspection kmod openrc -doc (-selinux) -static-libs (-hwdb%*) (-keymap%*)" ABI_X86="(64%*) -32% (-x32)" 2,328 kB
[ebuild     U ~] virtual/udev-206-r3 [200] USE="gudev introspection kmod (-selinux) -static-libs (-hwdb%*) (-keymap%*)" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U ~] sys-apps/hwids-20130915.1 [20130329] USE="udev" 1,535 kB
[ebuild     U  ] app-misc/media-player-info-21-r1 [17] 101 kB
[ebuild     U ~] sys-fs/e2fsprogs-1.42.8 [1.42.7] USE="nls -static-libs" 5,850 kB
[ebuild  N    ~] dev-libs/libusbx-1.0.17:1  USE="udev -debug -doc -examples -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 496 kB
[uninstall     ] dev-libs/libusb-1.0.9:1  USE="-debug -doc -static-libs"
[blocks b      ] dev-libs/libusbx:1 ("dev-libs/libusbx:1" is blocking dev-libs/libusb-1.0.9)
[blocks b      ] dev-libs/libusb:1 ("dev-libs/libusb:1" is blocking dev-libs/libusbx-1.0.17)
[ebuild     U ~] virtual/libusb-1-r1:1 [1:1] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild     U  ] net-print/cups-1.6.4 [1.6.2-r5] USE="X acl dbus filters pam ssl threads usb -debug -gnutls -java -kerberos -lprng-compat -python (-selinux) -static-libs -xinetd -zeroconf" LINGUAS="ja -ca -es -fr -ru" PYTHON_SINGLE_TARGET="python2_7%* -python2_6%" PYTHON_TARGETS="python2_7%* -python2_6%" 8,069 kB
[ebuild     U ~] dev-libs/libusb-compat-0.1.5-r2 [0.1.5] USE="-debug -examples% -static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild  rR    ] kde-base/kdelibs-4.10.5-r1:4  USE="3dnow acl alsa bzip2 fam handbook mmx nls opengl (policykit) semantic-desktop spell sse sse2 ssl udev udisks upower (-altivec) (-aqua) -debug -doc -jpeg2k -kerberos -lzma -openexr {-test} -zeroconf" 0 kB
[ebuild     U ~] virtual/libusb-0-r1 [0] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild  rR    ] www-client/chromium-30.0.1599.101  USE="bindist cups -custom-cflags -gnome -gnome-keyring -gps -kerberos (-neon) -pulseaudio (-selinux) (-system-sqlite) (-tcmalloc) {-test}" LINGUAS="en_GB ja ko -am -ar -bg -bn -ca -cs -da -de -el -es -es_LA -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -kn -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW" 0 kB
[ebuild  rR    ] media-video/vlc-2.0.7  USE="X a52 aac alsa avcodec avformat bidi cdda dbus dts dvbpsi dvd encode ffmpeg flac gcrypt gnutls httpd kde libass libnotify live lua matroska mmx mp3 mpeg mtp ncurses ogg opengl png postproc qt4 sdl sse svg swscale theora truetype udev vlm vorbis x264 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -avahi -bluray -cddb -dc1394 -debug -dirac (-direct2d) -directfb (-directx) (-dshow) -dvb (-dxva2) -egl -fbosd -fluidsynth -fontconfig* -gme -gnome -growl -ieee1394 (-ios-vout) -jack -kate -libcaca -libproxy -libsamplerate -libtar -libtiger -linsys -lirc (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) (-media-library) -modplug -musepack (-neon) -omxil -optimisememory -opus -oss -portaudio -projectm -pulseaudio -pvr -rtsp -run-as-root -samba -schroedinger -sdl-image -shine -shout -sid -skins -speex -sqlite -switcher -taglib -twolame -upnp -v4l -vaapi -vcdx (-waveout) (-wingdi) -wma-fixed -xosd -zvbi" 0 kB
[ebuild  rR    ] kde-base/gwenview-4.10.5:4  USE="handbook kipi semantic-desktop (-aqua) -debug" 0 kB
[ebuild  rR    ] kde-base/ksplash-4.10.5:4  USE="3dnow mmx sse sse2 xinerama (-altivec) (-aqua) -debug" 0 kB
[ebuild  rR    ] app-office/libreoffice-  USE="bluetooth branding cups dbus kde opengl vba webdav (-aqua) -debug -eds -gnome -gstreamer -gtk -gtk3 -java -jemalloc -mysql -odk -postgres -telepathy {-test}" LIBREOFFICE_EXTENSIONS="presenter-minimizer -nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7 (-python3_3)" PYTHON_TARGETS="python2_7 (-python3_3)" 0 kB
[ebuild     UD ] app-emulation/wine-1.6 [1.7.0] USE="X alsa cups fontconfig gecko gphoto2 jpeg lcms ldap mono mp3 ncurses nls opengl perl png prelink run-exes ssl threads truetype udisks xcomposite xinerama xml -capi -custom-cflags -dos -gsm -gstreamer -odbc -openal -opencl -osmesa -oss -pulseaudio -samba -scanner (-selinux) {-test} -v4l" ABI_X86="32 64 (-x32)" LINGUAS="ja ko -ar -bg -ca -cs -da -de -el -en -en_US -eo -es -fa -fi -fr -he -hi -hr -hu -it -lt -ml -nb_NO -nl -or -pa -pl -pt_BR -pt_PT -rm -ro -ru -sk -sl -sr_RS@cyrillic -sr_RS@latin -sv -te -th -tr -uk -wa -zh_CN -zh_TW" 0 kB

Total: 119 packages (91 upgrades, 1 downgrade, 4 new, 1 in new slot, 22 reinstalls, 1 uninstall), Size of downloads: 274,546 kB
Conflict: 8 blocks

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by sys-devel/prelink-20110511
# required by app-emulation/wine-1.6[prelink]
# required by @selected
# required by @world (argument)
>=dev-libs/elfutils-0.156 static-libs

Since I do not have a dvd drive atm, I cannot afford to break my system, so I need to be sure
Back to top
View user's profile Send private message

Joined: 23 Jan 2004
Posts: 1428

PostPosted: Mon Nov 04, 2013 3:18 pm    Post subject: Reply with quote

ABI_X86="32 64" is the new way of enabling 32 and 64 bit binaries on a multilib system. It's still in testing(and therefore hardmasked), but since the new emul libraries are testing also that's the issue. Add that last USE and you should be good to go
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
Utsuho Reiuji
Tux's lil' helper
Tux's lil' helper

Joined: 03 Apr 2013
Posts: 136

PostPosted: Mon Nov 04, 2013 10:25 pm    Post subject: Reply with quote

I see, I see.
Thanks eyoung100, this weekend, I'll run this update then ^^
Back to top
View user's profile Send private message

Joined: 23 Oct 2002
Posts: 1592
Location: Just over the horizon

PostPosted: Tue Nov 26, 2013 11:08 pm    Post subject: Reply with quote

eyoung100 wrote:
ABI_X86="32 64" is the new way of enabling 32 and 64 bit binaries on a multilib system. It's still in testing(and therefore hardmasked), but since the new emul libraries are testing also that's the issue. Add that last USE and you should be good to go

Thank you eyoung100! I just ran into another set of circular deps and this fixed it. Hard to keep track of these masked keywords.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum