Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Beaglebone Black with 3.12
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message

Joined: 22 Mar 2013
Posts: 6

PostPosted: Thu Oct 31, 2013 2:22 am    Post subject: Beaglebone Black with 3.12 Reply with quote

Hi all,

I tried installing Gentoo on the Beaglebone black with the instructions in

However, I couldn't get any output on my screen through the HDMI. I tried installing Arch, and it worked fine there. After a lot of fiddling around, I noticed Arch uses a 3.12 kernel, as opposed to the 3.8 used in the guide.

In summary, all I did differently was just the kernel compilation/installation:
git clone
cd kernel
git checkout origin/3.12 -b 3.12
cd kernel
wget ";a=blob_plain;f=bin/am335x-pm-firmware.bin;hb=HEAD" -O firmware/am335x-pm-firmware.bin

LOADADDR=0x80008000 make -j4 ARCH=arm CROSS_COMPILE=armv7a-hardfloat-linux-gnueabi- uImage dtbs

# this assumes that /mnt/p2 is mounted (don't know if it's strictly necessary, but I would guess that yes)
make -j4 ARCH=arm CROSS_COMPILE=armv7a-hardfloat-linux-gnueabi- modules
make -j4 ARCH=arm CROSS_COMPILE=armv7a-hardfloat-linux-gnueabi- INSTALL_MOD_PATH=/mnt/p2 modules_install

Clarification on LOADADDR:
Unless I added that, uImage would not build:
 make -j4 ARCH=arm CROSS_COMPILE=armv7a-hardfloat-linux-gnueabi- uImage dtbs
  CHK     include/config/kernel.release
  CHK     include/generated/uapi/linux/version.h
  CHK     include/generated/utsrelease.h
make[1]: `include/generated/mach-types.h' is up to date.
  CALL    scripts/
  CHK     include/generated/compile.h
  CHK     kernel/config_data.h
  Kernel: arch/arm/boot/Image is ready
  LZO     arch/arm/boot/compressed/piggy.lzo
  AS      arch/arm/boot/compressed/piggy.lzo.o
  LD      arch/arm/boot/compressed/vmlinux
  OBJCOPY arch/arm/boot/zImage
  Kernel: arch/arm/boot/zImage is ready
multiple (or no) load addresses:
This is incompatible with uImages
Specify LOADADDR on the commandline to build an uImage
make[1]: *** [arch/arm/boot/uImage] Error 1
make: *** [uImage] Error 2

I gave 0x80008000 as a value, because that's what mkimage reported when building 3.8 like in the guide. I don't understand more than that as far as that goes.

I did get HDMI output just like in Arch, but I did not have the time to test it any further.
IMO the problem was a bug in the 3.8 kernel, I got a warning about a recursive dependency (concerning dri and fb if I remember correctly), but I did not save the output. I'll try to find it again later.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum