Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with Nouveau/Nvidia on laptop [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Andrew-
n00b
n00b


Joined: 28 Oct 2013
Posts: 2

PostPosted: Tue Oct 29, 2013 12:41 am    Post subject: Problem with Nouveau/Nvidia on laptop [Solved] Reply with quote

So far the only driver I've been able to get to work on this is the VESA would like to have either Nouveau or Nvidia working.

With the Nvidia driver I end up with a blank screen.

In both cases make.conf VIDEO_CARDS is set to nouveau or nvidia as the case may be.

Trying not to paste too much in, but if more would help just let me know.

Code:

01:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 750M] (rev a1)
   Subsystem: Micro-Star International Co., Ltd. Device 10e7
   Kernel modules: nvidia


Obviously the kernel module changes depending on which I'm trying at the time.

Nouveau: 1.0.9

Xorg.0.log

Code:

[   725.697] (II) LoadModule: "nouveau"
[   725.698] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[   725.698] (II) Module nouveau: vendor="X.Org Foundation"
[   725.698]    compiled for 1.14.3, module version = 1.0.9
[   725.698]    Module class: X.Org Video Driver
[   725.698]    ABI class: X.Org Video Driver, version 14.1
[   725.698] (II) NOUVEAU driver
[   725.698] (II) NOUVEAU driver for NVIDIA chipset families :
[   725.698]    RIVA TNT        (NV04)
[   725.698]    RIVA TNT2       (NV05)
[   725.698]    GeForce 256     (NV10)
[   725.698]    GeForce 2       (NV11, NV15)
[   725.698]    GeForce 4MX     (NV17, NV18)
[   725.698]    GeForce 3       (NV20)
[   725.698]    GeForce 4Ti     (NV25, NV28)
[   725.698]    GeForce FX      (NV3x)
[   725.698]    GeForce 6       (NV4x)
[   725.698]    GeForce 7       (G7x)
[   725.698]    GeForce 8       (G8x)
[   725.698]    GeForce GTX 200 (NVA0)
[   725.698]    GeForce GTX 400 (NVC0)
[   725.698] (--) using VT number 7

[   725.701] (EE) [drm] KMS not enabled
[   725.701] (EE) No devices detected.
[   725.701] (EE)
Fatal server error:
[   725.701] (EE) no screens found(EE)
[   725.701] (EE)


xorg.conf

Code:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nouveau"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:1:0:0"

EndSection


Nvidia: 331.17

xorg.0.log

Code:

[    53.405] (II) NVIDIA GLX Module  331.17  Thu Oct 17 09:30:48 PDT 2013
[    53.412] Loading extension GLX
[    53.412] (II) LoadModule: "nvidia"
[    53.412] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[    53.478] (II) Module nvidia: vendor="NVIDIA Corporation"
[    53.478]    compiled for 4.0.2, module version = 1.0.0
[    53.478]    Module class: X.Org Video Driver
[    53.488] (II) NVIDIA dlloader X Driver  331.17  Thu Oct 17 09:11:05 PDT 2013
[    53.488] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    53.488] (--) using VT number 7

[    53.501] (II) Loading sub module "fb"
[    53.501] (II) LoadModule: "fb"
[    53.501] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    53.509] (II) Module fb: vendor="X.Org Foundation"
[    53.509]    compiled for 1.14.3, module version = 1.0.0
[    53.509]    ABI class: X.Org ANSI C Emulation, version 0.4
[    53.509] (WW) Unresolved symbol: fbGetGCPrivateKey
[    53.509] (II) Loading sub module "wfb"
[    53.509] (II) LoadModule: "wfb"
[    53.509] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[    53.514] (II) Module wfb: vendor="X.Org Foundation"
[    53.514]    compiled for 1.14.3, module version = 1.0.0
[    53.514]    ABI class: X.Org ANSI C Emulation, version 0.4
[    53.514] (II) Loading sub module "ramdac"
[    53.514] (II) LoadModule: "ramdac"
[    53.514] (II) Module "ramdac" already built-in
[    53.683] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    53.683] (==) NVIDIA(0): RGB weight 888
[    53.683] (==) NVIDIA(0): Default visual is TrueColor
[    53.683] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    53.683] (**) NVIDIA(0): Enabling 2D acceleration
[    54.310] (II) NVIDIA(0): NVIDIA GPU GeForce GT 750M (GK107) at PCI:1:0:0 (GPU-0)
[    54.310] (--) NVIDIA(0): Memory: 2097152 kBytes
[    54.310] (--) NVIDIA(0): VideoBIOS: 80.07.a2.00.05
[    54.310] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    54.310] (--) NVIDIA(0): Valid display device(s) on GeForce GT 750M at PCI:1:0:0
[    54.310] (--) NVIDIA(0):     none
[    54.310] (II) NVIDIA(0): Validated MetaModes:
[    54.310] (II) NVIDIA(0):     "NULL"
[    54.310] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[    54.310] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[    54.310] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[    54.310] (--) Depth 24 pixmap format is 32 bpp
[    54.310] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[    54.310] (II) NVIDIA:     access.
[    54.312] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[    54.312] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[    54.312] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[    54.312] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[    54.312] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[    54.312] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[    54.312] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[    54.312] (II) NVIDIA(0):     Config Options in the README.
[    54.312] (II) NVIDIA(0): Setting mode "NULL"
[    54.312] (EE) NVIDIA(0): Failed to initiate mode change.
[    54.312] (EE) NVIDIA(0): Failed to complete mode change
[    54.319] (II) NVIDIA(0): Built-in logo is bigger than the screen.
[    54.319] Loading extension NV-GLX
[    54.387] (==) NVIDIA(0): Disabling shared memory pixmaps
[    54.387] (==) NVIDIA(0): Backing store disabled
[    54.387] (==) NVIDIA(0): Silken mouse enabled
[    54.390] (**) NVIDIA(0): DPMS enabled
[    54.390] Loading extension NV-CONTROL
[    54.390] (II) Loading sub module "dri2"
[    54.390] (II) LoadModule: "dri2"
[    54.390] (II) Module "dri2" already built-in
[    54.390] (II) NVIDIA(0): [DRI2] Setup complete
[    54.390] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    54.390] (--) RandR disabled
[    54.394] (II) Initializing extension GLX


With the Nvidia created xorg.conf it can't even find the card, had to add the BusID to it. It gets the sync frequencies wrong.

Have tried putting in the proper sync frequencies and even a modeline, didn't help.


Last edited by Andrew- on Tue Oct 29, 2013 9:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1406

PostPosted: Tue Oct 29, 2013 3:34 pm    Post subject: Reply with quote

Is your laptop Optimus Based :?: If so, see No device detected while startx?
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
Andrew-
n00b
n00b


Joined: 28 Oct 2013
Posts: 2

PostPosted: Tue Oct 29, 2013 9:04 pm    Post subject: Reply with quote

eyoung100 wrote:
Is your laptop Optimus Based :?: If so, see No device detected while startx?


Yup, that was it. Thanks.

Took a lot of messing around (ran into another problem but got that one fixed).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum